Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

Plugin for coupon database doesn't work correctly


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Sep 15, 2011, 06:51 AM
thextremetime
 
7 posts · Aug 2011
Hello, first of all give thanks for the great support you give to all members of this forum.
You have been very helpful so far to make all necessary changes in my blog.

My problem is this:
I am building a blog coupons and I've installed a plugin to create a database of coupons. The installation was successful, the problem is that when you perform a search for some coupons in the search results says "coupons not found".

I changed the default theme and here it shows coupons, correctly.

It's super weird that some coupons aren't showing up and other yes.

I consulted the author of plugin and have made appropriate checks to see that the plugin is correctly installed and he told me that probably something interferes with the plugin.
I'm going crazy, since the only plugin I have installed is this and I've changed the default template and everything works fine.

The coupondatabase is here

Any idea, please?

Thank you.
  #2  
Old Sep 15, 2011, 07:00 AM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
The first thing to do would be to apply ALL the Atahutalpa 3.6.7 patches as they affect areas other than those mentioned in the titles.
  • PATCH 367-01: Odd effects when 'CSS: Compress' = 'Yes'
  • PATCH 367-02 is incorporated in PATCH 367-04
  • PATCH 367-03: PHP errors when adding widget areas in index.php
  • PATCH 367-04: Hovering over a Post/Page title only shows "Permanent Link to"
  • PATCH 367-05: Site Title appended after the 'WordPress SEO by Yoast' title
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Sep 15, 2011, 08:24 AM
thextremetime
 
7 posts · Aug 2011
lmilesw thank you for your answer.

I followed your instructions and I installed the necessary patches.
Something I have advanced, the coupons are shown but if I do the following:
Choose a source, for example: Allure, September.
To display the coupons I first click on "Link to Search", nothing comes up then repeat the search again and click on "Search".

So yes you can view the coupons.
What I don't understand is why in some I have to do this crossword puzzle and not in others.
It is possible that something is interfering with the search function?

Any ideas please?

Thank you.
  #4  
Old Sep 15, 2011, 08:36 AM
juggledad's Avatar
juggledad
 
22,322 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
what do you mean by
Quote:
Choose a source, for example: Allure, September.
I don't see where to 'pick' anything

are you using a plugin for the database? What is it? if not where did you get it?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Sep 15, 2011, 09:01 AM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
I see what you are talking about in the advanced search function and I too had to do what you did to see the entries for Allure September but the way they have there search set up is unclear to me. What is "Link to search"? What is the plugin?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Sep 15, 2011, 09:11 AM
thextremetime
 
7 posts · Aug 2011
This is the page where I have installed the database.

I've installed the plugin: dsmcouponsclient-1.0.15. I've purchased on this page. They have the same database.

What I say: "Choose a source, for example: Allure, September".
When you try to search for a coupon, from my coupon database:
Click on "advanced search" and there is a box. If you choose "source" there is a list of coupons available. If for example I choose "Allure, September" to display the coupons I first click on "Link to Search", nothing comes up. Then repeat the search again and click on "Search". So Yes You Can view the coupons.

The problem is that the coupons would be enough to see to click on "Search"

You can see how the database works here.

I apologize if my English is not very good, and maybe I'm not explaining very well.
Anyway, thank you very much for your help and for your interest.
  #7  
Old Sep 15, 2011, 09:44 AM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
Without having the plugin to test. I am not sure what to tell you. Based on what you said it has something to do with the way the plugin works with Atahualpa but it is difficult to determine whether that is because there is an issue with the Theme or the plugin has some code that is non standard.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #8  
Old Sep 15, 2011, 09:58 AM
thextremetime
 
7 posts · Aug 2011
Thanks for your answer.
I'm starting to think I've thrown the money it has cost me the plugin to the trash.
As a last resort...
How can I test the plugin?
Thank you.
  #9  
Old Sep 15, 2011, 10:55 AM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
It is just a matter of going through some configuration changes such as...
  • Deactivate ALL other plugins and test. If you still have the issue reactivate all the plugins.
  • Look at the setting of the plugin and make an educated guess at what might be an issue and try different settings.
  • Try different settings in Atahualpa
Also while looking at your site I tried clicking on Archives and got a very badly configured page which leads me to believe there is something going on with your installation.

Did you make any changes to the theme files? Is the CSS in CSS Inserts formatted correctly? You also have a Coupons button in the center top. What is that?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #10  
Old Sep 15, 2011, 12:01 PM
thextremetime
 
7 posts · Aug 2011
Once again, thanks for your help.

I followed all your instructions and I can't find the solution.
I think I'm ready to give up and install everything again from scratch.
Fifteen working days away.
You ask me if I made changes to css inserts. Yes, I put these lines to format the page menu bars and categories menu bar and for a button with the date beside the title.

div#menu1 {
border: none;
background:transparent;
}
div#menu1 ul.rMenu {
background:transparent;
}
div#menu1 ul.rMenu li {
background:transparent;
margin: 0px 0 0px 10px;
-webkit-border-top-left-radius: 15px;
-webkit-border-top-right-radius: 15px;
-moz-border-radius-topleft: 15px;
-moz-border-radius-topright: 15px;
border-top-left-radius: 15px;
border-top-right-radius: 15px;
-webkit-border-bottom-left-radius: 15px;
-webkit-border-bottom-right-radius: 15px;
-moz-border-radius-bottomleft: 15px;
-moz-border-radius-bottomright: 15px;
border-bottom-left-radius: 15px;
border-bottom-right-radius: 15px;
box-shadow: 0 3px 10px #ca7900; -moz-box-shadow: 0 3px 10px #ca7900;
}

div#menu2 {
border: none;
background: transparent;
}
div#menu2 ul.rMenu {
background:transparent;
}
ul.rMenu li, div#menu2 ul.rMenu li a {
margin: 0px 0 0px 10px;
-webkit-border-top-left-radius: 11px;
-webkit-border-top-right-radius: 11px;
-moz-border-radius-topleft: 11px;
-moz-border-radius-topright: 11px;
border-top-left-radius: 11px;
border-top-right-radius: 11px;
-webkit-border-bottom-left-radius: 11px;
-webkit-border-bottom-right-radius: 11px;
-moz-border-radius-bottomleft: 11px;
-moz-border-radius-bottomright: 11px;
border-bottom-left-radius: 11px;
border-bottom-right-radius: 11px;
box-shadow: 0 1px 5px #ca7900; -moz-box-shadow: 0 1px 5px #ca7900;
}
td#left a:link,
td#left a:active,
td#left a:visited,
td#left a:hover {
color: #ffffff;
}
div.header-image-container { padding-top: 0px; height: 227px;
-moz-border-radius:16px;
-khtml-border-radius: 16px;
-webkit-border-radius:16px;
border-radius: 16px;
}
.date {
background: url(wp-content/themes/atahualpa367/images/icons/dateicon.png[/url]) repeat-x scroll top left;
-webkit-border-top-left-radius: 11px;
-webkit-border-top-right-radius: 11px;
-moz-border-radius-topleft: 11px;
-moz-border-radius-topright: 11px;
border-top-left-radius: 11px;
border-top-right-radius: 11px;
-webkit-border-bottom-left-radius: 11px;
-webkit-border-bottom-right-radius: 11px;
-moz-border-radius-bottomleft: 11px;
-moz-border-radius-bottomright: 11px;
border-bottom-left-radius: 11px;
border-bottom-right-radius: 11px;
display: inline;
float: left;
width:45px;
text-align:center;
vertical-align: middle;
color:#000033;
font-family:calisto MT, Helvetica, sans-serif;
font-size:9px;
font-weight:bold;
border: none
padding: 35px 10px 10px 35px;

}
.date-inside {
border:1px none #66001f;
padding:4px;
}
.date .date-day {
font-size:9px;
}

The middle button "coupons" is a category of test I did, because I'm still building the blog.
Also, I have been tested with the code and without it and the coupondatabase is having the same issues.
I risk and I install everything again starting from zero?
What I can do?
Thank you very much again.
  #11  
Old Sep 15, 2011, 01:01 PM
lmilesw's Avatar
lmilesw
 
10,108 posts · Jul 2009
Central New York State USA
I don't think this is a huge thing but there are a couple of thinks in the CSS that are highlighted in red. The first may just be how you copied into your post but shouldn't be there if it is. For the second one you need a semicolon after the line.
.date {
background: url(wp-content/themes/atahualpa367/images/icons/dateicon.png[/url]) repeat-x scroll top left;
-webkit-border-top-left-radius: 11px;
-webkit-border-top-right-radius: 11px;
-moz-border-radius-topleft: 11px;
-moz-border-radius-topright: 11px;
border-top-left-radius: 11px;
border-top-right-radius: 11px;
-webkit-border-bottom-left-radius: 11px;
-webkit-border-bottom-right-radius: 11px;
-moz-border-radius-bottomleft: 11px;
-moz-border-radius-bottomright: 11px;
border-bottom-left-radius: 11px;
border-bottom-right-radius: 11px;
display: inline;
float: left;
width:45px;
text-align:center;
vertical-align: middle;
color:#000033;
font-family:calisto MT, Helvetica, sans-serif;
font-size:9px;
font-weight:bold;
border: none
padding: 35px 10px 10px 35px;
}
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #12  
Old Sep 15, 2011, 01:29 PM
thextremetime
 
7 posts · Aug 2011
Yes, the first is a failure as copied.
But in the second, if I put the semicolon, the date icon appears that way.
Without the semicolon it shows ok.
I apologize for all this trouble. I really feel quite clumsy and lost at this time.
  #13  
Old Sep 15, 2011, 06:34 PM
thextremetime
 
7 posts · Aug 2011
Ok, I've deleted all my database and I will install again from zero.
Thank you very much for your help.
You're the best.
  #14  
Old Nov 22, 2011, 08:27 AM
spanthegnome
 
1 posts · Nov 2011
Where did you get the coupon database. I am looking to do a local coupon blog in my town.
  #15  
Old Nov 22, 2011, 08:54 AM
juggledad's Avatar
juggledad
 
22,322 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
did you read the posts on this thread?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
If a plugin doesn't work try this: Flynn Plugins & Atahualpa 10 Sep 27, 2013 04:08 AM
[SOLVED] RSS/Comments feature in header does not work due to database upload problem alfie RSS, Feeds & Subscribing 7 Dec 25, 2010 01:01 PM
How to get those thumbnails to work correctly vbskss Excerpts, Read more, Pagination 2 May 14, 2010 01:21 PM
Can't get Autoviewer plugin to work jeffhuntphoto Plugins & Atahualpa 4 Apr 19, 2010 03:14 AM
Registy Plus Plugin - How to make it work? Craig Mattice Plugins & Atahualpa 2 Nov 2, 2009 12:26 PM


All times are GMT -6. The time now is 05:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.