Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Excerpts, Read more, Pagination »

Can't get "more" tag to function


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Oct 18, 2009, 10:19 AM
mathmojo
 
21 posts · Oct 2009
Hi.

I'm using 3.4.4 on WP 2.8.4 and I can't get the "read more" function to work.
My site is http://mathmojo.com/chronicles

I have inserted:
Read the rest →
in the Atahualpa settings, and inserted the <!--more--> code into the html on my posts, but the entire posts appear on the home page.

What am I doing wrong?

Thanks for your help. I love your theme. If this gets solved, I will make a donation.

Yours truly,

Brian (a.k.a. Professor Homunculus at MathMojo.com/chronicles )
  #2  
Old Oct 18, 2009, 12:21 PM
juggledad's Avatar
juggledad
 
22,379 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Where did you put the <!-- more --> in the first post?
What have you got set at ATO->Configure EXCERPTS->Posts or excerpts on HOME page?
and Show the first X posts on HOME page as full posts?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Oct 18, 2009, 02:10 PM
mathmojo
 
21 posts · Oct 2009
The excerpts is set to full post. I tried using 'excerpt only' but that chopped all of the posts off at 55 words, which isn't what I'm looking for.

I put the more tag on the first post right after the paragraph which reads
Commonly, someone I am helping will ask, " But what if we are not allowed to do it that way?" Recently someone wrote in:
I have "0" set for "Show the first X posts on HOME page as full posts?"
  #4  
Old Oct 18, 2009, 02:48 PM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
The Custom Excerpts plugin does a nice job.
  #5  
Old Oct 18, 2009, 03:27 PM
BradBrown's Avatar
BradBrown
 
54 posts · Mar 2009
The problem is your more tag is inside html <p> </p> tags. The more tag won't work if it's inside any HTML tags. Go into HTML mode in the editor and strip out the HTML around the <!--more-->.

-Brad
  #6  
Old Oct 18, 2009, 04:10 PM
mathmojo
 
21 posts · Oct 2009
Brad,

That was a noble try, but alas there's not a single <p> in the whole post. The only html is after the more tag. There is a <blockquote> tag in the post, but the more tag is not within it.

Thanks for the effort though. Any more thoughts?

Brian
  #7  
Old Oct 18, 2009, 05:10 PM
BradBrown's Avatar
BradBrown
 
54 posts · Mar 2009
There are LOTS of P tags. Every single paragraph in the post is wrapped in P tags. Go to your page in a browser and view the source. Below is an excerpt...

HTML Code:
<p>Commonly, someone I am helping will ask, ” But what if we are not allowed to do it that way?” Recently someone wrote in:</p>
<p><!--more--></p>
<blockquote><p>“I am fascinated with your approach to math but worry about teaching these kids differently from what their
The WordPress editor can be a bit tricky. When you switch to HTML mode, it hides the <p> tags and puts in blank lines. If you are typing out the more tag in the editor, be sure there are no blank lines before or after the tag. If you've done it correctly, when you go back into visual mode, you'll see a horizontal line at the break point.

It may be easier for you to use the more button in visual mode rather than typing it out. Just put the cursor where you want the break and click the more button at the top of the editor window. (It's the button right before the spell check button.) It will put the more tag in correctly.

-Brad
  #8  
Old Oct 18, 2009, 05:27 PM
mathmojo
 
21 posts · Oct 2009
Brad,

Thanks so much. I didn't know that about the html editor in WP. That's a great hint. I'm going to go fix this now.

Brian
  #9  
Old Oct 18, 2009, 07:55 PM
mathmojo
 
21 posts · Oct 2009
Brad,
I think I'm getting closer. I took out the bracketing <p></p> tags from around the <!--more--> tag, and I can see the little horizontal "more" bar in the visual editor, but no I still can't get it to function.

No matter what I do, the </br> tag shows up behind the more tag. Does this have anything to do with this?

I think I may be beginning to see the light, but I'm not sure. Do you know a good way of stripping out all the paragraph tags but still keeping the spaces? Is that the ticket?
  #10  
Old Oct 18, 2009, 09:54 PM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Sorry for not reading more closely. The Custom Excerpts plugin, http://wordpress.org/extend/plugins/custom-excerpts/, is indeed useful, but not exactly what you were asking about.

Perhaps what's happening is that if you set the theme to show a full post on the front page, that over-rides your desire to split the page into 2. I'm just guessing here.

You could use the Custom Excerpts plugin, actually, and set the theme options to show only excerpts on the front page, but then use the plugin to make them longer than 55 words.

Maybe Juggledad can explain the difference between the more and page split icons.

Last edited by paulae; Oct 18, 2009 at 10:24 PM.
  #11  
Old Oct 19, 2009, 06:03 AM
juggledad's Avatar
juggledad
 
22,379 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
if you want to know about excerpts and readmore see http://forum.bytesforall.com/showthread.php?t=2708 post #14
-------------------------
Ok I just copied your text with the read more and tested it on a new install, and it worked as expected. So there must be some setting you have that is causing what you see. So to verify:

1) you are using the HTML editor
2) you have no html in the post, only the <blockquote> and <!--more--> shortcodes
3) at ATO->"Read More" tag->Read More - you have 'Read the rest &rarr;'
4) at ATO->Configure EXCERPTS - you have everything set to the defaults
5) you have tried this with ALL plugins deactivated
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Nov 6, 2009 at 09:32 AM.
  #12  
Old May 16, 2010, 11:48 PM
mathmojo
 
21 posts · Oct 2009
Finally took your advice about disabling all plugins. On a slow, satellite connection, it was a major pain in the butt, but it bore fruit.

The culprit was one of my favorite plugins, FasterIM Opt-in.

I'm going to have to figure out the bug, because I love that plugin.

Thanks for your help.

B
  #13  
Old May 17, 2010, 06:45 AM
mathmojo
 
21 posts · Oct 2009
Finally fixed it with the new version of FasterIM opt-in plugin.

All is well in Math Mojo Land.

Bookmarks

Tags
more tag

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to post on 2 seperate "Pages" or "Cats" TPR Atahualpa 3 Wordpress theme 18 Aug 4, 2010 09:24 PM
How to remove the "no follow" meta tag toksrha Header configuration & styling 1 Aug 31, 2009 08:56 AM
Hiding "Blogroll" and "Meta" titles nige Sidebars & Widgets 1 Jul 21, 2009 01:13 AM
Atahualpa 3.4: no "title" Tag anymore - with wpSEO 2.7.5 chris New Versions, & Updating 4 Jul 11, 2009 12:31 PM
"more" tag not working on some posts joe hark Atahualpa 3 Wordpress theme 2 Mar 21, 2009 12:38 PM


All times are GMT -6. The time now is 11:13 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.