Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Installation/Upgrade Issues »

PHP 7 compatibility?


  #1  
Old Jan 29, 2018, 02:04 PM
bswb97
 
158 posts · Aug 2010
I have a number of legacy sites running on Atahualpa. One old client host pinged them and they got this error

[Sun Jan 28 19:56:51.328131 2018] [proxy_fcgi:error] [pid 29150:tid 140100390336256] [client 37.233.27.142:47228] AH01071: Got error 'PHP message: PHP Warning: A non-numeric value encountered in/wp-content/themes/atahualpa/css.php on line 137\nPHP message: PHP Warning: A non-numeric value encountered in /home/www/whphx12/writersinthestormblog.com/htdocs/wp-content/themes/atahualpa/css.php on line 138\n'

I also ran a checker plugin and it detected these issues:

FILE: /wp-content/themes/atahualpa/functions/JSON.php
----------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
----------------------------------------------------------------------------------------------
133 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
783 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
797 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
----------------------------------------------------------------------------------------------

As I work more on the CSS/HTML end, are any of these catastrophic issues? I have a new tool that I use that is even more flexible than Atahualpa, and it's not terribly hard to convert but I wasn't sure if this would even require any tinkering or conversion.
  #2  
Old Jan 29, 2018, 06:51 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I'm running PHP V7.0.27 on my site and I don't see any errors. and looking at css.php I don't see any problems with those two lines but it is possible. Could you export his Atahualpa settings and attach them to an reply.

Also what version of Atahualpa?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 29, 2018, 08:45 PM
bswb97
 
158 posts · Aug 2010
I've attached the export file.

It's running 3.7.24 and WP 4.9.2.
Attached Files
File Type: txt ata-writersinthestormblogcom-20180130.txt (18.4 KB, 35 views)
  #4  
Old Jan 30, 2018, 06:45 AM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I just imported the settings and I don't see those messages. This may mean there is a plugin issue.

Temporarily disable all plugins and see if the issue still occurs. If it doesn't then add a couple plugins in at a time and test till you isolate the one causing the conflict.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jan 30, 2018, 05:01 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
For the second issue if you can, rename the atahualpa/functions/json.php file to json.old and see if you see any issues.

That file is a simple encoder/decoder for JSON but JSON is part of PHP now, so I don't think it is needed anymore. In my simple test of removing the file, I did not see any issues.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jan 31, 2018 at 02:51 PM.
  #6  
Old Jan 31, 2018, 01:33 PM
bswb97
 
158 posts · Aug 2010
Since JSON is now built into PHP 7, is the file essentially a benign redundant? Will it harm anything if it's just kept in?

Also, can the fix you've identified be patched into the file, like an unofficial 3.7.24.1?
  #7  
Old Jan 31, 2018, 02:54 PM
juggledad's Avatar
juggledad
 
23,627 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
All you need to do is rename the file or delete it and you have your patched 3.7.24.1
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Tags
php7

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP 7 compatibility jlbo New Versions, & Updating 3 Nov 20, 2016 01:58 PM
datafeedr compatibility bigliettaio Plugins & Atahualpa 2 Oct 9, 2014 03:50 AM
Compatibility with Simplviewer rickpm Atahualpa 3 Wordpress theme 5 Jun 16, 2011 02:21 PM
Compatibility with wordpress MU quixysfrance New Versions, & Updating 4 Aug 3, 2010 06:16 AM


All times are GMT -6. The time now is 06:36 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.