Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Installation/Upgrade Issues »

php 7.3 issue


  #1  
Old Feb 26, 2020, 12:57 PM
lifeingalicia
 
8 posts · Jan 2010
Rural Galicia Spain
Hi
the site is on 3.7.8 Atahulpa - switching on php 7.3 had some surprises.
Yes some plugins failed - not surprising but I did get

Warning: Use of undefined constant https - assumed 'https' (this will throw an Error in a future version of PHP) in /home/www/xxxxxxxxxxx/public_html/wp-content/themes/atahualpa/functions.php on line 920

Warning: Use of undefined constant ‘init’ - assumed '‘init’' (this will throw an Error in a future version of PHP) in /home/www/xxxxxxxxxx/public_html/wp-content/themes/atahualpa/functions.php on line 1092

Not sure what this is about - quick tip would be great
Site fails to load but that is probably due to the failing plugins
Thanks


PS failing plugins
Warning: Use of undefined constant ‘wp_disable_emojis’ - assumed '‘wp_disable_emojis’' (this will throw an Error in a future version of PHP) in /home/www/xxxxxxx/public_html/wp-content/themes/atahualpa/functions.php on line 1092

Warning: Cannot modify header information - headers already sent by (output started at /home/wwwxxxxxx/public_html/wp-config.php:30) in /home/www/annachampeney/usuarios/textilesnaturales/public_html/wp-includes/pluggable.php on line 1219
  #2  
Old Feb 26, 2020, 03:28 PM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Wait, you are using 3.7.8 which was released in 2012??

the last version of Atahualpa is 3.7.24 some 16 releases later than the one you have. Are you still using a WordPress release from 2012 too?

Back up your site (all files and the database)
Restore it to a test location
Update Atahualpa
see if the issue still exists.

If it does, disable all plugins and see if the issue still exists.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Feb 27, 2020, 06:20 AM
lifeingalicia
 
8 posts · Jan 2010
Rural Galicia Spain
Hi
thanks for your reply .8 - .24 major updates? Well the modified codebase works well on 4.99 5.3 and php 7 so brilliant coding in the first place.... I might just suppress the warnings and do an upgrade at a later date.
Thanks anyway Martin
  #4  
Old Feb 28, 2020, 03:44 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
You should be aware that there will be no more updates of Atahualpa.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd CSS issue Sven Atahualpa 3 Wordpress theme 7 Nov 10, 2011 06:28 AM
[SOLVED] Can't edit posts - edits vanish - Virus? Theme Issue? WP Issue? jfrenaye Atahualpa 3 Wordpress theme 1 Aug 4, 2009 07:14 AM


All times are GMT -6. The time now is 04:16 AM.


Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.