Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Strange problem with Search widget and international characters


  #1  
Old Jun 9, 2016, 12:28 AM
Jerry_Q4d
 
22 posts · Apr 2014
Hi people! I have encountered a strange issue with the Wordpress search widget. I have noticed that the first - but only the first - search you do with it using international characters - German umlauts in my case - fails because of an encoding problem.

For example, if you search for "Gre" with an in it, no search results are found because the search resolves in the address bar of the browser to:

/?s=Grö%C2%9Fe&submit.x=0&submit.y=0

If you then enter it again it resolves to

/?s=Gre&submit.x=0&submit.y=0

and the search works.

If you revisit later - presumably when your browser cache is cleared - the problem occurs again. Any ideas what this could be? It does not occur if I switch to the Wordpress twenty fourteen theme.
  #2  
Old Jun 9, 2016, 02:57 AM
juggledad's Avatar
juggledad
 
23,520 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what happens if you temporally disable ALL plugins?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jun 11, 2016, 05:14 AM
Jerry_Q4d
 
22 posts · Apr 2014
Well.. what happens after I finally do my homework :-) You are right of course. It turns out that the culprit is the LaterPay Plugin: https://srd.wordpress.org/plugins/laterpay/
With it the first attempt goes wrong, the second one works. I have notified the programmer, I guess it is something on his end to fix.
Happens with Atahualpa and WP standard themes.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Strange Characters Showing up on pages - GOWeb2point0 New Versions, & Updating 4 Mar 21, 2013 01:05 PM
wrong accented characters shown inside search results Pillozzo Atahualpa 3 Wordpress theme 1 Feb 20, 2011 05:36 AM
Strange behaviour on search results title justshopandgive Atahualpa 3 Wordpress theme 7 Aug 26, 2010 12:01 PM
[SOLVED] Strange problem with PHP Code plugin widget paulae Plugins & Atahualpa 5 Oct 1, 2009 09:43 AM
Widget style causing ugly display of widget list, breaks at special characters wfzimmerman Sidebars & Widgets 1 Mar 20, 2009 03:31 PM


All times are GMT -6. The time now is 10:45 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.