Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

wrong accented characters shown inside search results


  #1  
Old Feb 14, 2011, 06:32 AM
Pillozzo
 
1 posts · Feb 2011
I am using the 3.6.1 version of Atahualpa in WP 3.0.5.; db charset is utf8_general_ci.
When the "" character (ANSI 224) is contained in an article:

- if you search (in the default WP search box) just for the "" character (or for a word including it) search returns nothing.;
- if you search for another word included in the same page than "", it returns a question mark instead of each "" character present inside the shown text.

Please note that this behaviour is shown only in Atahualpa.

I solved this problem replacing all occurrences of

"preg_split("/\s+/"

with

"preg_split("/\s+/u"

in the code inside "functions.php", particularly in "function bfa_wp_trim_excerpt($text)".
  #2  
Old Feb 20, 2011, 05:36 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Thanks, added for 3.6.5

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Search Results kpkes@yahoo.com Center area post/pages 4 Jul 16, 2012 02:57 AM
Template for search results kjetil Center area post/pages 1 Jun 14, 2010 04:06 AM
Links to post from Google search are wrong kmagyarics Post-Kicker, -Byline & -Footer 2 Nov 23, 2009 08:20 AM


All times are GMT -6. The time now is 12:08 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.