Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] UTF8 Character Error


  #1  
Old Feb 2, 2014, 01:38 AM
darwin8's Avatar
darwin8
 
12 posts · Jan 2010
Oahu, Hawaii
Send a message via Skype™ to darwin8
Have just upgraded a site to current versions, WordPress 3.8.1, and Atahualpa 3.7.13

In Body, Text & Links > Body Style, the following now appears:

<br />
<b>Warning</b>: htmlspecialchars() [<a href='function.htmlspecialchars'>function.htmlspec ialchars</a>]: charset `utf8_general_ci' not supported, assuming iso-8859-1 in <b>/home/harmony/public_html/content/wp-includes/formatting.php</b> on line <b>3019</b><br />
<br />
font-family: "Palatino", "Georgia", "Times New Roman", "Times", serif;
font-size: 1.0em;
line-height: 1.4em;
color: #ebebeb;
background: url(/content/wp-content/ata-images/background.jpg) repeat top left;
padding-top: 10px; padding-bottom: 10px;


Those first lines, between the <br /> tags, are being added. Deleting them and saving the options has no effect; they automatically come back when I view this page again.

The website: http://www.americachinabridge.com

Things to consider:

1. I have not modified formatting.php, so the standard WP file is functioning. No other WP files, or Ata files, have been modified, they are all standard-issue.

2. This site uses WPML to manage multiple languages, in this case English and Mandarin Chinese. WPML is fully upgraded, to the current version, 2.8.1

3. In the MySQL database encoding, PHPMyAdmin reports Server connection collation as utf8_general_ci - which has always worked fine with the Atahualpa and WP combo.

4. Note also that Chinese language characters being interpreted through the theme, like the blog title and subtitle, are being shown as ASCII garbage; see the header area on any page of http://www.americachinabridge.com, and the language switcher widget on the right sidebar.

What is happening here? Please help.
  #2  
Old Feb 2, 2014, 04:58 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what happens it you disable the MPML plugin?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Feb 2, 2014, 12:18 PM
darwin8's Avatar
darwin8
 
12 posts · Jan 2010
Oahu, Hawaii
Send a message via Skype™ to darwin8
Disabling WPML: results in no Chinese language display at all. Removes the problem, of course, but defeats the purpose of the website.

I have other sites with the same configuration, same versions etc., that are functioning fine. For example, compare http://www.chinaroyalties.com (OK) with the subject site, http://www.americachinabridge.com (not OK).

Can you tell what's happening in that formatting.php file, line 3019, that's causing Ata to write the error message?

The same error message is also being written into many other Ata fields that allow formatted text, including Style and Configure LAYOUT > Layout Container Style; Style and Edit HEADER AREA (all sections).

This error message is also repeated multiple times on the Edit screen of every Page. See attached screen shot, editing the Home page.

Your assistance sincerely appreciated...

Michael
Attached Thumbnails
Click image for larger version

Name:	bridge-screenshot.jpg
Views:	325
Size:	138.0 KB
ID:	2485  
  #4  
Old Feb 3, 2014, 07:17 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Go to ato->style & edit header and hit the save at the bottom
Do the same for the center area and footer and see what happens
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Feb 3, 2014, 11:51 PM
darwin8's Avatar
darwin8
 
12 posts · Jan 2010
Oahu, Hawaii
Send a message via Skype™ to darwin8
Go to ato->style & edit header and hit the save at the bottom

Result: now there are two identicalerror messages inserted. The first, Header Area, now contains:

<br />
<b>Warning</b>: htmlspecialchars() [<a href='function.htmlspecialchars'>function.htmlspec ialchars</a>]: charset `utf8_general_ci' not supported, assuming iso-8859-1 in <b>/home/harmony/public_html/content/wp-includes/formatting.php</b> on line <b>3019</b><br />
<br />
<b>Warning</b>: htmlspecialchars() [<a href='function.htmlspecialchars'>function.htmlspec ialchars</a>]: charset `utf8_general_ci' not supported, assuming iso-8859-1 in <b>/home/harmony/public_html/content/wp-includes/formatting.php</b> on line <b>3019</b><br />
%page-center %logo %bar1 %image %bar2

Same goes for the contents of Logo Area Styling, Logo Image Styling, Blog Title, Blog Tagline, Search Box, Horizontal Bar 1: Styling, and Horizontal Bar 2: Styling.

Do the same for the center area and footer and see what happens

This also duplicates the error message and inserts another, Center Column Style now contains:

<br />
<b>Warning</b>: htmlspecialchars() [<a href='function.htmlspecialchars'>function.htmlspec ialchars</a>]: charset `utf8_general_ci' not supported, assuming iso-8859-1 in <b>/home/harmony/public_html/content/wp-includes/formatting.php</b> on line <b>3019</b><br />
<br />
<b>Warning</b>: htmlspecialchars() [<a href='function.htmlspecialchars'>function.htmlspec ialchars</a>]: charset `utf8_general_ci' not supported, assuming iso-8859-1 in <b>/home/harmony/public_html/content/wp-includes/formatting.php</b> on line <b>3019</b><br />
border-bottom: solid 1px #cccccc;
padding: 10px 15px;

Same doubling of the error message for Center Column Top Widget Area, Center Column Bottom Widget Area; all now contain two error messages.

Before doing the steps you recommended, in each case above there was one error message. Now there are two.

The site is now behaving worse than earlier reported, as the error messages are now being dumped onto the web pages themselves; see http://www.americachinabridge.com

A number of other formatting errors, too numerous to explain, have now showed up; the site is essentially useless now.

The error messages cannot be removed.
  #6  
Old Feb 4, 2014, 04:43 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
if you send me a PM with an admin ID/pw I'll take a peek
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Feb 4, 2014, 12:06 PM
darwin8's Avatar
darwin8
 
12 posts · Jan 2010
Oahu, Hawaii
Send a message via Skype™ to darwin8
On its way now...thank you.
  #8  
Old Feb 4, 2014, 07:37 PM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
please try this
1) backup the site
2) download the following file
3) open the file in a TEXT editor
4) copy the contents
5) go to ATO->Export/Import Settings and paces the copied text into the 'Import Atahualpa settings' option
6) hit save
7) go back and look at the 'Configure Header Area' option
8) make a change and save it and see what it looks like.
Attached Files
File Type: txt ata-1921684899-20140205-3.txt (16.7 KB, 345 views)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Feb 4, 2014 at 07:40 PM.
  #9  
Old Feb 5, 2014, 01:37 AM
darwin8's Avatar
darwin8
 
12 posts · Jan 2010
Oahu, Hawaii
Send a message via Skype™ to darwin8
Followed your instructions, everything went fine.
Made a change in the HEADER as you suggested -- deleted the two error messages, and saved.

Came back with one error message in the field edited.

All the other fields had an additional error message now.

Tried a couple of different changes, and each time an additional error message was incremented to all fields.

No change in the behavior of the website, still unuseable. This site has nearly three years worth of work in it. I have a backup, and can restore back to where there was no problem. This would take ATA back many revs.
  #10  
Old Feb 5, 2014, 05:31 AM
juggledad's Avatar
juggledad
 
23,576 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Duh…it pays attention to read the error message (head slap)
HTML Code:
 ...charset `utf8_general_ci' not supported, assuming iso-8859-1...
So I went to dashboard->settings->reading->Encoding for pages and feeds and changed the value from `utf8_general_ci' to 'iso-8859-1' and when you change things, the error is not happening.

Re Import the setting file I sent you and test again.

what is odd is that option was removed in WP 3.5.0….

UPDATE: I changed that option to UTF-8 and now it is gone. Looks like that was the issue…a wordpress change/holdover.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Feb 5, 2014 at 05:37 AM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Character set in a meta tag - an Atahualpa problem? Fux Atahualpa 3 Wordpress theme 2 May 3, 2013 01:54 AM
Post title character limiter burnhamg Atahualpa 3 Wordpress theme 2 Mar 5, 2012 05:19 AM
Changing the drop down character on page menu bar SherylCPA Page & Category Menu Bars 6 Jun 16, 2011 12:00 AM
Atahualpa 3.4.2 bug - html entities instead of UTF8 chars in meta fields pgc Atahualpa 3 Wordpress theme 5 Aug 13, 2009 10:14 AM


All times are GMT -6. The time now is 12:38 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.