Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

Help to update from 3.6.7 to current


  #1  
Old Feb 1, 2014, 12:07 PM
Gwodan
 
3 posts · Jun 2010
California
Hi,
I've got a site that I want to update form 3.6.7 to the current version - and then WP 3.3 to the current version.

What is the best way to do this with out losing my current theme formatting...

The site is http://yourcoffeecups.com

I am also interested in talking to someone about doing it for me.

Thanks,
  #2  
Old Feb 25, 2014, 10:41 AM
runnerb0y
 
67 posts · Nov 2010
Edit: After more research on this, you might first look at juggledad's post about this sort of thing...http://forum.bytesforall.com/showthread.php?t=21394

To do this right you need to
  • Backup your DataBase
  • Did I say backup your DataBase? If I forgot to mention it... BACKUP your DataBase!
  • Perform an export of the theme's settings (since these are kept in the database, I don't know if this is really necessary, but I always feel better knowing I've got that data too)
  • Backup your website's theme files - or at a minimum, backup any files you've added or customized
  • Upgrade your version of WordPress
  • Upgrade your version of Atahualpa - I MUCH prefer to do this manually, that way it's easier to recover if something goes nuts.
None of these steps are a guarantee everything will work out perfectly, there may be some additional 'tweaking' once the upgrades are performed. Some Plugins may or may not be compatible with the new version of WP or ATA, if that's the case, you'll have to go searching for replacements. This has happened to me a couple of times.

Depending upon what theme changes you made you may have some additional work within the Theme to get it to look exactly like your existing setup. I don't remember which version of ATA no longer allows PHP code in the 'Content ABOVE Loop' and 'The LOOP' options. I think that was back in 3.6.5 and if that's the case then you should not be affected by this since you're already running 3.6.7. Now that I think about it, I don't think it was an ATA 'issue', I think it was a WordPress requirement that no custom PHP code was allowed within the theme, but you can always modify the .PHP files directly (though you will have to remember to back them up if you upgrade).

I'd be very careful if you decide to have someone else do the upgrades for you. They will need access to your host back-end to perform proper backups. Once they are done (assuming they get it completed without issues), you would be well advised to change all your passwords associated with your hosting service, and database. juggledad and a few others on this site are highly capable of performing this upgrade for you but I don't know if they are wanting to assume the responsibility of that upgrade without compensation.

Last edited by runnerb0y; Feb 25, 2014 at 11:05 AM.

Bookmarks

Tags
update theme

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Display current taxonomy rlgold2 Center area post/pages 0 Jul 23, 2012 10:52 AM
next/previous - keep it to current category sirabi Excerpts, Read more, Pagination 14 Oct 1, 2010 09:02 AM


All times are GMT -6. The time now is 08:54 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.