Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

[SOLVED] Montezuma forces line breaks in some widgets


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Feb 13, 2013, 06:46 AM
ThomasCle
 
3 posts · Feb 2013
After installing Montezuma on my blog I've got some problems with my widgets. Some of them foces line breaks, where there aren't supposed to be line breaks.

The three icons in this widget used to be stading horizontally, but now they're standing vertically:


As you can see in the source of the widget, there are no <br />'s between the images.
HTML Code:
<aside id="socialprofiles-2" class="widget social-profiles cf">
<h3><span>Keep in touch!</span></h3>
<a href="http://www.cupcakecoding.com/feed/" target="_blank"><img src="http://www.cupcakecoding.com/wp-content/plugins/social-profiles-widget/images/inside/Feed_48x48.png" alt="RSS" /></a>
<a href="https://twitter.com/#!/ThomasCle" target="_blank"><img src="http://www.cupcakecoding.com/wp-content/plugins/social-profiles-widget/images/inside/Twitter_48x48.png" alt="Twitter" /></a>
<a href="https://www.facebook.com/tclemensen" target="_blank"><img src="http://www.cupcakecoding.com/wp-content/plugins/social-profiles-widget/images/inside/Facebook_48x48.png" alt="Facebook" /></a>
</aside>
What can I do to remove these line breaks?
  #2  
Old Feb 13, 2013, 07:30 AM
jerryc
 
367 posts · Oct 2012
Florida
There's a checkbox at the bottom of the text widget, if that's what you're using, that says automatically insert paragraphs. Be sure that's unchecked.

If that doesn't work, try doing a view source. There may still be automatic <p> tags being inserted. I can't tell if you have each item on it's own line in your source or if the wordwrap is just displaying them that way, and I can't tell if what you're calling your source code is what you put into the widget or what your browser gave you after the page displayed.

Another possible solution could be to force a display:inline; style to each <a> item.

I hope one of them work. If not, please post a url.
  #3  
Old Feb 13, 2013, 07:45 AM
ThomasCle
 
3 posts · Feb 2013
The code I posted in the first post is the code the browser shows me when I view the source code.

I'm using the Text widget, but the "Automatically add paragraphs"-checkbox is unchecked. This is the code I've pasted in the widget:
HTML Code:
<a href="http://www.cupcakecoding.com/feed/" target="_blank"><img src="http://www.cupcakecoding.com/wp-content/plugins/social-profiles-widget/images/inside/Feed_48x48.png" alt="RSS" /></a>
<a href="https://twitter.com/#!/ThomasCle" target="_blank"><img src="http://www.cupcakecoding.com/wp-content/plugins/social-profiles-widget/images/inside/Twitter_48x48.png" alt="Twitter" /></a>
<a href="https://www.facebook.com/tclemensen" target="_blank"><img src="http://www.cupcakecoding.com/wp-content/plugins/social-profiles-widget/images/inside/Facebook_48x48.png" alt="Facebook" /></a>
I have tried to insert style="display:inline;" on all three <a> as you suggested, but that didn't change anything.

The blog is at www.cupcakecoding.com (I also have a linebreak problem in my "Blogroll"-widget. Icons and site-title should be standing on same line.)

Any other suggestions? :-)
  #4  
Old Feb 13, 2013, 07:52 AM
juggledad's Avatar
juggledad
 
22,049 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
add
HTML Code:
div.textwidget {float: left;}
to the CSS
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Feb 13, 2013, 07:53 AM
jerryc
 
367 posts · Oct 2012
Florida
I did a firebug on your site, and your img tag are set to display:block. Try forcing them to inline and see if that doesn't do it. If an inline force works, you can change your stylesheet later, if you want.
  #6  
Old Feb 13, 2013, 08:01 AM
ThomasCle
 
3 posts · Feb 2013
Quote:
Originally Posted by jerryc
I did a firebug on your site, and your img tag are set to display:block. Try forcing them to inline and see if that doesn't do it. If an inline force works, you can change your stylesheet later, if you want.
Thank you! That did the trick. I set style="display:inline;" on the <img>

Bookmarks

Tags
line break, montezuma, widget

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Line spacing / Line breaks disappearing - Help! tastecheese Center area post/pages 0 Mar 22, 2011 05:45 AM
Can I use line breaks in my site name? Tim F Header configuration & styling 3 Jul 9, 2010 07:25 AM
Line breaks and page layouts mattfield Center area post/pages 1 Apr 21, 2010 06:58 PM
Extra line breaks and paragraph breaks in posts paulae New Versions, & Updating 2 Jan 27, 2010 03:20 PM
Some of my line breaks go away when published Jerry Atahualpa 3 Wordpress theme 3 Feb 27, 2009 02:01 PM


All times are GMT -6. The time now is 09:20 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.