Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

[SOLVED] Display full post instead of excerpt -need a little more help


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jan 2, 2013, 01:21 PM
RobinDenning
 
12 posts · Dec 2012
As was discussed in a few previous threads, the post excerpt is controlled by
<?php bfa_excerpt(); ?>
[Default. Same as <?php bfa_excerpt( 55, ' ...' ); ?>]

and I changed that in my postformat.php Sub Template to:
<?php get_content(); ?>

Unfortunately, it does not completely solve the problem. I am working on a localhost before introducing changes to my my live site at http://alittlesewing.com.

edited to add: it looks like there is a limit to how many images I can upload.
The next step I took was to remove this line from postformat.php:
<?php bfa_thumb( 620, 180, true, '<div class="thumb-shadow"><div class="post-thumb">', '</div></div>' ); ?>

and that removed the thumbnail from displaying.
At that point the blog is displaying the correct date with the title of the post, but no content is shown.

I have looked all through the information in the Montezuma Options, including the Limited PHP code.
Unless you have a specific recommendation, it seems my next step is to learn how to create a child page? What am I missing.
Thanks so much for guidance.
Attached Thumbnails
Click image for larger version

Name:	3.jpg
Views:	161
Size:	70.8 KB
ID:	2164  Click image for larger version

Name:	4.jpg
Views:	147
Size:	70.4 KB
ID:	2165  

Last edited by RobinDenning; Jan 5, 2013 at 01:09 PM.
  #2  
Old Jan 2, 2013, 03:12 PM
juggledad's Avatar
juggledad
 
22,097 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
for the moment use
HTML Code:
<?php bfa_excerpt( 99999, '' ); ?>
I'm looking into the issue with the_content()
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #3  
Old Jan 2, 2013, 03:46 PM
juggledad's Avatar
juggledad
 
22,097 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
never mind, that will strip all html from the posts...
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #4  
Old Jan 4, 2013, 07:07 AM
juggledad's Avatar
juggledad
 
22,097 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I have a possible fix. I haven't tested it in all conditions but if you would like to try it
edit 'montezuma/includes/parse_php.php' and change line 35 from
HTML Code:
		if (have_posts()) 
to
HTML Code:
		if (is_single() AND have_posts()) 
and give it a shot. - let me know if you find any issues.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Mar 4, 2013 at 07:42 PM.
  #5  
Old Jan 4, 2013, 10:35 AM
RobinDenning
 
12 posts · Dec 2012
Juggledad, I changed the HTML on line 35 of the parse_php.php file.

But now I have a different problem - when I use Text Wrangler to save it, it saves as a text file, not a PHP file. I am new to Text Wrangler, but can't find option to allow me to save as a PHP file.

At this point, it has crashed the site. I guess I need a different editing program so I can save a PHP file.
I'll let you know what happens when I get that part straightened out.
  #6  
Old Jan 4, 2013, 11:40 AM
jerryc
 
367 posts · Oct 2012
Florida
Quote:
Originally Posted by RobinDenning
Juggledad, I changed the HTML on line 35 of the parse_php.php file.

But now I have a different problem - when I use Text Wrangler to save it, it saves as a text file, not a PHP file. I am new to Text Wrangler, but can't find option to allow me to save as a PHP file.

At this point, it has crashed the site. I guess I need a different editing program so I can save a PHP file.
I'll let you know what happens when I get that part straightened out.
I've run into this with other programs. Even the attachments on this blog won't let you upload a php file. Just save it as a .txt, then find a way to rename it, like through file manager or something. I use the WP-Filemanager plugin, which works from the dashboard. I hope this helps.
  #7  
Old Jan 4, 2013, 12:43 PM
juggledad's Avatar
juggledad
 
22,097 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
you can ues the dashboard->apearances->editor to edit the file on the server.

textwrangler saves php files as test, it just gives them the extension of .php
On the MAC I juse 'FETCH as my FTP program and edit the file that way with no problem. It could have something to do with your server...

can you get into the back end?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #8  
Old Jan 4, 2013, 07:35 PM
RobinDenning
 
12 posts · Dec 2012
I got my localhost sorted out and got my site back.

Quote:
Originally Posted by juggledad
you can ues the dashboard->apearances->editor to edit the file on the server.
Ah, well that was much easier! Once I had everything back in place, I edited the parse_php.php file, but the site looks the same - the posts are still excerpts.

thanks for the extra info, though, about text wrangler and fetch.

What do you think - can this be resolved or might it become a Request For Enhancement? I love the overall style of Montezuma. If I can't display complete posts, I need to provide better navigation for users at the bottom of the comment page. They don't like getting to the end of the comments and being "stranded" there with only the previous post or next post to click on. They want to click and return to the main page. What can I say, my readers don't like all the extra clicking!
  #9  
Old Jan 4, 2013, 07:54 PM
juggledad's Avatar
juggledad
 
22,097 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Well did you go into postformat.php in the virtual templates and change the 'bfa_excerpt(..)' to 'the_content()'?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #10  
Old Jan 4, 2013, 08:21 PM
RobinDenning
 
12 posts · Dec 2012
YES! It seems to have worked.I actually did that earlier, took a look and didn't see a change.
Duh, I forgot to refresh the page.

I just now did that and refreshed the page and I am getting the full post! Thank you!!
  #11  
Old Jan 5, 2013, 01:10 PM
RobinDenning
 
12 posts · Dec 2012
Juggledad,

My website (http://alittlesewing.com) is now up to date with the changes and I am getting complete posts with correct content, thank you!

There is one small issue I'd like to resolve - the text doesn't align perfectly with the date. I looked through CSS files, but can't figure out where it should change. Any ideas?

thanks so much!!
Attached Thumbnails
Click image for larger version

Name:	unaligned text.jpg
Views:	148
Size:	53.3 KB
ID:	2168  
  #12  
Old Jan 5, 2013, 01:28 PM
lmilesw's Avatar
lmilesw
 
10,077 posts · Jul 2009
Central New York State USA
Not sure why it is like that but the following might fix it.
HTML Code:
.post-bodycopy p {
    margin-top: 0px;
}
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #13  
Old Jan 5, 2013, 04:34 PM
RobinDenning
 
12 posts · Dec 2012
Larry, that did the trick! Thanks so much!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Excerpt or Full Post for Custom Taxonomy pages? vinny@usestrict.net Atahualpa 3 Wordpress theme 3 Sep 23, 2012 04:30 PM
Excerpt is not linking to full post clittell Excerpts, Read more, Pagination 1 Apr 5, 2012 11:10 AM
BUGFIX 364-05: No link to the full post shown on excerpt when post has no title juggledad Old Version fixes and change logs 0 Feb 21, 2011 03:49 PM
Post that is a sticky on the front page doesn't display the full post. jambo01 Center area post/pages 3 Oct 6, 2010 03:57 AM
Full Post instead of Excerpt after posting a comment? adum Excerpts, Read more, Pagination 4 Jul 11, 2009 03:19 PM


All times are GMT -6. The time now is 12:41 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.