Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] How can I have one post on main page with archives showing all posts


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Sep 9, 2012, 12:44 PM
disfasia
 
87 posts · Jun 2010
http://oneworldnow.net

There is a month archive on the right which I like but when I click on that, only one post shows up not all for that month. I changed the blog page read to 5 and that allows five to show up in the archive but I really want to keep my home page simplified to one post.

How can I fix this?

Thanks in advance!
  #2  
Old Sep 9, 2012, 12:54 PM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
You could use a plugin that let's you put a shortcode on the home page and allows for showing only one post.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Sep 9, 2012, 01:49 PM
disfasia
 
87 posts · Jun 2010
Can you suggest a reliable plugin?

Thanks so much!
  #4  
Old Sep 9, 2012, 05:14 PM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
TPG Get Posts is one.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Sep 10, 2012, 04:02 AM
disfasia
 
87 posts · Jun 2010
I downloaded this and others and I cannot see how to put code in the homepage. It seems to only allow for individual posts. No information is given further on these plugins or the short code..

What do you know of this? Where is the homepage php document?

Thanks again!
  #6  
Old Sep 10, 2012, 04:33 AM
juggledad's Avatar
juggledad
 
21,979 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
what do you have set at dashboard->settings->reading->Blog pages show at most?

this value controls how many posts show on any multi post page and the archive page is a multi post page.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #7  
Old Sep 10, 2012, 05:09 AM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
To use TPG Get Posts you need to change your setting in Settings>Reading to use a static page as the front page.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #8  
Old Sep 10, 2012, 05:53 AM
disfasia
 
87 posts · Jun 2010
I have it now set to one which is what I want for the entry page, but I also want the archives on the right-hand bar to show more than one post when a month/year is called up.

What I would like is the latest page on the front page, but for index/archives, I really do need that a list can be displayed of all articles for said month/year/topic.

Last edited by disfasia; Sep 10, 2012 at 05:56 AM.
  #9  
Old Sep 10, 2012, 09:21 AM
disfasia
 
87 posts · Jun 2010
Wont the static page remain always the same, not the last posted?
Thanks again.
  #10  
Old Sep 10, 2012, 09:49 AM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
Quote:
Originally Posted by disfasia
Wont the static page remain always the same, not the last posted?
Thanks again.
You use the static page with the TPG Get Posts plugin and shortcode.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #11  
Old Sep 10, 2012, 10:54 AM
disfasia
 
87 posts · Jun 2010
I am still trying to make this work but in the meantime a buttton has appeared on my menu: "Home".

How do I remove this?

Thanks
  #12  
Old Sep 10, 2012, 11:04 AM
disfasia
 
87 posts · Jun 2010
I removed the Home link but still struggling to get this code to work.
  #13  
Old Sep 10, 2012, 11:21 AM
disfasia
 
87 posts · Jun 2010
I created a X page and put [ tpg_get_posts numberposts=1 ] in it. This does not work. Any ideas?
  #14  
Old Sep 10, 2012, 11:28 AM
disfasia
 
87 posts · Jun 2010
Now I have figured it out BUT...it doesn't work. In other words, the [ tpg_get_posts numberposts=1 ] works fine on my test home page but when I set the number of blog posts back to 10, it still loads 10 pages on the home page.
  #15  
Old Sep 10, 2012, 11:40 AM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
It looks like you have a space after the opening and before the closing bracket causing the shortcode not to work.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #16  
Old Sep 10, 2012, 11:41 AM
juggledad's Avatar
juggledad
 
21,979 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Create a page - call it 'new home' for now
Put the short code in with number posts=1
At settings->reading
A) set number of posts to 10
B) set front page displays - point this at 'new home'

Now the front page should go to 'new home' and display 1 post while the archive shows 10
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #17  
Old Sep 10, 2012, 11:43 AM
disfasia
 
87 posts · Jun 2010
Thanks so much lmilesw and Juggledad. That worked. It was the space.

Now how to make that title of my "X" page disappear from the home page..so that the size, font, etc are the same as the other posts! I notice the other menu posts, for instance, don't have at the bottom of the page:

"No Comments | Filed under: Politics | Tags: No Tags"

How can I remove this?

I imagine to remove the X from the menu I just create a custom menu.

Thanks again!

Last edited by disfasia; Sep 10, 2012 at 12:02 PM.
  #18  
Old Sep 10, 2012, 12:24 PM
lmilesw's Avatar
lmilesw
 
10,054 posts · Jul 2009
Central New York State USA
You can turn on Post/Page options in the theme settings and then uncheck the box on that page so the title doesn't show or you can use CSS for that page to hide the title. The items on the bottom are handled in the Post/Page Info section of the theme options.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #19  
Old Sep 10, 2012, 05:32 PM
disfasia
 
87 posts · Jun 2010
I am going bald here. I think the scripts made my colors and sizes of fonts change because suddenly after installing it, they were altered.

I have fixed most everything but i am still stuck for the homepage http://oneworldnow.net/

1. How do I remove the X title?
2. How do I remove the byline? (It doesnt' show at all for the other posts)
3. How to remove this last line before the grey:

No Comments | Filed under: Politics | Tags: No Tags


Thanks for any and all help!

Last edited by juggledad; Sep 10, 2012 at 07:07 PM.
  #20  
Old Sep 10, 2012, 07:07 PM
juggledad's Avatar
juggledad
 
21,979 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
to have the X not display, you can just use 'display: none;' for the element
to remove the byline, look at the page/post info item options
wat last line before the grey?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #21  
Old Sep 11, 2012, 01:14 AM
disfasia
 
87 posts · Jun 2010
Yes, I tried that..but when I get rid of the X I get rid of all headlines. Is there a way to control only that front page?

And I don't think the byline is called the byline for the X page as I have used display: none; for that and it doesn't turn it off....

And then I tried going through style.css but there nothing changes either. And I am used to changing style sheets.... ???

Last edited by disfasia; Sep 11, 2012 at 04:31 AM.
  #22  
Old Sep 11, 2012, 04:23 AM
juggledad's Avatar
juggledad
 
21,979 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Quote:
Is there a way to control only that front page?
yes, prefix the CSS selector with 'body.page-id-xx' where xx is the page id - you can fine that by going to the page, look at the source and do a search for '<body'

Quote:
And I don't think the byline is called the byline for the X page as I have used display: none; for that and it doesn't turn it off....
once again, look at the source of the page to find the HTML elements and ID/classes assigned to it - the FireBug extension of FireFox is a great help doing things like this - you can even change the CSS on the fly to see it's effects. Learn to use it.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #23  
Old Sep 11, 2012, 04:49 AM
disfasia
 
87 posts · Jun 2010
Thanks... So do I edit from ATO pages or from the style.css file? Or do I create a custom.css file?

I have used Firebug but when I tried to replicate the commands it didn't work. But then I might have put them in the wrong place.

Last edited by disfasia; Sep 11, 2012 at 05:05 AM.
  #24  
Old Sep 11, 2012, 05:09 AM
disfasia
 
87 posts · Jun 2010
I have put:

body.page-id-2046

.h1 {font-size: 0px;}

In the style.css and nothing changes... I have also tried display: none; etc.
  #25  
Old Sep 11, 2012, 05:10 AM
juggledad's Avatar
juggledad
 
21,979 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
you can add custom CSS at ato->add HTML/CSS Inserts->CSS Inserts and then they are stored with the rest of the theme options, no editing of code needed.

Quote:
I have put:

body.page-id-2046

.h1 {font-size: 0px;}

In the style.css and nothing changes... I have also tried display: none; etc.
if that is exactly what you put in, it won't do anything since the CSS selector (the part before the {...}) is looking for a class of h1 (the period indicates a class)
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Sep 11, 2012 at 05:13 AM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help showing posts in archives widget insertgenericname Sidebars & Widgets 3 Dec 23, 2010 09:49 AM
[SOLVED] image not showing in post on the main page ???? jostakid Center area post/pages 3 Jun 17, 2010 03:29 PM
All Posts showing on main page. How can I get only certain post on main NoLimit24_FJ Forum How-To 1 Sep 22, 2009 05:18 PM
Archives not working, comments not showing and a page question ! aliferste Comments, trackbacks & pings 8 Dec 14, 2008 03:16 AM


All times are GMT -6. The time now is 01:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.