Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » eCommerce & Atahualpa »

Problem activating Shopp plugin

Old Jan 23, 2010, 11:11 AM
20 posts · Dec 2009
Yorkshire, UK
I've installed the shopp plugin sucessfully with my wp 2.9.1 + atahualpa 3.4.4 but when I try and activate it I get a server 500 error message and it fails to activate.

I have run the shopp compatibility plugin, and it gave me the all clear to install shopp with my hosting package.

I am in contact the shopp support guys, and they have responded and are looking into it (this alone is a big improvement on wp e-commerce!). But I was wondering if anyone else here has encountered this problem and know of a fix?
Old Jan 28, 2010, 06:26 AM
20 posts · Dec 2009
Yorkshire, UK
just an update, should anyone be interested. The Shopp support are saying it's a hosting issue, and my hosts tech support are clueless and implying it's a plugin issue. Looks like Shopp's off the menu for me with this host.

So, warning - the shopp compatibility plugin doesn't tell the whole story. It may give you the thumbs up, but it doesn't guarantee that it will work.

Still, I have an inactivated Shopp license to use at some point in the future!
Old Jan 28, 2010, 10:14 AM
jack96161's Avatar
66 posts · May 2009
Yes it's a hosting issue - I had the same problem and it took a while to figure out and fix it. Adam at Shopp spent days helping and fortunately my hosting service has fantastic tech support. It's a PHP issue, and different hosting services install, configure, and support PHP differently. Unfortunately, this problem didn't manifest itself with any PHP or script errors, making it very hard to debug.

In the end, my hosting service (like many others) runs something called Zend Optimizer, which optimizes and speeds up the use of PHP - great, except the version in use at that time was incompatible with the Shopp activation process. Working with my hosting service's PHP guru, we discovered an incompatibility between the release level of Zend Optimizer they were running at the time (last September). The tech turned off Zend Optimizer for my account a few minutes and Shopp activated normally. When Zend Optimizer was truned on again, Shopp ran fine - the only problem is something in the activation process. Turned out, my service was already in the process of testing a newer release of Zend Optimizer and we discovered that with it installed, Shopp activated normally.

Search entries on Shopp's user forum and try to contact Adam on their staff to find out if you're having the same problem - and contact your host and ask just how they have PHP support set up.

Old Jan 28, 2010, 11:43 AM
20 posts · Dec 2009
Yorkshire, UK
Thanks Jack. I'll run that by the support people at my hosting co.
Old Jan 29, 2010, 12:15 PM
2 posts · Jan 2010
Hi, "internal server error" is not always an internal server error. For example if you are using an htaccess file something could be wrong in that one. One common error is to forget the # -sign for comments. That will produce the error code 500.

Old Feb 2, 2010, 10:19 AM
20 posts · Dec 2009
Yorkshire, UK
I've just got Shopp to activate on my test domain with the same host. The support guys haven't told me what they did, but I'm trying to get them to do it on my clients domain!

One thing that did happen with shopp is that google checkout worked flawlessly within 30 minutes of me playing around with it. This is how it should be! I've been wrestling unsuccessfully with that issue for weeks with wp e-commerce plugin.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with e-commerce 'Shopp' plugin Sakshin eCommerce & Atahualpa 13 Apr 20, 2010 03:53 AM
All pages return 'Not Found' with /null URL after activating plugin. ianhaycox Plugins & Atahualpa 6 Feb 26, 2010 09:26 AM
Using the Shopp plugin with your Atahualpa site? Shepherd Jim eCommerce & Atahualpa 13 Jan 1, 2010 03:06 PM
[SOLVED] Glitch while activating the BFA subscribe widget.. site content not displayi Mariannable Sidebars & Widgets 4 Dec 22, 2009 07:32 PM
[SOLVED] Problem with double jquery library calls / "Shopp" plugin Shepherd Jim Plugins & Atahualpa 2 Nov 11, 2009 08:02 AM

All times are GMT -6. The time now is 01:38 AM.

Powered by vBulletin® Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.