Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] Changed URL can't get into site


  #1  
Old Aug 27, 2010, 04:20 AM
Pierre's Avatar
Pierre
 
36 posts · Aug 2010
Montpellier, France
Hello

This is my first post. I spent a couple of days discovering Atahualpa, and I really like it.

I have created a site using XAMPP for its local hosting capabilities. I did like working this way and would like to use it for my coming websites.

BUT I have made a stupid thing : in Wordpress admin I have changed the website url and blog url, so as to be capable of putting my local website onto its new location.

I know that's silly, but I had been designing the baby for days, was exhausted, and rookie...

Now my local website gives me a parse error, and my hosted website also...

Please give me a hand to get back my posts, pages and site design (Ata options mainly) from the local.

Donation-ready to fire ;o)

Please forgive my exotic English, I am a Frog
  #2  
Old Aug 27, 2010, 05:25 AM
juggledad's Avatar
juggledad
 
23,674 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
You will need to use phpMyAdmin and get into the database.
1) Find the table wp_options
2) edit the row with the option name of 'siteurl' and change the option_value ONLY
3) go to the next page and find the row with the name of 'home' - edit it and fix the url there also
That should do it
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Aug 27, 2010, 07:02 AM
Pierre's Avatar
Pierre
 
36 posts · Aug 2010
Montpellier, France
Hi Juggledad

Thanks for your answer, I just did that and now I can see my homepage (local) on the url :

http://localhost/wordpress/

but all my links (even if they give the right slug in the screen bottom left corner) redirect me to XAMPP.

http://localhost/xampp/

and http://localhost/wordpress/wp-admin

returns a "not found" error

and all my images / icons have broken links...


Any suggestions please ?

Thanks again

Pierre

Last edited by Pierre; Aug 27, 2010 at 07:14 AM.
  #4  
Old Aug 27, 2010, 07:58 AM
juggledad's Avatar
juggledad
 
23,674 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Get into the wordpress backend dashboard->settings->general and make sure the WordPress address (URL) and Site address (URL) are the same, then set the permalinks to default and see what happens
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Aug 27, 2010, 08:25 AM
Pierre's Avatar
Pierre
 
36 posts · Aug 2010
Montpellier, France
Can't log to wp-admin (as said above).

Gives me a 404 error.

thanks
  #6  
Old Aug 27, 2010, 11:11 AM
juggledad's Avatar
juggledad
 
23,674 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try http://localhost:8888/wordpress/wp-admin
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Aug 28, 2010, 03:15 AM
Pierre's Avatar
Pierre
 
36 posts · Aug 2010
Montpellier, France
Hi,

Firefox says :


Connection failed, Firefox cannot setup a connection with the server at address localhost:8888.

while XAMPP is running Apache, MySQL and Filezilla

Thanks again
  #8  
Old Aug 28, 2010, 04:41 AM
juggledad's Avatar
juggledad
 
23,674 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
you said
Quote:
Now my local website gives me a parse error, and my hosted website also...
why is your hosted site giving you a problem? your not using the same database for both...are you??
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Aug 28, 2010, 04:55 AM
Pierre's Avatar
Pierre
 
36 posts · Aug 2010
Montpellier, France
No !

I have changed the hosted website database settings in wp-admin to those given by the hoster.

But as I needed to go forward, I have decided to :

- try and save my local site using XAMPP
- delete and restart from scratch my hosted website (with ATA 353 and WP 301)

I'd really love to be able to copy & paste my posts and pages from local to hosted, as I have no backup copy of them. Only the texts would be great.

thks
  #10  
Old Aug 28, 2010, 05:09 AM
juggledad's Avatar
juggledad
 
23,674 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
you should get into the database using phpMyAdmin and do a full export.
With the export, you can then edit the sql to change the url address and import it where ever you want.

I'm on a MAC and I import other people's databases all the time for testing purposes. I also have MAMP installed on a second machine and things work fine.

Unfortunately, I don't have access to XAMPP so I don't think I can help you more than I have.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Aug 28, 2010, 06:54 AM
Pierre's Avatar
Pierre
 
36 posts · Aug 2010
Montpellier, France
thanks for your help around that topic,

I'll try your idea ASAP and keep you posted (and ensure donation in case of success as promised).

Thanks a lot,

Pierre
  #12  
Old Aug 30, 2010, 07:44 AM
Pierre's Avatar
Pierre
 
36 posts · Aug 2010
Montpellier, France
Quote:
Originally Posted by juggledad
you should get into the database using phpMyAdmin and do a full export.
With the export, you can then edit the sql to change the url address and import it where ever you want.

I'm on a MAC and I import other people's databases all the time for testing purposes. I also have MAMP installed on a second machine and things work fine.

Unfortunately, I don't have access to XAMPP so I don't think I can help you more than I have.
Hi Juggledad,

Thanks for the tip, it did work ! I could see my pages and posts, when exporting to Word 2000 (ie for me Open Office Write).

Here goes your Donation (and another question).

How is it that my posts and pages do appear on www.e-motion-marketing.com as excerpts but when clicking them, they give me a 404 : not found.

That even more curious that the same occurs whenever I click on "preview page" in Wordpress control panel.

Thanks again for your help, answer 2 is key to me too...

Pierre
  #13  
Old Aug 30, 2010, 08:10 AM
juggledad's Avatar
juggledad
 
23,674 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
this is probably a permalinks issue. -go change your permalinks to the default and test, then switch back to what you currently have and test again. This will cause a rewrite of the htaccess file that controls the 'pretty' names
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #14  
Old Aug 30, 2010, 08:38 AM
Pierre's Avatar
Pierre
 
36 posts · Aug 2010
Montpellier, France
GREAT ! Works now, thanks a lot.

Just donated.

Pierre

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I changed the fixed width for my header? rsaelee Header configuration & styling 1 Jun 17, 2010 05:16 AM
Can the banners be changed? killerbee Header configuration & styling 3 Apr 20, 2010 03:05 PM
formatting of sidebar abruptly changed RS4 Sidebars & Widgets 4 Jan 6, 2010 01:53 PM
[SOLVED] !!! Site have changed own image and theme's setting don't affect to it. shus Plugins & Atahualpa 2 Jan 5, 2010 09:24 AM
HELPPPPPPPPPP I changed the logo.gif and now I cant see it at all??????? norwichkaren Atahualpa 3 Wordpress theme 9 Sep 17, 2009 05:26 AM


All times are GMT -6. The time now is 06:42 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.