Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] Suggestion to allow easier upgrades...


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jul 10, 2010, 09:34 AM
PainFreeComputing
 
20 posts · Dec 2009
Suggestion: Change the theme to allow the use of logo and favicon images that reside OUTSIDE the theme directory.

If we could do this, upgrading would be SO much more simple. Nothing would need to be added to what's in the zip file at all, unless the user had customized some of the code. As is, I have to copy custom images into the theme directory every time I upgrade. I don't use the rotating header images, so I don't know if this suggestion could also apply for them.

Jack

Last edited by PainFreeComputing; Jul 24, 2010 at 07:47 AM.
  #2  
Old Jul 24, 2010, 07:46 AM
PainFreeComputing
 
20 posts · Dec 2009
Surely I'm not the only user who this would help...

Jack
  #3  
Old Aug 23, 2010, 08:47 PM
PainFreeComputing
 
20 posts · Dec 2009
Just in case anyone else wants to keep "custom" logo images and favicons outside the atahualpa theme directory, here's how I did this on Apache 2.x:
  1. Create a "custom_images" directory in the DocumentRoot directory (it could be anywhere you want it).
  2. Create an AliasMatch in the virtual host's config file as follows:
    Code:
    AliasMatch ^/wp-content/themes/atahualpa.*/images/custom_images/(.*) [/absolute/path/to/custom_images]/$1
    This is for a Linux box. If you used spaces in your directory names, be sure to escape them in the code. If you use a Windows machine, you should probably put the path to your directory all in quotes and hope for the best. WARNING: Bad syntax can cause your httpd server not to restart.
  3. Restart httpd
  4. Go to the Wordpress Dashboard, Atahualpa Theme Options | Style & Edit Header Area. In the field under "Show Logo Image?" put custom_images/yourlogo.jpg (substitute the actual directory and image name, of course). Upload the custom logo to the directory you created in the first step above.
Now the new Atahualpa theme will not need my custom images copied into it every time I upgrade.

The procedure for the favicon.ico is similar enough that I won't spell that one out. I do not know if this would work for rotating header images, I just don't use those.

Jack
  #4  
Old Aug 2, 2013, 01:42 PM
PainFreeComputing
 
20 posts · Dec 2009
This is no longer an issue, since recent versions allow a custom image location outside the Atahualpa theme directory (in wp-content). My solution was simply a workaround. This is an actual fix.

Jack

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dashboard not working after trying 3.4.7, 3.4.9 upgrades Ferd New Versions, & Updating 4 May 25, 2010 03:00 PM
Easier to change to new theme? Meg Forum How-To 5 Apr 16, 2010 04:58 PM
[SOLVED] Catching up on the upgrades ozbod New Versions, & Updating 9 Apr 2, 2010 03:01 AM
Comments: Making them easier to find SherylCPA Comments, trackbacks & pings 2 Nov 3, 2009 11:35 AM
Canonical Suggestion Larry New Versions, & Updating 0 Oct 21, 2009 11:03 AM


All times are GMT -6. The time now is 05:44 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.