Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] Error upgrading 3.3.3 to 3.4.6


  #1  
Old Feb 20, 2010, 10:12 PM
ymf
 
61 posts · May 2009
Manually upgraded from 3.3.3 -> 3.4.6. Now I see error messages. Any pointers what could go wrong and how it can be fixed? Using WordPress 2.9.2.

Thank you!

Code:
Warning: array_slice() [function.array-slice]: The first argument should be an array in C:\Apache_htdocs\wordpress\wp-includes\plugin.php on line 166

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '' was given in C:\Apache_htdocs\wordpress\wp-includes\plugin.php on line 166

Warning: array_slice() [function.array-slice]: The first argument should be an array in C:\Apache_htdocs\wordpress\wp-includes\plugin.php on line 166

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '' was given in C:\Apache_htdocs\wordpress\wp-includes\plugin.php on line 166

Warning: in_array() [function.in-array]: Wrong datatype for second argument in C:\Apache_htdocs\wordpress\wp-includes\functions.php on line 384

Warning: in_array() [function.in-array]: Wrong datatype for second argument in C:\Apache_htdocs\wordpress\wp-includes\functions.php on line 384

Warning: in_array() [function.in-array]: Wrong datatype for second argument in C:\Apache_htdocs\wordpress\wp-includes\functions.php on line 384

Warning: in_array() [function.in-array]: Wrong datatype for second argument in C:\Apache_htdocs\wordpress\wp-includes\functions.php on line 384

Warning: array_slice() [function.array-slice]: The first argument should be an array in C:\Apache_htdocs\wordpress\wp-includes\plugin.php on line 166

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '' was given in C:\Apache_htdocs\wordpress\wp-includes\plugin.php on line 166

Warning: array_slice() [function.array-slice]: The first argument should be an array in C:\Apache_htdocs\wordpress\wp-includes\plugin.php on line 166

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '' was given in C:\Apache_htdocs\wordpress\wp-includes\plugin.php on line 166

Fatal error: [] operator not supported for strings in C:\Apache_htdocs\wordpress\wp-includes\general-template.php on line 32

Warning: array_slice() [function.array-slice]: The first argument should be an array in C:\Apache_htdocs\wordpress\wp-includes\plugin.php on line 339

Last edited by ymf; Feb 21, 2010 at 12:46 PM. Reason: added "code" tags
  #2  
Old Feb 21, 2010, 08:11 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Try downloading the copy from here http://wordpress.bytesforall.com/?p=87. I had problems with the one on wordpress.org.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Feb 21, 2010, 11:10 AM
ymf
 
61 posts · May 2009
Quote:
Originally Posted by lmilesw
Try downloading the copy from here http://wordpress.bytesforall.com/?p=87.
Yes, it came from here. Any other ideas?
  #4  
Old Feb 21, 2010, 12:43 PM
ymf
 
61 posts · May 2009
I found in a prior thread somebody reported a similar problem with the weird error mesage "Fatal error: [] operator not supported for strings", and also when upgrading from 3.3.3. His reported error message was:
Code:
Fatal error: [] operator not supported for strings in /home/eg000216/public_html/wp-includes/general-template.php on line 32
In that thread, juggledad recommended:
Quote:
remove all the themes except the default theme from wp-content/themes and all the plugins from wp-content/plugins and see if you can get WP running
  #5  
Old Feb 21, 2010, 01:05 PM
ymf
 
61 posts · May 2009
I found the culprit: an old "Paged Comments" plugin Version 2.9.1, presently decomissioned by its author (http://www.keyvan.net/code/paged-comments/). Which solves the issue .

Bookmarks

Tags
upgrade 332 to 346

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] After upgrading to 3.5.1 Custom Fields data problem star_echo New Versions, & Updating 1 Feb 16, 2010 01:41 PM
Error while upgrading theme bluedogcreative New Versions, & Updating 1 Jan 28, 2010 04:27 PM
[SOLVED] Upgrading Question MyJourneytoMillions New Versions, & Updating 4 Oct 20, 2009 11:20 AM
[SOLVED] Upgrading ATA 3.3.2 to 3.4.2 only half successful Shepherd Jim New Versions, & Updating 11 Sep 16, 2009 11:53 AM
[SOLVED] Categories disappear from bar when upgrading to WP 2.8.3 jankph Page & Category Menu Bars 0 Aug 4, 2009 07:08 AM


All times are GMT -6. The time now is 10:07 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.