Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Help!!! Just launched a site that is not showing headers at the top!!!


  #1  
Old Dec 7, 2009, 11:53 AM
Masselyn
 
91 posts · Jan 2009
So. California
I launched a site last night, where I am using the following code in the Style & Edit Header Area "<div id="imagecontainer" class="header-image-container"></div>". I read about this on a post here, so I could then dictate different headers for each page in the site (through CSS Inserts). It works beautiful on Safari and Firefox. My Windows PC was down last night, and when I checked this morning IE is not showing the headers at the top at all. The correct space is there, but no image. Any thoughts.

The site is www.foodandspirit.com

Thanks for any help someone can offer.
  #2  
Old Dec 7, 2009, 12:50 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
it's working fine when I look at in IE8. The only page with a problem is BOoks. It shows a white background in IE8 while Safari shows a green background
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Dec 7, 2009 at 12:52 PM.
  #3  
Old Dec 7, 2009, 12:54 PM
Masselyn
 
91 posts · Jan 2009
So. California
It was not in IE6, or IE8. I figured out what the problem was and it was my fault for not scrolling and reading the rest of what you typed in this post http://forum.bytesforall.com/showthr...=div+container. I was missing the "!important" at the end of the background CSS code. The instructions were working beautiful in Safari and Firefox, but the header was not showing on any pages for any version of IE. Once I added that, Voila it was showing.

Goes to show - IE stinks - AGAIN!

So, it was all my fault and I am sorry about that. Consider this issue closed!!

Thanks, Juggledad. Once again!
  #4  
Old Dec 7, 2009, 12:56 PM
Masselyn
 
91 posts · Jan 2009
So. California
Yeah, any thoughts on that Books page. The CSS for that is the same for all other pages, but I have NO idea why it is not showing the green background (with broccoli). Looks fine in Firefox and Safari, and not in IE. I did nothing different for that page, that I can think of.
  #5  
Old Dec 7, 2009, 01:50 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
you don't have the '!important'
HTML Code:
body.page-id-572 {
background:#b9e5fb url(http://www.foodandspirit.com/images/BG_Blueberry.jpg) repeat-x fixed center bottom
}
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Dec 7, 2009 at 06:53 PM.
  #6  
Old Dec 7, 2009, 03:30 PM
Masselyn
 
91 posts · Jan 2009
So. California
I tried that, and don't think it worked. Not to mention I don't have that written on any of the other pages. Why are they all showing up perfectly fine, and this is the only page that does not show the background. I just found that "odd", although totally in line with IE from what I have worked with.

  #7  
Old Dec 7, 2009, 06:55 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
not sure, I was just comparing a page that worked to the one that doesn't and found that difference.
The CSS was also out of order verses the other pages and I didn't check anything else, so you may want to go over them with a fine tooth comb to see if there are any more differences.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Dec 8, 2009, 09:20 AM
Masselyn
 
91 posts · Jan 2009
So. California
Thanks. I'm just not seeing a difference from that page and others, because the others do not have the important and this one does. It is so weird, I even changed the order of the elements and even placed all of the CSS for this page at the top before others and it still does not show properly for IE - but all other pages are right on target. It is so weird.
  #9  
Old Dec 8, 2009, 09:25 AM
Masselyn
 
91 posts · Jan 2009
So. California
Here is something weird. I removed the code dictating in CSS Inserts that the background of that page should be:


Code:
body.page-id-543 { 
-moz-background-clip:border;
-moz-background-inline-policy:continuous;
-moz-background-origin:padding;
background: #d1e7c1 url(http://www.foodandspirit.com/images/BG_Green.jpg)repeat-x fixed center bottom !important;
color:#535250;
margin:0;
padding:0;
text-align:center;
}
I then entered the same background line above into the Body, Text & Links area of Theme Options. Since I am not telling it anything specific in CSS, the page should then take its queue from the Theme Options. It does for the Books page in all other browsers, but IE is still not showing it at all. I have a white background. Any thoughts why that is happening?
  #10  
Old Dec 8, 2009, 09:26 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try this,
1) change the page id for one of the other css selectors to this page and see if it works.
if it does, then it's got to be a css selector problem
if it doesn't, change it back and

2) change the image for the books page to one of the others and see if it works.
if it does, the image must be the problem
if it oesn't, start scratching your head
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Dec 8, 2009, 09:48 AM
Masselyn
 
91 posts · Jan 2009
So. California
Changing the image for that page did not work, changing another page to point to that image did work. But, I just copied the line from another page :

Code:
body.page-id-536 { 
background: #fcf8c5  url(http://www.foodandspirit.com/images/BG_Lemons.jpg) repeat-x fixed center bottom;
}
and changed the file it points to, background color and the page ID, and the darn thing works. What I don't get is here is the original line I was asking the Green page to use. I see no difference, between this below and the item above other than the obvious color.

Code:
background: #d1e7c1 url(http://www.foodandspirit.com/images/BG_Green.jpg)repeat-x fixed center bottom;
  #12  
Old Dec 8, 2009, 09:50 AM
Masselyn
 
91 posts · Jan 2009
So. California
OMG - it is all in the spacing. Obviously IE insists that there be a space between the closing parenthesis and then where I have "repeat-x". Other browsers do not need this, therefore they were able to read the line and IE (no version according to someone I had testing IE8 and I have IE6) was able to read it. Makes no damn sense!!

Sorry, just terribly frustrated at IE (who isn't).

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Do not upgrade dynamic headers - help! krystyna Plugins & Atahualpa 9 Aug 10, 2009 09:30 AM
Atahualpa-themed site not showing properly in any browser besides Firefox ViRo Atahualpa 3 Wordpress theme 1 Aug 4, 2009 05:44 PM
Set different headers for each page curious Header configuration & styling 17 Jun 19, 2009 04:53 PM
Sticky Headers + Sidebar justjoolz Atahualpa 3 Wordpress theme 1 Apr 7, 2009 05:57 AM
Odd lingo on top is messing up site scarlett827 Atahualpa 3 Wordpress theme 5 Jan 31, 2009 08:01 AM


All times are GMT -6. The time now is 09:33 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.