Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

Do not upgrade dynamic headers - help!


  #1  
Old Jul 29, 2009, 11:39 AM
krystyna
 
121 posts · Apr 2009
I upgraded to the new Dynamic Headers version on this site:

http://equinecisers.com/wordpress/

and the message I got was the following:


Fatal error: Call to undefined function show_media_header() in D:\Hosting\2781642\html\wordpress\wp-content\themes\atahualpa342\header.php on line 49

I tried to delete the plugin (which hadn't even been activated), to no avail. I even tried to restore the old header file. That didn't work either.

So if this happens to anyone, revert to the old version of Dynamic Headers until there's a reply to this post.

Last edited by krystyna; Jul 29, 2009 at 11:53 AM.
  #2  
Old Jul 29, 2009, 01:53 PM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Did you create the new folder?
Quote:
Important Upgrade Note: If upgrading from Dynamic Headers 2.7 or lower: The image folder has moved. You will need to create the directory /wp-content/header-images/ and make it writable. You will need to backup /wp-content/plugins/dynamic-headers/header-images/ and move your header files to the new directory before upgrading.
What version of Atahualpa?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jul 29, 2009, 02:03 PM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Also, what settings did you use?
What's your url?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Jul 31, 2009, 10:51 PM
krystyna
 
121 posts · Apr 2009
Well, now we have a different problem. Using the older version of Dynamic Headers, I was able to place a static JPG header with no problem. Then I placed a SWF on the home page and got the following:

Warning: getimagesize() [function.getimagesize]: URL file-access is disabled in the server configuration in D:\Hosting\2781642\html\wordpress\wp-content\plugins\dynamic-headers\custom-header.php on line 369

Warning: getimagesize(http://equinecisers.com/wordpress/wp...ges/header.swf) [function.getimagesize]: failed to open stream: no suitable wrapper could be found in D:\Hosting\2781642\html\wordpress\wp-content\plugins\dynamic-headers\custom-header.php on line 369

URL : http://equinecisers.com/wordpress/


Update: I think it's because the /header-images/ folder wasn't chmod 777, so it looks like this site will have to wind up on a unix server. Darn.

Last edited by krystyna; Jul 31, 2009 at 10:57 PM.
  #5  
Old Jul 31, 2009, 11:29 PM
krystyna
 
121 posts · Apr 2009
Nope, the chmod didn't work. It's something in the plugin itself but how to change that .php file to what WILL work, I have no idea.
  #6  
Old Jul 31, 2009, 11:50 PM
krystyna
 
121 posts · Apr 2009
BTW when the previous version of Dynamic Headers (3.1) was paired with Atahualpa 3.3.3, the Flash file worked. When I used it with Atahualpa 3.4.2, I got the error message.
  #7  
Old Aug 1, 2009, 12:03 AM
krystyna
 
121 posts · Apr 2009
Thinking, maybe this is because this site is on a Windows server, that could be the problem, but I put the same flash file in a Unix-based site I'm working on - same problem. Static images are displaying ok, Flash files not.
  #8  
Old Aug 1, 2009, 12:29 AM
krystyna
 
121 posts · Apr 2009
My goodness, I don't believe it ... but I fixed it.

There may be an easier way within Atahualpa (please feel free to tell me if there is!) but what I did was ...

1. downloaded Dynamic Headers' custom-header.php file (make sure you back up the original).
2. deleted lines 368 and 369, which refer to the "get...." function.
3. In references to .swf files in PHP code below the lines mentioned in #2, I placed the full path to the SWF file (replacing the php echo references), including the width and the height.

What remains to be seen is why using WP 2.8.2, Ata 3.3.3 and Dynamic Headers 3.1 (not the latest version, but the last one before the new one), SWF files displayed with no problem. The only difference between the site where it worked and this site I'm working on now is the upgrade to Ata 3.4.2.
  #9  
Old Aug 4, 2009, 04:51 PM
viewdesigninc
 
35 posts · Mar 2009
Could you post the code you took out and inserted? I can't get mine to work.
  #10  
Old Aug 10, 2009, 10:30 AM
krystyna
 
121 posts · Apr 2009
Lines 368 and 369 that start with "GET" should be removed. Changes to code below I'll BOLD.
Replace what's in the original file with your file name (absolute path) and the file name's width and height.



<script type="text/javascript">
if (AC_FL_RunContent == 0) {
alert("This page requires AC_RunActiveContent.js.");
} else {
AC_FL_RunContent(
'codebase', 'http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0',
'width', '800',
'height', '250',

'src', 'http://www.yourdomain/wordpress/wp-content/header-images/yourflashfile.swf',
'quality', 'high',
'pluginspage', 'http://www.macromedia.com/go/getflashplayer',
'align', 'middle',
'play', 'true',
'loop', 'true',
'scale', 'showall',
'wmode', 'transparent',
'devicefont', 'false',
'id', 'mediaHeader',
'bgcolor', '#ffffff',
'name', 'mediaHeader',
'menu', 'true',
'allowFullScreen', 'false',
'allowScriptAccess','sameDomain',
'movie', '<?php echo $dhnd_image_url_base.$swf_name; ?>',
'salign', ''
); //end AC code
}
</script>
<noscript>
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="<?php echo $width; ?>" height="<?php echo $height; ?>" id="mediaHeader" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="allowFullScreen" value="false" />
<param name="wmode" value="transparent" />
<param name="movie" value="<?php echo '/'.$swf_src; ?>" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />
<embed src="<?php echo '/'.$swf_src; ?>" wmode="transparent" quality="high" bgcolor="#ffffff" width="800" height="250" name="mediaHeader" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>
</noscript>

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to insert 'dynamic headers' into horbar2 fruitbat Plugins & Atahualpa 17 Oct 5, 2009 07:46 AM
Headers appear in Firefox, but not in IE & Chrome! GuitarGuy Header configuration & styling 1 Jul 17, 2009 08:20 PM
Set different headers for each page curious Header configuration & styling 17 Jun 19, 2009 05:53 PM
Sticky Headers + Sidebar justjoolz Atahualpa 3 Wordpress theme 1 Apr 7, 2009 06:57 AM
Page Menu button images w/dynamic resize kritho Page & Category Menu Bars 1 Feb 18, 2009 06:06 PM


All times are GMT -6. The time now is 07:33 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.