Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Installation/Upgrade Issues »

Header Image Problem in Preparation For Upgrade


  #1  
Old Aug 1, 2016, 03:36 PM
BrightonNY
 
38 posts · Jul 2013


The website is on a subdomain.

I'm currently running on ATA 3.7.12 and preparing for upgrade to latest version. I followed the directions precisely as described under IMAGE LOCATIONS. I did not upgrade; this problem is happening on my wesbite when I select RELATIVE LOCATION as wp-content.

My folders are as follows: public_html to wp-content to ata-images to header to head1(header image).
The permissions are 0755 except the header image which is 0644.

No caps and no spaces.

I've tried it several times with the same result.

Here is the problem: http://www.testing.selmarcerini.com

Any help would be greatly appreciated. Thank you.
  #2  
Old Aug 1, 2016, 03:44 PM
BrightonNY
 
38 posts · Jul 2013
Correction: header image is head01, not head1
  #3  
Old Aug 1, 2016, 05:19 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Try turning off rotating headers - set ATO->Header Image->Rotate header images with Javascript? to zero (0)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Aug 3, 2016, 12:22 PM
BrightonNY
 
38 posts · Jul 2013


This did not work. I've tried to vary some other settings without success.
  #5  
Old Aug 3, 2016, 12:52 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Export your settings (ATO->export/import settings) and attach them to a reply
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Aug 3, 2016, 02:26 PM
BrightonNY
 
38 posts · Jul 2013
Settings attached.

Last edited by BrightonNY; Aug 7, 2016 at 12:13 PM.
  #7  
Old Aug 3, 2016, 03:52 PM
BrightonNY
 
38 posts · Jul 2013
I created a new subdomain and deleted the 3 default headers and uploaded a copy of the original header in the same header folder. It works fine until I change the setting to wp-content from atahualpa; gives the same error.

This new subdomain is WP 4.5.3 and ATA 3.7.24.
  #8  
Old Aug 3, 2016, 04:23 PM
BrightonNY
 
38 posts · Jul 2013

CORRECTION: Same problem when changing setting from ATAHUALPA to WP-IMAGES
  #9  
Old Aug 3, 2016, 06:54 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
So it works when you use images in teh atahualpa/images/header folder...right?
Since you have changed the test case, what is the new URL and what is the exact content of the wp-contents/ata-images/header folder?

In copying your settings to my test site, it works fine both ways. This leads me to beleive there is still a permission problem or a files name is 'funny' or a file is corrupt.


When I go to your site and look for errors (In safari) I am seeing the following
Quote:
http://testing.selmarcerini.com/wp-c...der/head01.jpg
Failed to load resource: the server responded with a status of 404 (Not Found)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Aug 3, 2016 at 07:02 PM.
  #10  
Old Aug 4, 2016, 12:54 PM
BrightonNY
 
38 posts · Jul 2013
Yes, works fine in the ATA images/header folder so long as I use ATAHUALPA rather than WP-CONTENT.

The wp-content/ata-images/header folder contains only one file: header01.jpg. I had downloaded it from the ATA images folder and then uploaded it to the ata-images/header folder.

I noticed in the error message the last part is .../header/-wp-content. Is that correct? Just wondering where the - ahead of wp-content came from.

The original website is still there. The new subdomain is: http://www.newata.selmarcerini.com
  #11  
Old Aug 4, 2016, 03:24 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
1) you need to put your logo.jpg in the wp-content/ata-images folder
Quote:
http://newata.selmarcerini.com/wp-co...mages/logo.png
Failed to load resource: the server responded with a status of 404 (Not Found)
2) if you can not enter in the fully qualified path to the image in the browser address bar and see the image, you have a permission or misspelling issue.

For example if you put
HTML Code:
http://newata.selmarcerini.com/wp-content/themes/atahualpa/images/header/header01.jpg
in the address bar, you see the image, but if you put
HTML Code:
http://newata.selmarcerini.com/wp-content/ata-images/header/header01.jpg
you get a not found.

Check the name of the folders, look for something like headerS vrs header or something in uppercase.

It's not your Atahualpa settings, it's something to do with the folders/files
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Aug 5, 2016, 10:26 AM
BrightonNY
 
38 posts · Jul 2013
I did the following:

1. Created ata-logo folder in wp-content and added logo.gif and logo.png files.

2. Deleted and rebuilt:
wp-content => ata-images => header => header.jpg

3. All in lower case and no spaces.

I really appreciate your help but at this point I need to just live with the problem provided there is some way I can shut off automatic updates. Is there a way to do that?

Thank you.
  #13  
Old Aug 5, 2016, 12:41 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
1) in your settings you state the logo is 'logo.png' If the actual file is 'logo.gif' it will not find it and it must be in the 'wp-content/ata-images' folder

2) You have me confused - is the header image 'header.jpg' or 'header01.jpg'?

can you use an FTP program and go to the 'wp-content' folder and takk a screen snap shot, then go to the 'ata-images' folder and take a snap shot and then go to the 'header' folder and thk a snapshot and attach them to a reply.

something is wrong with the spelling of a file or it's permission.

(actually you can keep using the atahualpa folders - with the major change in theme review that requires all themes must use the customizer for all options or the theme will not pass review, I do not see another release of Atahualpa happening. The number of man-hours that would be involved is staggering. If any issues comes up that can be patched a fix will be released for them.)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Aug 5, 2016 at 12:45 PM.
  #14  
Old Aug 5, 2016, 01:29 PM
BrightonNY
 
38 posts · Jul 2013
1. I moved logo.gif to ata-images.

2. When I uploaded a fresh copy of the header, I renamed it to header from header01.

3. I'm not sure how to use FTP as I haven't used it in years and back then I only used it to upload images as I recall. I will work on your request later today and tomorrow.

4. Yes, I'm fine using the ATA folders. But I still want to shut off any kind of automatic updates especially for WP and plugins, etc.

Thank you.
  #15  
Old Aug 5, 2016, 01:34 PM
BrightonNY
 
38 posts · Jul 2013
Question: Does the name of the header file in ata-images have to be identical to the name of the header file in the ATA files?

I changed the name because the ATA file has upper and lower case letters.
  #16  
Old Aug 6, 2016, 03:57 AM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
1) you just said you moved 'logo.gif' into ata-images - does that match the name you supplied at ATO->Style & edit HEADER AREA->Show Logo Image?
2) How are you moving the files into ata-images if you are not using FTP?
3) With what ever you are using to move the files, can you create a screeen shot of the contents of at a-images and ata-images/header?
4) after moving the files in to the folders, have you double checked the file permissions?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #17  
Old Aug 7, 2016, 12:18 PM
BrightonNY
 
38 posts · Jul 2013
1). This may be a non-issue since I do not use a logo. Under CONFIGURE HEADER AREA I do not have %logo.

2). On the File Manager top menu I am using the UPLOAD and DOWNLOAD icons from/to my PC harddrive. See attached screen shots.

3). The requested screen shots are attached.

4). Yes, I check the permissions each time I make a change.

Thanks.

Last edited by BrightonNY; Aug 7, 2016 at 06:22 PM.
  #18  
Old Aug 7, 2016, 03:13 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
can you send me a PM with an admin id/pw?

Something is seriously out of whack if you don't have %logo in the option, because the code is trying to create the header and it only does that id the %logo is there.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #19  
Old Aug 8, 2016, 04:25 AM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
ok, things got crazy because I was lookaing at the http://www.newata.selmarcerini.com site, which must have %logo in the header config

for the http://www.testing.selmarcerini.com you still have a folder/file permission problem
The images you show of the folders are not for the testing site ehis is:
Quote:
/home1/breslau/public_html/testing/wp-content/ata-images/header/
the images you show are for
Quote:
/home1/breslau/public_html/wp-content/ata-images/header/
Also you are running wp-supercache which is bad when you are doing testing - I shut it off so remember to turn it back on when you are done making changes.

So go back and look at the premissions for the at a-images folder at
Quote:
/home1/breslau/public_html/testing/wp-content
all teh folders and files at
Quote:
/home1/breslau/public_html/testing/wp-content/ata-images
amnd the images at
Quote:
/home1/breslau/public_html/testing/wp-content/ata-images/header/
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #20  
Old Aug 11, 2016, 01:06 PM
BrightonNY
 
38 posts · Jul 2013
I have been distracted from this problem by another one with FILEZILLA for the past few days.

As you suggested in an earlier post, I tried out FILEZILLA to reload the header image. I last used it 3 years ago when I built the website. Now it will not connect to the website files. I've been on the phone several times with HOSTGATOR support and they do not have an answer. I also mentioned this ATA Header problem and they suggested it comes initially from the implementation code of ATA and possibly WP if the ATA code depends on WP to set up the path.

This leads me to another more general question about ATA. Since you such in-depth knowledge, are you one of the developers of ATA?

Thanks.

Last edited by juggledad; Aug 11, 2016 at 04:50 PM.
  #21  
Old Aug 11, 2016, 03:10 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Yes, I sort of am one of the developers. I've been responsible for the releases for the last few years.

You don't need to use FileZilla, since your file manager shows the permissions, just make sure to look at the right folders and files.

The images you sent were NOT for the testing site. Read my previous post
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #22  
Old Aug 11, 2016, 05:29 PM
BrightonNY
 
38 posts · Jul 2013
1. I'll re-capture the images tomorrow. Not sure how I managed to screw that up.

2. I'll go through the files again and document their permissions.

2. I agree that I do not need FILEZILLA at this time however the fact that this is happening at the same time as my ATA problem suggests to me that my files have somehow been corrupted. I will probably have to start all over with HOSTGATOR resetting all my files to their defaults and rebuild my website rather than restore from a backup.

Thanks.
  #23  
Old Aug 11, 2016, 05:38 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I will be VERY surprised if your issues with Filizilla and atahualpa are related.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #24  
Old Aug 12, 2016, 02:52 PM
BrightonNY
 
38 posts · Jul 2013
I went through the folders and files and checked their permissions as follows:

- public_html 750
-testing 0755
- wp-content 0755
-ata-images 0755
-header 0755
- header.jpg 0644

Also had some logo folder and images but I do not use a logo. Those folders and files had the same permissions as the ata-images folders and files.

Do you need images for the testing folders and files?

Thanks.
  #25  
Old Aug 12, 2016, 06:53 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
ok, so you have a file called 'header.jpg' and it is in the folder 'header' or
../header/header.jpg
and the 'header folder is in the 'ata-images' folder or
..ata-images/header/header.jpg
and that is in the wp-content' folder or
..wp-content/ata-images/header/header.jpg
or the full path is
http://testing.selmarcerini.com/wp-c...der/header.jpg

If that is the case you should be able to copy and paste that url into the browser and see the image...but if gets a not found

You might want to check all your .htaccess files and see if there is anything preventing access to that file/folder
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Tags
header error

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Header image disappears on upgrade chalkybones Header configuration & styling 3 Sep 18, 2013 03:23 AM
Header problem following auto upgrade to 3.7.12 quintain Header configuration & styling 13 Jun 18, 2013 04:21 AM
Header image won't display after upgrade JeromeR New Versions, & Updating 3 Apr 7, 2013 01:56 PM
[SOLVED] Header Image Problem after upgrade Jimsplace New Versions, & Updating 4 Sep 6, 2009 10:14 AM


All times are GMT -6. The time now is 11:03 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.