Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

[SOLVED] Old problem comes back: Disappearing Menu in header section


  #1  
Old Dec 16, 2015, 11:18 AM
markzip
 
57 posts · Jan 2010
WP 4.4
Atahualpa 3.7.24
indonesiaetc.com

My header is:
Code:
%logo %image %bar2 %bar2 %bar2 %pages %bar2 %bar2
I am using custom menu in the "pages" location but it has completely disappeared. See screen cap at http://imgur.com/GXA6MlC for what it should look like.

The disappearance was not, as far as I can tell, related to an update. It was working Monday and there have been no updates since then.

1) I have turned off caching plugin and reverted to clean .htaccess
2) Menu re-appears when I switch to default WP 2105 theme or default 2014 theme (Assuming i tell it to use my custom menu) See screencap at http://imgur.com/BxBoCAp
3) If I switch off all plugins it still does not reappear.
4) Have moved something off the menu and saved the new version of the menu. No luck.
5) Have tried assigning the custom menu to the categories spot and changing my header to reflect the new placement. No luck.
6) Have tried constructing a whole new custom menu and putting it in the categories spot in the header. No luck.

Thoughts?
  #2  
Old Dec 16, 2015, 12:27 PM
juggledad's Avatar
juggledad
 
23,545 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Quote:
Have tried constructing a whole new custom menu and putting it in the categories spot in the header. No luck.
It won't show if you use 'menu location 2' since you only have %pages (which is 'menu location 1') in the header Configuration options.

What happens if you point it at 'menu location 1'?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Dec 16, 2015, 12:33 PM
markzip
 
57 posts · Jan 2010
Thanks for the note.
Apologies, I was unclear in my original.
I have built separate but identical custom menus and assigned one to one position and one to the other position.
I have invoked both positions in my header thus
Code:
%logo %image %bar2 %bar2 %bar2 %pages %cats %bar2 %bar2
No luck.

This truly is mysterious.
  #4  
Old Dec 16, 2015, 01:40 PM
juggledad's Avatar
juggledad
 
23,545 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
send me a PM with an admin ID/PW and I'll take a peek
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Dec 16, 2015, 02:11 PM
juggledad's Avatar
juggledad
 
23,545 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
this is also caused by the menu change WP introduced with version 4.4. I just applied the fix described in PATCH 3724-01: Custom Menu/SubMenu issue after upgrading to WP 4.4 and that took care of it.

moral of teh story: Always check to see if there are any patches avaliable.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Dec 16, 2015, 04:15 PM
markzip
 
57 posts · Jan 2010
Gaah!
I only searched in "Page & Category Menu Bars" and "Header configuration & styling".

Marking issue as solved.

Thanks as always.

Bookmarks

Tags
custom menu, header area, menu 1, menu 2

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Accidentally hid the whole header section, not sure how to get it back parker589 Header configuration & styling 1 Dec 16, 2011 09:37 AM
A problem with a disappearing stick blogpost on blogiste since upgrade t stribe Center area post/pages 8 Jun 12, 2011 01:11 PM
PROBLEM: Font only changes in footer section conquestlife Center area post/pages 4 May 9, 2010 07:49 PM
Moving the RSS section to a page menu bar below the header patriciaeddy Header configuration & styling 0 Mar 14, 2010 01:29 PM


All times are GMT -6. The time now is 07:19 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.