Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] PATCH 3724-01: Custom Menu/SubMenu issue after upgrading to WP 4.4


  #1  
Old Dec 15, 2015, 05:28 AM
juggledad's Avatar
juggledad
 
23,560 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
WordPress version 4.4 changed the way the menu structure was returned when using a custom menu. The symptom is that a menu item before a menu with a submenu would show an indicator that there were child items, while the actual parent of the submenu would not show the indicator.

To fix this problem you can eithor (1) edit bfa_new_wp3_menus.php and change line 43 from
HTML Code:
	$newmenu = preg_replace("/<li (.*?)class=\"(.*?)\">(.*?)\n(.*?)<ul class=\"/i","<li \\1 class=\"rMenu-expand \\2\">\\3\n\\4<ul class=\"rMenu-ver ",$newmenu);
to
HTML Code:
	$newmenu = preg_replace("~menu-item-has-children~","rMenu-expand menu-item-has-children",$newmenu);
or (2) download the attached file, unzip it and replace bfa_new_wp3_menus.php with the fixed version.
Attached Files
File Type: zip bfa_new_wp3_menus.zip (760 Bytes, 326 views)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jan 8, 2016 at 04:28 AM.
  #2  
Old Dec 15, 2015, 03:36 PM
kdawes01's Avatar
kdawes01
 
96 posts · May 2009
Missoula, MT
Good fix! Thanks Juggledad!

Do you know many ATA versions back this fix will work for?
__________________
Ken | The Web Mechanic
Many thanks to Flynn for the amazing Atahualpa. Please consider a donation!
  #3  
Old Dec 15, 2015, 03:51 PM
juggledad's Avatar
juggledad
 
23,560 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The code is the same all the way back to 3.7.15 - maybe earlier, but that's the earliest I had on my maching to check with.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Dec 15, 2015, 04:12 PM
kdawes01's Avatar
kdawes01
 
96 posts · May 2009
Missoula, MT
Perfect!

Merci!!!
__________________
Ken | The Web Mechanic
Many thanks to Flynn for the amazing Atahualpa. Please consider a donation!
  #5  
Old Mar 27, 2016, 03:29 AM
SubtleTom
 
1 posts · Mar 2016
Quote:
Originally Posted by jugglerdad
WordPress version 4.4 changed the way the menu structure was returned when using a custom menu. The symptom is that a menu item before a menu with a submenu would show an indicator that there were child items, while the actual parent of the submenu would not show the bathmate indicator.

To fix this problem you can eithor (1) edit bfa_new_wp3_menus.php and change line 43 from
HTML Code:
	$newmenu = preg_replace("/<li (.*?)class=\"(.*?)\">(.*?)\n(.*?)<ul class=\"/i","<li \\1 class=\"rMenu-expand \\2\">\\3\n\\4<ul class=\"rMenu-ver ",$newmenu);
to
HTML Code:
	$newmenu = preg_replace("~menu-item-has-children~","rMenu-expand menu-item-has-children",$newmenu);
or (2) download the attached file, unzip it and replace bfa_new_wp3_menus.php with the fixed version.
I haven't updated wordpress in a long time. If I update wordpress and update to the latest version of Atahualpa will there be a problem with the menus or is this fixed in the latest version?

Last edited by SubtleTom; May 21, 2016 at 03:31 PM.
  #6  
Old Apr 8, 2016, 05:07 AM
juggledad's Avatar
juggledad
 
23,560 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
this patch still applies to teh latest version of Atahualpa
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
PATCH 3710-01: fix export issue when WordPress Address and Site Address are different juggledad Old Version fixes and change logs 0 Dec 21, 2012 06:37 AM
PATCH 378-01: only excerpts showing after upgrading to 3.7.7 or 3.7.8 on some sites juggledad Old Version fixes and change logs 5 Sep 14, 2012 06:08 AM
Padding issue in submenu tsheridan Page & Category Menu Bars 2 Jan 26, 2012 10:47 AM
PATCH 373-01: Fix issue where one word is not translated juggledad Old Version fixes and change logs 0 Dec 9, 2011 06:21 AM
[SOLVED] Submenu dropdown covers rest of submenu - how do i get it to the right? Friland Page & Category Menu Bars 6 Feb 19, 2011 02:37 PM


All times are GMT -6. The time now is 03:04 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.