Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Site suspended by web host - errors in code?


  #1  
Old Nov 26, 2013, 08:20 PM
rpfray
 
9 posts · Mar 2010
Hi all,

I tried to post this in the Gold forum but it doesn't appear to have allowed me, despite being a donor. Anyway...

One of my Atahualpa websites has been suspended by my web host because it became unstable and was hogging bandwidth. In order to get it back again, I have to show the web hosts that I've fixed the problem, or at least know how to. But I don't really understand what the problem is. It might not have anything to do with Atahualpa, but it might, so I thought I'd ask here as I don't have any idea what else to do.

The main error message they are getting are:

[Tue Nov 19 02:34:46 2013] [error] [client 109.73.120.132] PHP Warning: implode() [<a href='function.implode'>function.implode</a>]: Invalid arguments passed in /***/***/public_html/wp-content/themes/atahualpa/js.php on line 43, referer: http://www.teanewsdirect.com/feed/atom/
[Tue Nov 19 02:34:46 2013] [error] [client 109.73.120.132] PHP Warning: array_rand() expects parameter 1 to be array, null given in /***/***/public_html/wp-content/themes/atahualpa/functions/bfa_header_config.php on line 268, referer: http://www.teanewsdirect.com/feed/atom/

I replaced the address of my folders with ***. The website in question is www.teanewsdirect.com, but as it has been suspended, you can't see it at the moment.

Any ideas or suggestions are much appreciated.

Thank you!
  #2  
Old Nov 26, 2013, 08:38 PM
juggledad's Avatar
juggledad
 
23,648 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What version of atahualpa and wp?
Who is the host?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Nov 27, 2013, 02:05 AM
rpfray
 
9 posts · Mar 2010
Latest, fully updated versions of Atahualpa, WordPress and all plugins.

Host is Network Redux.

Thanks for your time.
  #4  
Old Nov 27, 2013, 05:23 AM
juggledad's Avatar
juggledad
 
23,648 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Saying 'the latest version' really doesn't help.
What are the actual version numbers.

How many images do you have in the 'wp-content/themes/atahualpa/images/header' folder?
do you have a folder 'wp-content/ata-images/header' folder? if so how many images in it?

[please only post once - there is an issue with posts being moderated and Flynn is looking into it]
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Nov 27, 2013, 06:56 PM
rpfray
 
9 posts · Mar 2010
As I can't get onto the account, it's difficult to answer these questions accurately, but here's what I can say.

All my websites are updated at the same time, so they all use the same versions of WP, Atahualpa, etc. Checking on another site, I'm using:

Atahualpa version 3.7.12
WordPress version 3.7.1

I'm pretty sure I've only got one image in the header folder, but I can't check. I can't remember if I have an 'ata-images/header' folder or not, but I do on some of my other sites.

I'll ask the hosts if they can allow me access to at least check these things.

I've also got a whole string of information from Network Redux - would that help?

Again, thanks for taking the time. It's much appreciated.
  #6  
Old Nov 27, 2013, 07:04 PM
juggledad's Avatar
juggledad
 
23,648 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The code the messages point to is the rotating header code - which is why I ask about the images. If you can get to file manager via cPanel, you should be able to look at the folders in question. make sure any file names have no spaces.

that's all I can tell you without more information.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Dec 1, 2013, 07:22 PM
rpfray
 
9 posts · Mar 2010
I think this is fixed now, but will have to leave it a few days to see if it occurs again.

I persuaded the web host to un-suspend the account so I could see what was going on. I'd forgotten that, on this site, I'd used the overlay header image feature and added my own html so I could have a split header with an ad. Apparently the ad, which was hosted on a third party site, is no longer active and wasn't being shown, presumably resulting in lots of 404s and other errors, the server being overloaded and the account suspended.

I've replaced the ad with an image hosted on my site, which should remove the problem. It's all up and running again: www teanewsdirect com

If I get more problems of this nature in the future, I'll start a new thread if this one is closed.

Many thanks for pointing me in the right direction

Last edited by juggledad; Dec 2, 2013 at 03:38 AM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Moved site to different host but image URLs still point to the old one GrahamW Atahualpa 3 Wordpress theme 6 Aug 19, 2012 06:21 PM
Can I use wordpress to host a domain that I purchased on another site? Jeromens Web Hosting for WordPress 1 Nov 23, 2010 04:27 AM
[SOLVED] Scared to move site from my computer to host Andante New Versions, & Updating 4 Mar 22, 2009 06:39 PM


All times are GMT -6. The time now is 09:28 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.