Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Moved site to different host but image URLs still point to the old one


  #1  
Old Aug 19, 2012, 05:09 PM
GrahamW
 
101 posts · Jul 2010
I am helping a friend to set up her website. We developed it on my host's server, and then moved it to hers (never again!). I thought I followed the codex instructions carefully, and everything seemed to be all right, but now we've discovered that the image urls are all still pointing back to the old server. Is there anything I can do to change this in one go rather than having to edit every image?

Thanks
Graham
  #2  
Old Aug 19, 2012, 05:13 PM
juggledad's Avatar
juggledad
 
23,631 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I would have used Backup Buddy that can move teh whole site and take care of issues like this.
Did you try a google search for help with this?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Aug 19, 2012, 05:22 PM
GrahamW
 
101 posts · Jul 2010
Sorry... on closer inspection, it is not the image URLs that have not updated it is the hyperlinks associated with the images.
  #4  
Old Aug 19, 2012, 05:25 PM
GrahamW
 
101 posts · Jul 2010
Quote:
Originally Posted by juggledad
I would have used Backup Buddy that can move teh whole site and take care of issues like this.
Did you try a google search for help with this?
I wish I'd known that before. When I was getting ready to do it I searched this forum for tips and all I found were messages from you referring people to the codex. It's OK, but it does seem to make things complicated.

Yes, I tried Googling but most of the replies seemed to think this was something to do with particular themes - hence my message here.

Cheers
Graham
  #5  
Old Aug 19, 2012, 05:27 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I have used the Search and Replace plugin for that type of thing. Just be sure and double and triple check the spelling of the from and to URLs.

I would also suggest experimenting with the plugin on a test site along with having a backup of your site.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Aug 19, 2012, 05:31 PM
juggledad's Avatar
juggledad
 
23,631 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
the hyperlinks are stored in the database.

When I've moved a site like that I would always take the export and do a global change of 'olddomain.com' to 'newdomain.com' - the problem comes when the domain names are not the same length. This is why they tell you to change the dashboard->settings->general->WordPress Address (URL) and Site Address (URL) to the new site BEFORE exporting the DB then all the links should be correct.

Thein is once you do that, you can't get back into the old site unless you use phpMyAdmin t change the values back to 'olddomain.com'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Aug 19, 2012, 06:21 PM
GrahamW
 
101 posts · Jul 2010
Ok

Thanks guys. I used the "search and replace" plugin - though I didn't trust it entirely so I used the search function just to make sure I knew how many of the wrong ones there were, and then I edited the pages manually using the S&R function on Notepad++.

It's worked out fine.

Many thanks for your very prompt support.

Best wishes
Graham

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Moved Host, Atahuapa displaying inline js. Can you help? chaten Atahualpa 3 Wordpress theme 5 Nov 11, 2011 09:23 AM
Can I use wordpress to host a domain that I purchased on another site? Jeromens Web Hosting for WordPress 1 Nov 23, 2010 04:27 AM
[SOLVED] Scared to move site from my computer to host Andante New Versions, & Updating 4 Mar 22, 2009 06:39 PM


All times are GMT -6. The time now is 06:40 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.