Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

Removing Font Switching


  #1  
Old Aug 22, 2013, 04:27 PM
plowboy
 
7 posts · Aug 2013
When my website loads.. the <h> tagged text (the title, the post titles, etc.. <h1>, <h2>, <h3> etc) first load in a large alternate font than is default.. and then are changed to the correct font after the page loads..

which for low bandwidth users, sometimes results in no switch at all :/

..is there a way to get these to load in the correct font without the switch?
  #2  
Old Aug 22, 2013, 05:31 PM
juggledad's Avatar
juggledad
 
23,575 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
go to MTO->CSS Settings->Add Google Fonts and blank out the google font and hit save
  #3  
Old Aug 22, 2013, 06:31 PM
plowboy
 
7 posts · Aug 2013
Quote:
Originally Posted by juggledad
go to MTO->CSS Settings->Add Google Fonts and blank out the google font and hit save
When I do this.. now it only loads in the pre-switch font..

Is it possible to have it only load in the default font only.. without a switch

The default <h> font is..

Code:
h1, h2, h3, h4, h5, h6 {
	font-family: 			'Yanone Kaffeesatz', sans-serif;
	font-weight: 			normal; 
	margin: 					20px 0 10px 0;
}

EDIT:

I removed the Google Font code like you suggested.. and added the following code into the header, it seems it may have fixed it

Code:
<script type="text/javascript">
  WebFontConfig = {
    google: { families: [ 'Yanone+Kaffeesatz:400,200:latin' ] }
  };
  (function() {
    var wf = document.createElement('script');
    wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
      '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
  })(); </script>

<script type="text/javascript">
I don't always experience the issue I was having, so I don't know if this issue is 100% resolved yet..

If I see it in the future, I'll come back..

or.. if there are alternative solutions available, I'd be willing to try them in the mean time

Last edited by plowboy; Aug 22, 2013 at 07:09 PM.
  #4  
Old Aug 22, 2013, 10:15 PM
plowboy
 
7 posts · Aug 2013
Quote:
Originally Posted by plowboy
When I do this.. now it only loads in the pre-switch font..

Is it possible to have it only load in the default font only.. without a switch

The default <h> font is..

Code:
h1, h2, h3, h4, h5, h6 {
	font-family: 			'Yanone Kaffeesatz', sans-serif;
	font-weight: 			normal; 
	margin: 					20px 0 10px 0;
}

EDIT:

I removed the Google Font code like you suggested.. and added the following code into the header, it seems it may have fixed it

Code:
<script type="text/javascript">
  WebFontConfig = {
    google: { families: [ 'Yanone+Kaffeesatz:400,200:latin' ] }
  };
  (function() {
    var wf = document.createElement('script');
    wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
      '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
  })(); </script>

<script type="text/javascript">
I don't always experience the issue I was having, so I don't know if this issue is 100% resolved yet..

If I see it in the future, I'll come back..

or.. if there are alternative solutions available, I'd be willing to try them in the mean time
Alright.. I have discovered my fix did not solve this issue..

Any more advice would be appreciated..

I want the font to load on its own, without a switch.. is this possible?
  #5  
Old Oct 29, 2013, 01:47 PM
CrouchingBruin's Avatar
CrouchingBruin
 
299 posts · Aug 2010
Santa Monica, CA
I may have found a solution.

If you are using the default Yanone Kaffeesatz font family and weights (200 & 400) in your Montezuma site, then copy & paste this line into Appearance > Montezuma Options > Head > Insert Code > Top:
Code:
<link href='http://fonts.googleapis.com/css?family=Yanone+Kaffeesatz:400,200' rel='stylesheet' type='text/css'>
If you are using a different Google font, or additional Google fonts, then go to the Google Fonts site, look for the font(s) that you are using (there's a filter field in the left sidebar), and add the fonts to your "collection." When you're done choosing all of your fonts, click the Use button. Make sure all of the weights that you want are checked off for each font in section 1. Copy & paste the line in section 3 into the Top field as described above.
__________________
My Montezuma-themed sites: ESHS Girls Basketball Team, Venice Hongwanji Buddhist Temple
Please consider making a donation to BytesForAll for their great themes!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] My post images are missing after switching to ATA 3.7.3 scottpollack Forum How-To 14 Mar 16, 2012 01:53 PM
Switching the logo placement Daniel Hurtubise Header configuration & styling 2 Aug 24, 2010 02:18 PM
How do I change the font color of the post/pages font and the title font? GreenEyedMonst Center area post/pages 0 Jan 16, 2010 03:06 PM


All times are GMT -6. The time now is 07:50 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.