Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

Upgrading from WP 2.9.2 and Atahualpa 3.4.6


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jan 6, 2013, 06:43 AM
philrey212
 
5 posts · Jan 2013
Hello,
After spending too many hours trying to upgrade both theme and WP, I turn myself to you for some help.
I'd like to update WP from 2.9.2 to 3.4 or 3.5.
At the same time, I'd like to upgrade the Atahualpa theme from 3.4.6 to a more recent version.
I downloaded everything locally to do some testing so I can't show you anything.
Here is what I tried:
1) Keep current WP version and manually upgrade to Atahualpa 3.7.1
--> When I click the Activate link in the wp back end, I get a server error:
The website encountered an error while retrieving http://localhost:8888/vindjeuprd3/wp...activated=true. It may be down for maintenance or configured incorrectly.
HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

2) Keep current WP version and manually upgrade to Atahualpa 3.5.1
I figured that may be the step was to big so I manually updated to Atahualpa v3.5.1. Here, all looks fine in the back-end bat when reloading the page, all is blank (except the background color)
I still have control on the back end so I switch back to 3.4.6 and all is back to normal.

Could you advice on how to proceed? Should I try an earlier version?
I di-activated all plugins, in case of.
Should I upgrade WP first and then Atahualpa?
For info, here are the plugins I use:
Simple Tags 1.7.4.4
Shortcode Exec PHP 1.1
More Fields 1.5.1
Alphabetical list 1.0.3
Wordpress PostViews 1.62
StatTraq 1.3.0

I hope you can help.
Thanks in advanced.
Phil
  #2  
Old Jan 6, 2013, 11:39 AM
juggledad's Avatar
juggledad
 
21,714 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
1) Do a database backup
2) disable ALL plugins
3) swap to twenty-ten
4) upgrade WordPress
5) check that your posts are there
6) do a database backup
7) upgrade Atahaualpa
8) activate Atahualpa
9) re-enable your plugins.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #3  
Old Jan 7, 2013, 08:19 AM
philrey212
 
5 posts · Jan 2013
Thanks for your feedback.
There is no Twenty Ten Theme with WP 2.9.2.
I tried installing the Twenty Ten theme from WP 3.1.1 but I get the same as for the Atahualpa 3.5.1
I'll try with the default one then.
One question though: would Atahualpa 3.4.6 will work with WP 3.1.1?
If yes, I can try to keep the current version and upgrade WP.
I'll try that too and I'll keep you posted of all the results.
I do have some concerns about the Simple Tags plugin though.
  #4  
Old Jan 8, 2013, 04:47 AM
juggledad's Avatar
juggledad
 
21,714 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Actually you should be able to upgrade both WP and Atahualpa. I was suggesting you swap to the default theme (I forgot it is the 'classic' or 'default' back then) to do it one step at a time.

the issues you may run into are
1) if you modified any of the themes actual code - you will have to re do that
2) if you are using any of the themes new widget areas - they are not allowed in some of the options any more (wordpress requirement) and may have to be moved into the index.php.
3) you may need to re-apply your widgets to the widget areas
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Jan 9, 2013, 03:09 AM
philrey212
 
5 posts · Jan 2013
I currently was able to keep Atahualpa v3.4.6 and upgrade WP to v3.1.1 RC1.
I also upgraded some plugins such as Simple Tags as Shortcode Exec PHP.
So that's already a step forward.
I don't remember if I had to modify any files from the theme. I don't think so but I'll check.
I know that I added some code in the Atahualpa byline post config to display the extra info in the posts. (related to More Fields and Simple Tags plugins).

What do you mean by: 2) if you are using any of the themes new widget areas - they are not allowed in some of the options any more (wordpress requirement) and may have to be moved into the index.php?
What is a new widget area?
  #6  
Old Jan 9, 2013, 03:33 AM
juggledad's Avatar
juggledad
 
21,714 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Quote:
What do you mean by: 2) if you are using any of the themes new widget areas - they are not allowed in some of the options any more (wordpress requirement) and may have to be moved into the index.php?
What is a new widget area?
if you don't know what it is you probably didn't use it. See 'ATO->Add new WIDGET AREAS' - if in the 'Delete custom Widget Areas' option nothing is showing, then you don't have any.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #7  
Old Jan 11, 2013, 08:51 AM
philrey212
 
5 posts · Jan 2013
Thanks for your reply again.
No, you're right, I don't have any new widget area.

Now, I managed to upgrade wp to v3.4.2.
I can now preview Atahualpa v3.7.1.
The only issue I still have to resolve to do the upgrade is that the custom taxonomies I use don't show any more.
The following lines are inserted in the functions.php:
// Custom taxonomy (by Justin Tadlock)
add_action( 'init', 'create_my_taxonomies', 0 );

function create_my_taxonomies() {
register_taxonomy( 'annee', 'post', array( 'hierarchical' => false, 'label' => 'Annee', 'query_var' => true, 'rewrite' => true ) );
register_taxonomy( 'auteurs', 'post', array( 'hierarchical' => false, 'label' => 'Auteurs', 'query_var' => true, 'rewrite' => true ) );
register_taxonomy( 'editeurs', 'post', array( 'hierarchical' => false, 'label' => 'Editeurs', 'query_var' => true, 'rewrite' => true ) );
}


And this is how it is display in the post' BYLINE area:
<strong><?php echo get_the_term_list( $post->ID, 'annee', 'Année: ', ', ', '' ); ?> | de %meta('joueursmin')% à %meta('joueursmax')% joueurs | <?php echo get_the_term_list( $post->ID, 'auteurs', 'Auteur(s): ', ', ', '' ); ?> | <?php echo get_the_term_list( $post->ID, 'editeurs', 'Editeur(s): ', ', ', '' ); ?></strong>
<br /><strong>Explication des règles: </strong>%meta('regles')% ' |
<strong>Durée de la partie: </strong>%meta('partie')% '</>


All works fine with Atahualpa 3.4.6 but not with 3.7.1.
I suspect some method changed somewhere in between that I need to adapt?
Any thought?

Again, many thanks.
  #8  
Old Jan 11, 2013, 10:05 AM
juggledad's Avatar
juggledad
 
21,714 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
the code added to functions.php is fine, but you can't have php in the theme options anymore - a WordPress requirement.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #9  
Old Jan 11, 2013, 02:55 PM
philrey212
 
5 posts · Jan 2013
That's why it doesn't work anymore.
Hmmm, I'll have to find something else but frankly, I don't know what.
I guess you can close the thread.
Many thanks.
  #10  
Old Jan 11, 2013, 05:43 PM
juggledad's Avatar
juggledad
 
21,714 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
You could
1) install the 'exec-php' plugin then
2) put a new widget area into the buyline and then
3) add a text widget with your code
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Bookmarks

Tags
atahualpa 3.4.6, upgrade 3.4.6, wordpress 2.9.2

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Why I Hate Upgrading Atahualpa ctoews New Versions, & Updating 29 Feb 27, 2013 06:23 PM
Web Site doesn't display after upgrading Atahualpa from 3.4.9 to 3.6 desoda New Versions, & Updating 16 Jan 18, 2011 03:23 PM
Upgrading from Wordpress 2.9.2 and Atahualpa 3.4.6 cfibanez New Versions, & Updating 5 Jul 10, 2010 06:00 AM
Upgrading Atahualpa from one release to another gmr1970 New Versions, & Updating 9 Jan 15, 2010 05:07 AM
Upgrading to WP 2.8.4, still using Atahualpa 3.2 paulae Installing & running WordPress 0 Sep 6, 2009 11:40 AM


All times are GMT -6. The time now is 11:45 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.