Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Includes not working after a move to a new host


  #1  
Old Jul 24, 2012, 11:33 PM
Graveyard Shifter
 
24 posts · Dec 2009
After moving WordPress to a new host some strange problem appeared that prevents my Atahualpa 3.6.4 theme to display correctly. Basically what I see after a page load is an empty page with just a background. Tracing this problem I discovered that the cause is an include statement on line 18 in header.php that fails to execute correctly:
PHP Code:
    <?php if( $bfa_ata['html_inserts_header'] != '' ) include 'bfa://html_inserts_header'?>
On the old host it was loading a css stylesheet which is defined in HTML Inserts: Header section of Atahualpa Options. On the new host it loads nothing and causes a termination in a page load process which means that a page generated is blank except some HTML header statements that goes before this include statement, all statements after line 18 are not executed at all.

Trying to investigate further I commented this include statement out and a page was generating as expected until the next include statement <?php include 'bfa://html_inserts_body_tag'; ?> which is on line 21.

So my guess is that include 'bfa://html_inserts_...' statements does not work on a new host for some reason. Not new to WordPress, I moved WP to other hosts several times before without any issues.

Turning on WP_DEBUG gave me no messages.

Is this some kind of server configuration issue? How does exactly include 'bfa://html_inserts_header' work? I used include statement with php or other file name only. How does exactly 'bfa://html_inserts_header' resolve? Is this some kind of symbolic link?

Will be grateful to anybody who may shed some light on this weird issue ...
  #2  
Old Jul 25, 2012, 02:55 AM
juggledad's Avatar
juggledad
 
23,671 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Thiis is probably the suhosin issue (do a search on suhosin for more info) I would suggest upgrading to 3.7.7 which doesn't use the include but you loose the ability to include php in most theme options (wordpress restriction)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jul 25, 2012, 08:55 AM
Graveyard Shifter
 
24 posts · Dec 2009
Yep, that's certainly a suhosin, because Atahualpa version 3.7.7 works well.
It's all clear now. Thank you, juggledad!

Bookmarks

Tags
header, include

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
WP Atahualpa and other themes not working properly on new host peter achutha Atahualpa 3 Wordpress theme 8 Mar 1, 2012 03:29 AM
[SOLVED] Background image not working... running on local host robpaterson23 Atahualpa 3 Wordpress theme 1 Jun 19, 2010 09:41 PM
[SOLVED] Atahualpa not working with Yahoo Web Host SiberianSiren5 New Versions, & Updating 3 Mar 26, 2010 11:45 AM
Will your configurations follow when you move your host? GustavK New Versions, & Updating 1 Mar 7, 2010 02:47 PM
[SOLVED] Scared to move site from my computer to host Andante New Versions, & Updating 4 Mar 22, 2009 06:39 PM


All times are GMT -6. The time now is 03:08 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.