Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » eCommerce & Atahualpa »

Can't get rid of comment box on product pages wp-e-commerce


  #1  
Old Jul 14, 2012, 03:58 PM
Harald
 
72 posts · Mar 2010
I have a problem regarding comment box on all single product pages with wp-e-commerce. I have disabled comments in settings and no comment box is present on "normal" pages, but on all single productpages. The other thing is that I can't turn comments off individually either because the is no checkbox for on the wp-e-commerce generated pages. I don't know what to do.

I use:
Wordpress 3.4.1
Atahualpa 3.7.7
wp-e-commerce 3.8.8.5

and this is a link to a product page http://www.aferdsjo.se/?wpsc-product=KTA-XE667K2-4G

Please let me know if you have any suggestions on how to solve this.
  #2  
Old Nov 25, 2013, 05:25 PM
dwsproduction
 
5 posts · Nov 2013
This one stumped me for a while too. Even upgrading to the correct WP e-commerce version that supposedly fixed this, removing out the comments code for the theme had no effect.

But I did find a solution for my particular problem (characterised by some products having a comments box and some not):

Try editing the actual product, go down to Advanced Settings, and right at the bottom of this section use the dropdown menu under Enable Comments and change it to No.
  #3  
Old Aug 6, 2014, 09:58 PM
dwsproduction
 
5 posts · Nov 2013
[solved] WP e-Commerce - Single products showing comments box

After I upgraded WP e-Commerce 3.8.7.6.2 to 3.8.14.1 all the comment boxes reappeared, and there was no option in each product to turn the comments back off.

Here are two solutions I found;

1. On each product edit page, Under Product Details go to Metadata and add a new item;
Name: comments
Value: no

Click save. Done.

Of course this is not going to be a quick job if you have a lot of products.

2. In the theme settings add this custom CSS;
.single-wpsc-product #respond {
display: none;
}

This hides all the comment boxes from display on all single product pages. Since the form is merely hidden, auto spam bots will still be able to access it, in which case you'll need to install some kind of comment spam blocker.

If anyone else has encountered this, and has a different solution, I'd love to hear about it.

Michael

Last edited by juggledad; Aug 7, 2014 at 03:01 AM.

Bookmarks

Tags
product comments, product page comments, single product comments, wp e-commerce comments

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Add sidebar to new pages created by Woo Commerce? moomum Sidebars & Widgets 5 Sep 12, 2013 01:18 AM
[SOLVED] WP e-commerce + ATA = Category Pages broken mafgirl eCommerce & Atahualpa 25 Dec 6, 2012 06:47 AM
[SOLVED] Widget does not show on product page in wp-e-commerce Harald Sidebars & Widgets 6 Jul 14, 2012 05:58 AM
How to Display Right Column & Comment form on Product Page - (Using FoxyShop Plugin) agusbagus eCommerce & Atahualpa 5 Jun 8, 2011 08:14 AM
Styling product page in Atahualpa (using WP e-Commerce plugin) igrowkids eCommerce & Atahualpa 5 Jul 26, 2010 03:22 PM


All times are GMT -6. The time now is 09:40 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.