Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

after upgrade to 3.7.1, my search (plugin Relevanssi) times out with error


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Oct 27, 2011, 07:08 AM
owc
 
19 posts · May 2011
After I upgraded from ATA 3.6.4 to the new version 3.7.1 my search doesn't work anymore:

Fatal error: Maximum execution time of 90 seconds exceeded in /var/www/domain.com/wp-content/themes/atahualpa/functions.php on line 296
  #2  
Old Oct 27, 2011, 07:52 AM
juggledad's Avatar
juggledad
 
22,324 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
what is the url?
who is the host?
do other functions work?
How big is the database (how many posts)
when was the last time you optimized the db?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Oct 27, 2011 at 09:23 AM.
  #3  
Old Oct 27, 2011, 09:08 AM
owc
 
19 posts · May 2011
It seems to have to do with the plugin Relevanssi. When I deactivate it, the search runs fine again. When I activate it, after a long time of waiting the error message above occured. Before the upgrade I didn't had such problems. Both, Atahualpa and Relevanssi worked fine together. So what to do now? Was there any change in the new ATA version that might cause this error?
  #4  
Old Oct 27, 2011, 09:15 AM
juggledad's Avatar
juggledad
 
22,324 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
have you built the index. I wonder if changing themes (an update is seen by wordpress as changing the theme) cause an index issue with the plugin.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Oct 27, 2011, 09:20 AM
owc
 
19 posts · May 2011
Of course I have build the index. I also uninstalled and deleted the plugin and installed it anew, but nothing changes...
  #6  
Old Oct 27, 2011, 09:23 AM
juggledad's Avatar
juggledad
 
22,324 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I just tested it on my site and it works fine.
can you answer my questions from post #2
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Oct 27, 2011, 09:39 AM
owc
 
19 posts · May 2011
sorry, no url, i host it by myself. other functions work properly so far. 200 posts, 150 custom posts, 50 pages and some other stuff. The database has a size of about 40 MB and is optimized every day.

Btw. I tried out Twenty Eleven Theme with Relevanssi activated and it runs fine. So I suppose the error must have to do with ATA?!
  #8  
Old Oct 27, 2011, 09:58 AM
juggledad's Avatar
juggledad
 
22,324 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
well I tried it with Atahualpa 3.7.1 and it worked fine for me, You might want to contact the plugin author and see if they have any ideas.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Oct 27, 2011, 10:16 AM
owc
 
19 posts · May 2011
I don't think that this is a Releanssi issue. I downgraded back to ATA 3.6.4 and now Relevanssi and Atahualpa run together again very fine, without any problems.
  #10  
Old Oct 27, 2011, 10:48 AM
juggledad's Avatar
juggledad
 
22,324 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
does it always time out and show the same line number in functions.php?
do all searches time out?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #11  
Old Oct 27, 2011, 10:57 AM
owc
 
19 posts · May 2011
yes, exactly that is the behaviour.
  #12  
Old Oct 27, 2011, 11:44 AM
juggledad's Avatar
juggledad
 
22,324 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
so if you search for something that doesn't exist, it still fails. That is very odd, the line the failure shows up on has nothing to do with the searching, it is doing a preg_split on the text it is passed to create an excerpt.

Since this is a local host have you checked for other errors? out of memory etc.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #13  
Old Nov 18, 2011, 11:04 AM
owc
 
19 posts · May 2011
I have the caching activated in Relevanssi. Maybe that is the reason?
  #14  
Old Nov 18, 2011, 12:29 PM
juggledad's Avatar
juggledad
 
22,324 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
could be, try shutting it off
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
FastCGI Error after upgrade from 3.4.9 to 3.6.4 knottinbotswana New Versions, & Updating 1 Feb 20, 2011 12:14 PM
Error after upgrade to 3.6.1 enri1968 New Versions, & Updating 8 Feb 7, 2011 05:18 AM
SEARCH ERROR: Catchable fatal error:Object of class WP_Error could not be converted angelarose Plugins & Atahualpa 3 Jul 8, 2010 06:05 PM
Search Unleashed plugin and fatal error perdox808 Plugins & Atahualpa 1 Apr 23, 2009 01:39 PM


All times are GMT -6. The time now is 12:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.