Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Background graphic file loads first in page transitions


  #1  
Old Apr 8, 2011, 10:49 AM
windhover4's Avatar
windhover4
 
102 posts · May 2010
Fort Lauderdale
Juggledad Genius,

Your posts have been my rock for more than two years. I am stuck on BFA and Juggledad.

Problem: the 1494 x 319 background graphic file (only one I like) loads first in actual size in the upper left side of the screen briefly before the page content comes up. This happens every time you change Menu links. Is there any way to adjust the CSS Insert to avoid this distraction?

I have a new site: http://wiltonsuites.com using the fabulous Atahualpa Theme. I followed some advise found on the forum and got the following CSS Insert to work:

img#bg {
position:fixed;
top:0;
left:0;
width:100%;
height:100%;
}

#wrapper {
position:relative;
z-index:1;
}
div#menu1 ul.rMenu {
background-color: transparent !important;
}

ul.rMenu li a:link, ul.rMenu li a:active,
ul.rMenu li a:visited, ul.rMenu li {
background: transparent !important;
}

ul.rMenu li a:hover {
background: transparent !important;
}


Cheers,
Ray

Last edited by lmilesw; Apr 11, 2011 at 09:51 AM.
  #2  
Old Apr 8, 2011, 03:14 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I get a server not found on that link
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Apr 9, 2011, 04:17 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I tried replicating your configuration and I did not get the original image showing first like on your site. Not sure what to tell you.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #4  
Old Apr 11, 2011, 08:49 AM
windhover4's Avatar
windhover4
 
102 posts · May 2010
Fort Lauderdale
My server is iXWebHosting. Concerned that you say you get a different server. Please look at my site info: Attachment 1277
  #5  
Old Apr 11, 2011, 09:11 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The URL for your site is misspelled

where did you put the line of code
HTML Code:
<img src="http://wiltonsuites.com/wp-content/themes/atahualpa/images/bg.jpg" id="bg" />
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Apr 11, 2011, 11:11 AM
windhover4's Avatar
windhover4
 
102 posts · May 2010
Fort Lauderdale
I put the background image file named bg.jpg in the following location in my web shell:

/wiltonsuites.com/wp-content/uploads/bg.jpg
  #7  
Old Apr 11, 2011, 11:21 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
No you didn't read what I asked. The location of the FILE doesn't matter. Where in the Atahualpa theme options did you put that html statement? (it was probably in teh 'Add HTML/CSS Inserts' somewhere)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Apr 11, 2011, 11:48 AM
windhover4's Avatar
windhover4
 
102 posts · May 2010
Fort Lauderdale
Ooooops

I had it in the HTML Inserts: Header
I moved it to HTML Inserts: Body Top

It seems to be working much smoother now.

Thank you so much.

Bookmarks

Tags
background images

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Upgrade Loads 2 Headers cltaylor Header configuration & styling 13 Feb 16, 2011 11:56 AM
hardcode a graphic for main page above the loop? talynndar Center area post/pages 3 Aug 31, 2010 01:25 PM
Background won't load in IE8, but loads fine in Firefox ktaylor310 Header configuration & styling 6 May 6, 2010 01:36 PM
[SOLVED] Rollover Graphic in Header Whatsthatcat? Header configuration & styling 2 Sep 25, 2009 07:51 AM
Recommended File Size for Background Images Jcasteli Atahualpa 3 Wordpress theme 1 Jun 10, 2009 05:14 AM


All times are GMT -6. The time now is 05:23 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.