Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] bloginfo() fails


  #1  
Old Apr 8, 2011, 12:11 PM
jbrown13
 
10 posts · Feb 2011
What would prevent the php function bloginfo from working correctly? The following line in ATO > Body, Text & Links > Body Style fails to fill the page background with the image file:
Code:
background: #AAFFAA url('<?php bloginfo('template_url'); ?>/images/cslbackground.gif') repeat-x top left;
When I check the source code for the page as displayed, it shows this where the background style should be:
Code:
background: #AAFFAA url('<?php bloginfo('template_url'); ?>/images/cslbackground.gif') repeat-x top left;
I tried putting
Code:
<?php bloginfo('show'); ?>
in the text of a new page and previewing the page; nothing is displayed.

I just got done fixing the Suhosin blank page issue. Is this related?

My environment: Wordpress 3.1 & Atahualpa 3.6.4.

Thanks...

JGB
  #2  
Old Apr 9, 2011, 03:13 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
That has to do with the required use of stream wrappers. You need to use a relative path such as shown by the example above the Body Style box.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Apr 11, 2011, 11:06 AM
jbrown13
 
10 posts · Feb 2011
I am not sure I follow you, Larry. Are you saying that it is not possible to use the bloginfo() function in the Body Style option?

Thanks...

JGB
  #4  
Old Apr 11, 2011, 01:15 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Yes... there some php code doesn't work as it used to because of changes to the WordPress requirements although I am not sure that the code you are trying ever worked in that area. I would just use as the example shows... A relative path
HTML Code:
background: url(/wp-content/themes/atahualpa364/images/backgr.gif) repeat top left;
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Apr 12, 2011, 09:21 AM
jbrown13
 
10 posts · Feb 2011
Thanks for the clarification, Larry. At least I do not have to bang my head against this particular wall any longer.

JGB

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pls help me change this code<title><?php bloginfo('name'); ?><?php wp_title(); ?></ti tobywinn Header configuration & styling 1 Nov 18, 2011 11:51 AM
How do i change the bloginfo(‘name’) to always show recent post title instead winnox Header configuration & styling 7 Sep 22, 2010 12:28 PM
[SOLVED] wp-admin login fails, changed default directory roekoe Page & Category Menu Bars 2 Nov 14, 2009 09:37 AM
Logout link in footer fails in WP2.7 BradBrown Atahualpa 3 Wordpress theme 3 May 24, 2009 04:10 PM


All times are GMT -6. The time now is 07:36 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.