Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Tried to change bfa_header_config.php now site down


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Feb 6, 2011, 09:58 PM
tokshra's Avatar
tokshra
 
12 posts · Oct 2010
I was trying to put an image in the header section of my site: umarketingu.com...through the editor.

I always make a copy of code in case I mess something up...and I still have that...BUT as soon as I updated, my site is completely down.

When I go into cpanel, there is not much left of the atahul 353 site....when entering URL I get the following error message:
Parse error: syntax error, unexpected '<' in /home/quickpen/public_html/umarketingu.com/wp-content/themes/atahualpa/functions/bfa_header_config.php on line 146

I can't even login to my blog, just get the error message....can you tell me how to get this back? As I said, I have the original code, but can't access the site to change it back.

I was using the editor: bfa_header_config.php/ What is ecode?
  #2  
Old Feb 6, 2011, 10:13 PM
lmilesw's Avatar
lmilesw
 
10,082 posts · Jul 2009
Central New York State USA
All the editing for the Atahualpa theme should, for the most part, be done in the theme options. If you edited your bfa_header_config.php file I would suggest the following.
  • Download a copy of the same version of the theme you installed
  • Unzip it
  • Replace your current bfa_header_config.php with the one from the downloaded copy
  • You should now be able to access your site.
  • Now look through the theme options for information on where to put header images, etc.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Feb 6, 2011, 10:32 PM
tokshra's Avatar
tokshra
 
12 posts · Oct 2010
The files are all gone on cpanel...I cannot login to the site the normal way as the login screen won't come up? So, where do I upload the theme to? All the directories in cpanel are empty...?
  #4  
Old Feb 6, 2011, 11:04 PM
tokshra's Avatar
tokshra
 
12 posts · Oct 2010
I would just change themes if I could get into my site...can you tell me how to do that to change the theme?
  #5  
Old Feb 7, 2011, 04:10 AM
juggledad's Avatar
juggledad
 
22,160 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
You need to FTP to the site. If cpanel has an FTP section, you can use that. If you delete the Atahualpa folder from the 'wp-config/themes' folder, WordPress will default back to the Twenty-Ten theme (as long as you haven't deleted it). If you have FTP access you can also go into the Atahualpa folder and rename'index.php' to 'oldindex.php' and you should default back to twenty-ten.

Using the WordPress editor and making a change to one module of Atahualpa can not effect the other modules. If it did, I would get a new host.

('e code' was a mistyping of 'the code')
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Feb 7, 2011 at 04:12 AM.
  #6  
Old Feb 7, 2011, 07:40 AM
tokshra's Avatar
tokshra
 
12 posts · Oct 2010
OK, here's what I did...uploaded theme version 3.53 to my server (the files were all empty from the other one)...changed index.php to oldindex.php...still get the same error message?

I have not deleted 20/10, it's still there on server...do I need to change index.php to oldindex.php on all the themes?

This site is 3 years worth of content..I really don't want to lose all of it...yes, I have a backup, but it won't upload either.

I am really getting frustrated with this.
  #7  
Old Feb 7, 2011, 07:55 AM
juggledad's Avatar
juggledad
 
22,160 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Ok, take a deep breath, your data should be safe because it is in the database, not the theme files.
You do do regular database backups...right?

you should have a folder called wp-content
--wp-content
in it is the themes folder
--wp-content
----themes
In that folder you will find a file called index.php (don't touch this) and some other folders
--wp-content
----themes
------index.php
------atahualpa
------twentyten
in the atahualpa fold are a bunch of files and folders. One of the filed is called 'index.php'. This is the file that starts of the processing for the theme and every theme has one. If you change it's name (like from index.php to oldindex.php) the theme can not run and WordPress will switch to the TwentyTen theme.

If you haven't added any images to the Atahualpa folder, you can just delete the folder and it's contents. When WordpPress tries to activate it, it will realize it is not there and will switch to...you guessed it, the TwentyTen theme (his is why you never get rid of the default theme).

You can then reinstall Atahualpa and re-activate it. Your styling will all be there because it is stored in the database.

(you did do a database backup right?
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #8  
Old Feb 7, 2011, 08:10 AM
tokshra's Avatar
tokshra
 
12 posts · Oct 2010
I have done all that....yes, I have a backup (was daily until this happened, so it is a couple of days old now)....I still can't login?

I deleted the Atahualpa 3.53 and re-uploaded still nothing....still getting the same message when trying to login: [i]Parse error: syntax error, unexpected '<' in /home/quickpen/public_html/umarketingu.com/wp-content/themes/atahualpa/functions/bfa_header_config.php on line 146 [i]

It doesn't revert back to 20/10
  #9  
Old Feb 7, 2011, 08:12 AM
tokshra's Avatar
tokshra
 
12 posts · Oct 2010
Never mind, I contacted my host and they corrected whatever was wrong. Thanks for your help, I will be making a donation!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pls help me change this code<title><?php bloginfo('name'); ?><?php wp_title(); ?></ti tobywinn Header configuration & styling 1 Nov 18, 2011 11:51 AM
bfa_header_config.php on line 294 Problems jeslynnr Header configuration & styling 1 Sep 13, 2010 01:39 PM
[SOLVED] help: i messed up my bfa_header_config.php file and my whole site is down! kopperwoman Header configuration & styling 1 May 26, 2010 04:30 PM
[SOLVED] Error in bfa_header_config.php after migration paulalford New Versions, & Updating 3 Nov 1, 2009 05:10 PM
Strange behavior when editing bfa_header_config.php jacoblo Header configuration & styling 2 Mar 24, 2009 04:45 AM


All times are GMT -6. The time now is 05:42 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.