Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] Error in bfa_header_config.php after migration

Old Nov 1, 2009, 01:52 PM
5 posts · Oct 2009

I have just migrated my site over to Rackspace cloud. Everything loaded fine, db went over without a hitch. DNS records are changed and a ping and tracert shows all in order. But when I access the site, first it is absolutely dog slow (think of access through a 56kbs modem). The site loads OK, but the first thing you notice is that the header image isn't displaying and only shows the alternate text. The second thing that happens is that when I am trying to log in to the WP Admin area it throws me an error "Page not found" and an "oops, you're looking for something that's not here". wp-login.php does exist. Checking the logs I find this error message:

[01-Nov-2009 13:24:06] PHP Warning: array_rand() [function.array-rand]: First argument has to be an array in /mnt/stor2-wc2-dfw1/531252/www.nameofdomain.com/web/content/wp-content/themes/atahualpa/functions/bfa_header_config.php on line 279

Not a clue what's happening as all was beautiful on the old server.

Any help much appreciated.


Last edited by paulalford; Nov 1, 2009 at 01:58 PM.
Old Nov 1, 2009, 05:47 PM
juggledad's Avatar
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you did a COPY of your database, then the Wordpress settings are most likely incorrect. Remember how in the WordPress dashboard->settings you set a 'ordPress address (URL)' and a 'Blog address (URL)'? They may be incorrect.

You can fix this by going ito the database with phpMyAdmin and looking in the wp-options table and changing the data

I always suggest doing an SQL export - editing the file to change the address from the old blog to the new, then importing the file into the new database,
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
Old Nov 1, 2009, 05:55 PM
5 posts · Oct 2009
Hi juggledad,

Thanks for the response.

I did an SQL export for the db from phpMyAdmin and an import at the other end. All that went fine. All the posts and pages are showing up correctly when I access the site, it's just when I try to login using the link in Meta that it throws the error and writes the php log posted above. The new domain on the Rackspace server is exactly the same name, with the DNS records pointing to the new IP. The old files have been moved on the old server to stop any potential conflict.

I've been through WP-Options and all the links seem to be fine.

I think the problem might be here:

/mnt/stor2-wc2-dfw1/531252/ (from the log error thrown in bfa_header_config.php)

This is the new absolute mount point on the Rackspace Unix box.

Possibility maybe?
Old Nov 1, 2009, 06:10 PM
5 posts · Oct 2009

I re-read your post again, and again and....

The site with the problem is located under the main site, and I hadn't re-created that sub-folder, instead loading the files in the root.

Thanks for that. I've moved about 20 domains this weekend and I think it was a case of not seeing the wood for the trees!


bfa_header_config.php, error, migrate

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Parse error: syntax error, unexpected '<' in the functions.php file pingitt Atahualpa 3 Wordpress theme 6 Mar 12, 2013 04:52 AM
[SOLVED] Error in PHP Coding Using PHP Text Widget rnimchuk Sidebars & Widgets 2 Oct 28, 2009 01:26 PM
Error in PHP trying a header insert in logo rohaver Header configuration & styling 7 Oct 22, 2009 07:44 AM
PHP Error peterkb Header configuration & styling 4 Jun 18, 2009 11:38 AM
Strange behavior when editing bfa_header_config.php jacoblo Header configuration & styling 2 Mar 24, 2009 05:45 AM

All times are GMT -6. The time now is 09:32 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.