Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Post-Kicker, -Byline & -Footer »

[SOLVED] transparent background displays white in IE


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jan 31, 2011, 03:09 AM
IldiW
 
39 posts · Oct 2010
NZ
Here I am again - after three days of desperate search all over this forum and the internet in general, I've found nothing. To an extent that it seems that my problem doesn't even exist to others. This leaves me hoping that it's a simple oversight on my behalf rather than a massive issue...

All I'd like is the footer to be transparent so that only the gradient background on the body can be seen. As you might suspect I'm happy with FF but it gives me a white background in IE (all versions). I'm reasonably sure that I'm looking at the right thing because if I change it to say red, it's fine in both FF and IE.

Site: http://50.22.130.189/~haurakim/
WP: 304
ATA: 353 (I know I could upgrade but 361 didn't work properly so I ended up downloading this version as it is said to be the most stable.)

Any help is hugely appreciated!
Thanks,
Ildi
  #2  
Old Jan 31, 2011, 05:40 AM
juggledad's Avatar
juggledad
 
22,370 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
What do you have defined at ato->Style & edit FOOTER->Style FOOTER?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 31, 2011, 02:40 PM
IldiW
 
39 posts · Oct 2010
NZ
I'm just saying:

background-color: transparent;
border-top: none 4px #eee;
padding: 0px;
text-align: center;
color: #555;
font-size: 11px;

I tried to put it in the CSS as well (not both places just one at a time), but that didn't work either.
If I put background-color: #ff0000; that'll work fine, it's only the trasnparent bit that doesn't display properly.
I have since heard that I could put a transparent image as the background to solve the issue which will be my final try I just would love to understand what I am doing wrong with the above...
  #4  
Old Jan 31, 2011, 02:59 PM
IldiW
 
39 posts · Oct 2010
NZ
I also have this in the CSS for getting the the effect of the footer running accross the entire width but I don't think it's relevant for my problem... or is it?

html {
background-color:#fff;
background-image: url(<?php bloginfo('template_directory'); ?>/images/site/bg_bottom.png);
background-repeat:repeat-x;
background-position: bottom left;
}
  #5  
Old Jan 31, 2011, 04:14 PM
lmilesw's Avatar
lmilesw
 
10,111 posts · Jul 2009
Central New York State USA
Take out the background line in ATO>Style & configure Layout>Layout Container Style
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Jan 31, 2011, 06:53 PM
IldiW
 
39 posts · Oct 2010
NZ
Hm, taking out that one line effectively made the header AND footer image disappear and the navigation stopped working properly (ie. it's now a list). So that didn't work unfortunately but how on earth does the background affect these things at all?
  #7  
Old Jan 31, 2011, 06:58 PM
IldiW
 
39 posts · Oct 2010
NZ
Update: I've put back the background, this time transparent instead of the original white and it works!! Apologies Larry if this was what you meant and I misunderstood! Anyway, it works, which is great because I use this setup (with header and footer 100% and content something less) for most of my websites, so I'll be able to apply this on all of them with ATA!
Yay, thank you both!
  #8  
Old Jan 31, 2011, 07:48 PM
lmilesw's Avatar
lmilesw
 
10,111 posts · Jul 2009
Central New York State USA
What you did will work as well. I tested by changing #fff to transparent and jut taking out that line and both worked for me but it it works it works.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Made Page Menu transparent, but white outline remains. implet Page & Category Menu Bars 3 Jan 10, 2011 05:05 PM
Transparent GIF images in main page body not transparent donfos001 Center area post/pages 2 Jan 10, 2010 10:14 AM
[SOLVED] Too much red background at top - how to move main body w/white background hi Andante Header configuration & styling 2 Dec 18, 2009 05:25 AM
[SOLVED] Transparent background PNG WITH background color? interage Header configuration & styling 2 Nov 16, 2009 01:59 PM
Transparent Menu Item Instead of A Background Color oz1 Page & Category Menu Bars 1 Jun 29, 2009 06:19 AM


All times are GMT -6. The time now is 09:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.