Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] HOW TO: MultiSite or WP Multi Network: Easy Header Images


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jan 15, 2011, 08:56 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
This represents an easy way to add header images to MultiSite or WP Multi Network installations of WordPress for each site.
In five easy steps…

Download the Zip File, Unzip, Upload the Three Files to Your Server, Create the New Directories, and Upload Your Header Images.

1. Download the Zip File

CLICK HERE

Username: atahualpa
Password: custom

2. Unzip

Gee, you already know how to do that!

3. Upload the Three Files to Your Server

Atahualpa 3.6.1

If you are using Atahualpa 3.6.1 you can just copy the files to your server with your favorite FTP program. Just replace the files that are there in these two directories.

themes/atahualpa
functions.php

themes/atahualpa/functions
bfa_rotating_header_images.php
bfa_custom_site_dir.php


Atahualpa Other (manual)

If you are not on 3.6.1 upgrade to 3.6.1 first! OR...
Follow the manual upload instructions HERE…

4. Create the New Directories

Using FTP, you will need to create a new header directory for each of your sites.

You need this directory structure...

wp-content/blogs.dir/example.com/images/header

Replace example.com with your domain name, without the www.

5. Upload Your Header Images

Using your FTP Program Upload Your Header Images to the header directory you just created.

You Are Finished!

Just give it a try!

Click Here for More Detailed Instructions.

Last edited by LANtait; Jan 15, 2011 at 08:58 PM.
  #2  
Old Jan 16, 2011, 07:17 AM
juggledad's Avatar
juggledad
 
22,311 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
You could just add the rest of the directions here instead of making users travel to another location. That would be much more helpful and supportive.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 16, 2011, 07:26 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
@juggledad
Oh, ok.

These are the directions for...
Other than Atahualpa version 3.6.1

1. Download the zip file.

Same As Above…

2. Unzip

Same As Above…

3. Upload ONE File to Your Server

See instructions above for downloading, however upload only ONE file into this directory:

themes/atahualpa/functions
bfa_custom_site_dir.php

4. Modify

themes/atahualpa/functions
bfa_rotating_header_images.php

Replace This:

PHP Code:
$imgpath TEMPLATEPATH '/images/header/';
$imgdir $templateURI '/images/header/'
With This:

PHP Code:
if ( is_dirBFA_CUSTOM_DIR '/images/header/' ) ) {
    
$imgpath BFA_CUSTOM_DIR '/images/header/' ;
    
$imgdir BFA_CUSTOM_URL '/images/header/' ;
} else {
    
$imgpath TEMPLATEPATH '/images/header/' ;
    
$imgdir $templateURI '/images/header/' ;

5. Modify

themes/atahualpa
functions.php

Replace This:

PHP Code:
include_once (TEMPLATEPATH '/functions/bfa_header_config.php'); 
With This:

PHP Code:
include_once (TEMPLATEPATH '/functions/bfa_custom_site_dir.php');
include_once (
TEMPLATEPATH '/functions/bfa_header_config.php'); 
Note: Actually this just adds the first line before the second, which already exists.

6. Create the New Directories

Same As Above…

7. Upload Your Header Images

Same As Above…

You Are Finished!

Just give it a try!
  #4  
Old Jan 16, 2011, 08:05 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Directory Structure Details for Less Experienced Users.

You will need a new header directory for each of your sites.
Use your FTP program and start with your wp-content directory.

You need this directory structure for each site.
wp-content/blogs.dir/example.com/images/header

Replace example.com with your domain name. See Examples Below.

That Means:

Using your FTP Program:
1. In the wp-content directory create a directory that is blogs.dir (if it doesn’t already exist).
2. In the blogs.dir directory create a directory that is your domain name.
To find your domain name, look at the address bar.
Mine says: http://alantait.net/
The domain name is between the two slashes // and the very next slash /
DO NOT include any www. if you are using that.
So http://www.blog.example.com/ would be a directory called blog.example.com
3. In your domain name directory create a directory that is images.
4. In the images directory create a directory that is header.
This structure mimics the structure in the Atahualpa theme directory.

EXAMPLES:
These Examples are for single sites, multisite subdomains, and WP Multi Network sites.

http://acts-29.net/
http://www.acts-29.net/
wp-content/blogs.dir/acts-29.net/images/header

http://franciskong.acts-29.net/
http://www.franciskong.acts-29.net/
wp-content/blogs.dir/franciskong.acts-29.net/images/header

http://filipina.fil.net/blog/
http://www.filipina.fil.net/blog/
wp-content/blogs.dir/filipina.fil.net/images/header
  #5  
Old Jan 16, 2011, 08:59 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
SPECIAL INSTRUCTIONS FOR
MultiSite Sub-Directory Users

Warning: Do Not use these instructions for a single site, a multisite subdomain, or a WP Multi Network site.

When you use multisite in sub-directory mode, there is no unique domain name, so the directory structure changes slightly... this is ONLY for sub-DIRECTORY mode, if you set that up at the very start of your WordPress install.

Here is how sub-directory sites would look...
Code:
http://www.example.com/peter/
http://www.example.com/paul/
http://www.example.com/mary/
The instructions are the same, except you need to add a dash (-) Plus the sub-directory.
wp-content/blogs.dir/example.com-directory/images/header

Where:
example.com = Your Domain Name (no www.)
directory = Your Sub-Directory

EXAMPLES
Code:
http://example.com/peter/
http://www.example.com/peter/
wp-content/blogs.dir/example.com-peter/images/header
Code:
http://example.com/paul/
http://www.example.com/paul/
wp-content/blogs.dir/example.com-paul/images/header
Code:
http://example.com/mary/
http://www.example.com/mary/
wp-content/blogs.dir/example.com-mary/images/header
  #6  
Old Jan 16, 2011, 09:09 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Question, why the empty image directory?

The empty image directory mirrors the theme file structure. However, this directory is a convenient place to put things like logo files on a per site basis.

Likewise we will be looking at additional site customization issues regarding theme updates, multisite, and WP Multi Network sites and will be using this for storage of unique files in this regard.

For example, a custom site may need logo files, icon files, footer or sidebar image files, and header files. This gives a place that will not be overwritten with each theme update and would allow the use of automatic updates without loss.
  #7  
Old Jan 16, 2011, 09:30 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Question, Can this be used to protect custom header image files from being deleted during automatic updates?

Yes, even in single site mode!

From one standard site, all the way through Multi Networks with multisites, this mod may be used to safeguard custom image files from being deleted during automatic or manual updates.

Likewise, the mod has automatic fall back to the default files for sites without custom header image files.

Example 1: Say you are running multisite mode with a dozen sites. You add a new site, but you do not have header images yet. No problem, the default images will be served until you add your custom image directories. No setting needed!

Example 2: Say you are running in single site mode with this mod to protect your header image files, logo files, favicons, etc. You decide to activate multisite mode and create another site on a subdomain. Automatically the second site is being served the default header image files while the original site is still being served the custom protected header image files... Plus anything else in the first custom directory, like logos, favicons, etc.
  #8  
Old Jan 17, 2011, 08:26 AM
cavsinfo
 
1 posts · Jan 2011
Thank you so much - this is such a great solution.

Quick thing, I initially followed your directory naming instructions here:
http://alantait.net/2011/01/13/wordp...-multisite-wp/
for sub-domains [change the dots (.) into dashes (-), e.g. wp-content/blogs.dir/peter-example-com]
but your instructions on this post, keeping the dots [e.g. peter.example.com] worked for me.
  #9  
Old Jan 29, 2011, 05:20 AM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Yes cavsinfo, you're right!

The original post you sited did have people change the dots to dashes, and also had a lot of code to handle it on the other end. Which in the re-write seemed a little silly since a dot is a perfectly legal character at this location! At least all open source servers I know of allow dots in the directory name.

It also makes it easier on the mind, as the directory name and the domain simply match!

Maybe you did not see the update notice on my blog...

http://alantait.net/2011/01/15/wordp...header-images/

This was written before I posted this how to, so the how to has the latest and best info. I am now using it in a growing number of biogs for our team.

I am glad you like this tiny little mod. It opens the door for locating easily a lot of custom stuff, even in single site mode!

I am trying to watch the multi-site stuff on this forum, to see what can be added!

Take care and I will try to add a correction to the blog post you noticed. Thanks, Lan
  #10  
Old Feb 5, 2011, 09:13 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
cavsinfo,

If you are still reading this thread...

You might stay tuned...

I almost have a new mod finished that will allow word press to do all the heavy lifting.

It will allow each sites admin to upload header images, logos, and favicons via the normal page or post interface and put them into the site with Atahualpa 3 - no FTP uploads and no creating directories! No worries about dot or dashes either!

It is all done using the normal file update handling functions of WP 3.x !!!

In fact it is a super way to safeguard custom files during a one touch automatic update too! Even on a single site!

Plus it handles the base blog vs the multisite blog in sub domain mode perfectly! All auto-magically!

I will post the announcement here as soon as I have done a little more testing.

Anyone want to test a sub-domain site with me?
  #11  
Old Feb 7, 2011, 02:49 PM
nik
 
1 posts · Feb 2011
I'll happily try that with you, if you have no other takers? It sounds great.

Just left a question on your own site about a subdirectory install I can't get working. Any chance of some help? Maybe once the subdomain mods are finished the same can be done for subdirectories?
  #12  
Old Feb 23, 2011, 07:05 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Hi Nik, sorry about the delay, just got back after traveling to two funerals...

When I left I had the beta of The Ultimate MultiSite Mod already working... Just need to clean it up and package it. This New Version has many great features including...
  1. It works for Single Sites and MultiSite Sites and WP MultiNetwork Sites.
  2. It is a cleaner version that could be added into the core Atahualpa code (it breaks no functionality).
  3. It allows automatic updates of Atahualpa (from WP), which will not delete custom image files. (Truly automatic if merged into the Atahualpa code.)
  4. It uses standard WP functions to find the upload directory. So you do not need to do any of that. (Just upload the replacement files and you are done, all other mods are done in the WP Admin pages.)
  5. It includes uploading ALL unique per-site graphics, the headers, the the logo and the favicon / per site.
  6. It allows all files to be uploaded via the standard WP media uploader. Therefore different admins could only upload to the sites they are admin for as set by the Super Admin.
  7. Once the Mod is made, no FTP access is needed to change images.
  8. It keeps backward compatibility with WPMU (for anyone who may be using that function).
  9. It allows Normal Default Settings for Atahualpa to function in a normal way. (Modified by the Admin Panel)
  10. It allows Sort and Shuffle modes for MultiSite and MultiNetwork as well as Single site mode (these were never available in MPMU).

All in all it is a very nice mod and I hope it will be considered for permanent inclusion. I have a lot of catch up work to do after being shut down for a few weeks... but I will try to have this code cleaned up and packaged by March First. However, it has been working on two live sites for 3 weeks!

I also want to test in on WP 3.1 to be sure,

Lan

Last edited by juggledad; Feb 24, 2011 at 04:42 AM.
  #13  
Old Feb 24, 2011, 03:31 PM
Tamara-IT's Avatar
Tamara-IT
 
41 posts · Jan 2011
Italy
Thanks LANtait, seems a great mod!
By the way, I have a MU installation with subdirectories and, in the new path to add, both the dot and the dash did no worked...
This is an example of what I tried:
Code:
/schiosostenibile.it/wp-content/blogs.dir/schiosostenibile.it-economia/images/header
and
Code:
/schiosostenibile.it/wp-content/blogs.dir/schiosostenibile.it.economia/images/header
but the images are still being sorted, seems like the new path is being ignored.

Last edited by Tamara-IT; Feb 24, 2011 at 05:09 PM.
  #14  
Old Feb 24, 2011, 10:02 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
That is interesting Tamara-IT!

I did notice that in the theme code for real WPMU (Not WP3.0 Multisite), there are no code provisions for either shuffle or sort. It could be that your server just defaults to "sort" from the directory read (not from the Theme code).

I personally got into WP at the request of my wife AFTER WP3.0x so I never even saw a WPMU code up close (I started with Multisite and the WP MultiNetwork plugin). However, my background is writing code for the last 40 years!

This mod (the old one and the new one), totally avoid the Atahualpa code for WPMU. The code blocks are divided between MU and WP3.x or "regular WP".

The code I am modifying should NEVER run on a real WPMU site.

I would suggest that the more revisions of Atahualpa there are, the less compatible it will be for WPMU sites. Just because MU today is sorta a thing of the past already.

I noticed juggledad in "Atahualpa 3.6.5 TODO"

http://forum.bytesforall.com/showthread.php?t=12898

The first thing listed on juggledad's list is:

"Check this - Don't check for wpmu-settings.php"

Which links to boone's post:

http://forum.bytesforall.com/showthread.php?t=11814

Boone, having problems with WPMS, is suggesting removing the WPMU code all together. Or modifying it in a way I believe will make the theme not work on WPMU sites.

Personally I am hoping they will merge my new code into the main package as it would support both boone and fix his problem with WPMS, and also retain the support for WPMU for users like you who may not have converted to WPMS yet.

I also hope this mod will encourage more people to migrate their WPMU sites to WPMS as it makes everything work smoothly. This mod is clean code at this point, working about a month on a number of international sites.

Sorry I am really not looking at the MU part of the code, but what I did notice it it handles files without sorting or shuffling. Just what you get from the directory is what you get...

On most servers that directory list is usually sorted!

Lan

PS I hope to have the mod package out in the next day or two...

After that maybe I can help you post a patch to add shuffle to WPMU. Which version of Atahualpa are you using?
  #15  
Old Feb 24, 2011, 10:58 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Quote:
Originally Posted by Tamara-IT
Thanks LANtait, seems a great mod!
By the way, I have a MU installation with subdirectories and, ... the images are still being sorted, seems like the new path is being ignored.
WPMU Does Not Shuffle!

Hey Tamara!

The WPMU code in Atahualpa 3.6.4 has no prevision for sort or shuffle. It just uses the files as returned from the directory search (usually sorted by the server). If you want to add this feature, you can try this.

Edit:
functions/bfa_rotating_header_images.php

In Atahualpa 3.6.4 it is about lines 11-12

Find:
PHP Code:

        
if ($files) {
            foreach(
$files as $value) { 
Change to:
PHP Code:

        
if ($files) {
            if( isset( 
$bfa_ata['header_image_sort_or_shuffle'] ) ) {
                if ( 
$bfa_ata['header_image_sort_or_shuffle'] == "Sort" ) {
                    
sort($files);
                } else { 
                    
shuffle($files);
                }
            }
            foreach(
$files as $value) { 
I do not have an MU to try it on, but it is pretty simple code and is identical to what I am using in the WPMS Mode to shuffle/sort the files and also almost identical to what the Theme uses in Single Site WP3.x

Hope it helps!

Lan
  #16  
Old Feb 25, 2011, 01:49 AM
Tamara-IT's Avatar
Tamara-IT
 
41 posts · Jan 2011
Italy
Ok, thanks!
I also tried on a WP 3.0.x multisite and I have the same problem, in sub-sites I don't have one header image but the multiple headers, like the main site. I used the same structure I posted above.
  #17  
Old Feb 25, 2011, 04:46 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Quote:
Originally Posted by Tamara-IT
Ok, thanks!
I also tried on a WP 3.0.x multisite and I have the same problem, in sub-sites I don't have one header image but the multiple headers, like the main site. I used the same structure I posted above.
Hi Tamara!

You are, of course, correct!

I have a NEW Mod and I am hoping it will be merged into the Atahualpa Theme permanently as it fixes ALL known WP multisite problems and adds features to WP in single site mode.

As to your question...

One goal of WP3.0 was to merge the code of MU into regular WP. It is not WP2 plus add MU and it is not MU with added WP regular. Actually, WP3.x has an actually different structure that anything before it. However, to the naked eye, it is hard to notice.

They look the same, and actually in maybe 80-90% MU and WP2 were the same!

One very IMPORTANT design concept of WP3 was that it should allow the upload of site graphics via the WP media uploader, not via FTP.

Now the problem is, WP for the first site behaves differently that the MU part for the second part... so ALL NEW code was written to make them friends and cooperate. That code makes them enemies of FTP for Site Graphics.

Basically (simplified) Site Graphics, Header Images, Logo Images and Favicon Icons, should be not be uploaded via FTP.

To get around this complication, theme authors have done many "tricks". These tricks have some problems like what you have noted.

Likewise, older theme codes still work too! However, the older codes cause problems with the automatic updates from the WP site. Atahualpa falls into this category.

The answer is to rewrite the code to NOT use FTP but to use the WP Media Manager. That sounds easy, right? Read again...
rewrite the code!

CODE REWRITE

That is exactly what I have been working on and it works really well. If you would like to try it...

http://alantait.net/2011/02/26/ultim...atahualpa-mod/

I do not have the documents ready to announce here yet. But if you would like to try, the download comes with with a file called

README_MULTISITE_MOD.php

This tells exactly how this mod works and exactly what lines were modified. You do not really need to know this to use it. Just download the files, then upload them overwriting them to your Atahualpa Theme folder. Then upload your image files through Wordpress.

The Blog Announcement and the README file has better instructions... However, I am still reviewing these so I am not ready to post them here.
  #18  
Old Feb 25, 2011, 05:37 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Quote:
Originally Posted by Tamara-IT
Thanks LANtait, seems a great mod!
By the way, I have a MU installation with subdirectories and, in the new path to add, both the dot and the dash did no worked...
This is an example of what I tried:
Code:
/schiosostenibile.it/wp-content/blogs.dir/schiosostenibile.it-economia/images/header
and
Code:
/schiosostenibile.it/wp-content/blogs.dir/schiosostenibile.it.economia/images/header
but the images are still being sorted, seems like the new path is being ignored.
I looked at your site and right mouse clicked on your file image to view it. On the address bar of my browser it says...

http: //schiosostenibile.it/wp-content/themes/atahualpa361/images/header/economia.jpg

That would be: (Starting at your wp-content directory - where every you have that located.)

wp-content/themes/atahualpa361/images/header/economia.jpg

That is the actual location of the header you have displayed.

===

Now take a look at http://naturespharmacy.org/

Again point at the header and display the background image. The address box will display something like:

http: //naturespharmacy.org/files/2011/02/header_6.jpg

files/2011/02/ is not the exact directory where this header is located. Wordpress translates this based on your site id number. No need for you to know the actual location, because WP knows it from when you uploaded if via the WP Media Upload in WP 3.x

This is basically the way the default theme (TwentyTen) works also.

All of this is set up for you when you set up WP 3.x in multisite mode (either subdomain or subdirectory).

===

Looking at: http: //schiosostenibile.it/economia/

I can see you are uploading everything (header and logo, using the default favicon) via FTP to the Theme folder.

If you decide to try the instructions here...

http://alantait.net/2011/02/26/ultim...atahualpa-mod/

You can get the same effect using the two options listed under...

1) Custom Headers and Custom Logo
2) DEFAULT FAVICON

I am still working on the documentation.

This is working in WP 3.0.4 and Atahualpa 3.6.4
I expect it will also work in WP 3.0.5 and WP 3.1 but have not tested this yet.

If you have any problems with the instructions, let me know, I am still writing them.
  #19  
Old Feb 26, 2011, 09:02 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
I received this PM - and modified it for an example.

If you have an install like this:
http://fgbmfi.net/
http://fgbmfi.net/fgbmfi-links/

The Original Mod will NOT work for you. Use the Ver 2.0 Mod located at:
http://alantait.net/2011/02/26/ultim...atahualpa-mod/

Quote:
Good Afternoon

I was wondering if I could trouble you for help regards your above posting:

I have installed your fix, and am using sub-directories and have taken the required steps in blogs.dir

My two blogs:

http://fgbmfi.net/
http://fgbmfi.net/fgbmfi-links/

do not collect the image file and are coming up with errors as can be seen.

I would be most grateful of any help or advice please.

Many thanks
Hi,

You can skip the explanation and scroll down to the SOLUTION!

Explanation

As you have noticed, the original mod does not work in your case.

The problem is what did you use for the directory names?

http://fgbmfi.net/
http://fgbmfi.net/fgbmfi-links/

The rule for subdirectories says the domain name a dash (-) and the first directory. Lets consider that both sites have an about page and that is what we are viewing.

The idea was something like this...
1) http: //fgbmfi.net/something/about/
2) http: //fgbmfi.net/fgbmfi-links/about/

The directories would then be:
1) fgbmfi.net-something
2) fgbmfi.net-fgbmfi-links

But in your real world settings, your default site has no subdirectory. Hence...
a) http: //fgbmfi.net/
b) http: //fgbmfi.net/about/
c) http: //fgbmfi.net/fgbmfi-links/about/

The directories looked for would then be:
a) fgbmfi.net-
b) fgbmfi.net-about
c) fgbmfi.net-fgbmfi-links

As you can see, a and b do not point to the same directory and therefore they will never work. That is the bad news. For the good news, keep reading...

SOLUTION!

The solution is a completely different program that creates and modifies directories within Wordpress on its own. Base on the Site ID Number that you never see!

Actually this is really much easier.

Pretty much complete instructions can be found HERE:

http://alantait.net/2011/02/26/ultim...atahualpa-mod/

On site posts referring to this are at:

http://forum.bytesforall.com/showthread.php?t=11814
http://forum.bytesforall.com/showthread.php?t=12267

If you have installed the old mod, you do not have to remove it because the new mod will overwrite the old one. Just upload it and configure it as listed in your Admin and options pages. You may then delete any directory you created with the first mod.

If you have any problem with the new program, let me know.

Sincerely,

LAN

Last edited by juggledad; Feb 27, 2011 at 04:56 AM.
  #20  
Old Apr 10, 2011, 03:09 PM
bwolfsohn
 
3 posts · Apr 2011
Is there any thought to making this (or another) solution part of the base atahualpa package in a future update??
  #21  
Old Apr 26, 2011, 06:30 PM
griffinjay
 
16 posts · May 2009
Thanks much for Version 2.0 of this Atahualpa mod, Lan.

I got it to work! Exactly what I needed.

FYI, there's an incomplete sentence in Step 1:

"Upload all Headers, Logos and your Favicon in the same place makes it easy to maintain the."
  #22  
Old Apr 30, 2011, 12:51 AM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Quote:
Originally Posted by bwolfsohn
Is there any thought to making this (or another) solution part of the base atahualpa package in a future update??
Hey, you have my vote! This is now working in all modes, so I am hopeful we can merge this code into the standard atahualpa package.
  #23  
Old Apr 30, 2011, 01:02 AM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Quote:
Originally Posted by griffinjay
Thanks much for Version 2.0 of this Atahualpa mod, Lan.

I got it to work! Exactly what I needed.

FYI, there's an incomplete sentence in Step 1:

"Upload all Headers, Logos and your Favicon in the same place makes it easy to maintain the."
Wow, you are right! Thanks, I fixed it! However, it looks like I should have just deleted the "the"!

Quote:
"Upload all Headers, Logos and your Favicon in the same place makes it easy to maintain."
  #24  
Old May 26, 2011, 04:43 PM
BanditSiix
 
2 posts · Jan 2011
Wow! I can't tell you how amazed I am by the giving that goes on here. LANtait is awesome with the solutions.

My question is... has anyone from BytesforAll who is working on Atahualpa even commented on adding the Multi Network header solutions to the theme? I haven't upgraded my themes yet but plan to do so soon but I haven't seen anywhere where they have listed it as a fix or enhancement to the theme.

LANtait's solutions are awesome to be sure and for most of you here are pretty simple fixes but for a guy like me who's real business is NOT website development, maintenance etc it's a lot of extra effort to get it to work on all my sites. I would just like to know if BytesforAll plans on solving this problem for us average users?

And before someone barks at me about hiring a WP professional, trust me, I would love to and will when our economic situation improves.
  #25  
Old Jun 6, 2011, 06:24 PM
LANtait's Avatar
LANtait
 
56 posts · Jan 2011
Cebu Island, Philippines ~ I live on a tropical island!
Thank you BanditSiix for your kind words and for your support of adding this solution into the base Atahualpa package. The 2.0 version is now operating, without problems, in many production websites and I get many emails and messages of thanks on my blog.

Like you, I also hope that this mod becomes a part of the Atahualpa core as it supports Atahualpa in ALL modes, even adding features in the single site mode and one touch automatic updates from WordPress.org. There have not been any failures reported to me in any mode (single site, multisite subdirectory, multisite subdomain, WP Multi Network plugin, or WPMU), since the release of Mod Version 2.0

We have heard rumors of sites using this in production up to about 200 networks and or subdomains on a single install of Atahualpa with full customization, and even without using FTP after install (image files are uploaded via word press in the same way post images are). We personally have about 3 dozen sites running on one install.

In the default mode (single site) it behaves identical to the standard Atahualpa package. Therefore this would be a drop in replacement to the current Atahualpa theme with no modification required for the vast majority of sites. It also adds header image upload features (No FTP) to the single site mode for those who choose to use it.

Likewise it fixes the problem with automatic uploads as it moves custom images to a safe location. If this is added to the package core code it means the one touch upgrades of Atahualpa from the WordPress.org site will work (this is now broken for sites with custom images).

It would be very easy to add this mod to the base Atahualpa package. The mod itself is now very stable and has not changed at all (only the line numbers change do to other changes in the theme). I would be more than willing to help in adding this to the core as it is ready for production servers. I am currently using it on all our servers as our primary theme (the only other theme we have now is the default theme TwentyTen).

I have talked to the themes team at WordPress.Com about adding Atahualpa and this mod to the WordPress.com website. The mod was verified by a number of sources to be both stable and suitable for the multi-network, multi-site configuration. However, WordPress.Com declined to use Atahualpa for other reasons (policies of custom CSS without additional payment and uploading of custom favicon without additional payment - to name two).

In other words, the MOD works just fine for multisite WordPress.com. However, the Atahualpa theme (with this mod) would seriously cut into their revenue streams, so they declined to use it.

I am very grateful to the Atahualpa 3 Development Team for their hard work on this wonderful theme. We must remember that the Atahualpa theme is mainly used on single site installs and a few MPMU sites that have not yet upgraded to WP3.x

Based solely on observations of posts on the Bytesforall forum, I do not believe any of the Atahualpa team use multisite mode, nor have even tried this mod on a multisite test platform (indeed they may not even have one!).

It is a lot of work to maintain a project like this theme, and the Atahualpa team may not feel comfortable adding this mod to the core package without their own testing of it. Perhaps we should start a thread of people who are actually testing/using this mod ... with reports on the results in each of the major modes listed above. With wider testing/usage of this mod, the Atahualpa 3 Development Team may feel more comfortable in adding this to the package core?

BanditSiix - what mode are you using the mod in? (single site, multisite subdirectory, multisite subdomain, WP Multi Network plugin, or WPMU) Are you using this on production/public sites or only on a test platform?

Perhaps BanditSiix, it would be nice if the Atahualpa 3 Development / Support Team made a comment about adding this mod to the Atahualpa core package. But we should keep in mind that they are very busy people... And thank them for making such a wonderful theme!

Bookmarks

Tags
header, header image, multi network, multisite

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Header Images and other elements in WP Network installations BanditSiix Header configuration & styling 1 Jan 13, 2011 07:47 PM
Wordpress network feature > header problem! JeromeH Header configuration & styling 10 Oct 5, 2010 12:05 AM
Easy: Left-align headlines on multi-post pages but center on single? Jeff G Excerpts, Read more, Pagination 5 Jul 26, 2010 10:08 AM
How to: The easy way to add Facebook thumbnails to posts with no images Androsko Center area post/pages 0 Mar 8, 2010 09:15 AM
Is it easy to place a new widget in the header and footer for a novice jkfly4 Sidebars & Widgets 1 Jan 30, 2010 02:09 PM


All times are GMT -6. The time now is 12:55 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.