Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

[SOLVED] Problems when comment order changed and comments broken into pages


  #1  
Old Jan 9, 2011, 05:36 PM
NN82
 
5 posts · Jan 2011
I have updated the theme and I now have the 3.6 version and, more or less, everything works fine. The problem I have is with respect to comments.

I am using Wordpress 3.0.4. I have also changed the discussion settings. The comments are broken into pages with 10 comments per page. The first comment page is displayed by default and the newer comments are supposed to appear at the top of the page. I have also modified the theme settings so that the newer comments are displayed before the older ones. I am using comments on static pages.

I have spotted two issue so far: the first one is with respect to the navigation links and the second one is regarding how the comments are displayed when the order of comments is changed and the comments are broken into pages.

Issue with navigation link:
Since I have modified the setting, the newest comments must be displayed on the first page and the older ones on other pages. So the navigation link pointing to pages 2, 3, and so on must read "Older comments" but it reads "Newer comments". I have managed to fix this problem by swapping previous and next messages in the BFA navigation link file but since it is not a general fix I have not included it here.

the way comments are displayed:
On every individual comment page, the comments are displayed correctly, with the newer comments at the top of the page followed by the older ones. However, when the number of comments on a page is 10 (i.e. the limit for the number of comments per page is reached) and I add a new comment, this new comment goes to the last page. Since this comment is the newest comment it must go to the first page. I am not sure if this is an issue with the theme or wordpress, but if anyone knows how to fix this, could you please let me know. I would really appreciate it.
  #2  
Old Jan 10, 2011, 04:35 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
please attach your settings file (ato->export/import settings)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 10, 2011, 11:52 AM
NN82
 
5 posts · Jan 2011
Please find attached the settings
Attached Files
File Type: txt setting.txt (18.4 KB, 697 views)
  #4  
Old Jan 10, 2011, 02:51 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
well, your settings work fine for me. I would suggest the first rule of debugging - disable all your plugins and see if it still happens.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jan 10, 2011, 03:43 PM
NN82
 
5 posts · Jan 2011
I deactivated all the plugins and it is still not working. The same two issues are still present.
  #6  
Old Jan 10, 2011, 03:47 PM
NN82
 
5 posts · Jan 2011
I do not know if you modified the number of comments per page, if not then did you add 10+ comments (my limit for comments was 10)? when I added the 11th comment (after disabling all the plugins) the comment went to the second page as oppose to the first page. Since I want the newer comments to be displayed before the older ones, it should have been added to the first page.
  #7  
Old Jan 10, 2011, 05:56 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
(sorry I was looking at posts earlier)

I have the same issue, but this is not an Atahualpa issue but a wordpress issue in the way comments are returned. You can see this by temporally switching to the twenty ten theme and comments come out in the same order

What you want is a plugin like http://wordpress.org/extend/plugins/...rder-comments/ Never tried it, just got it with a qquick google search
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Jan 10, 2011, 10:09 PM
NN82
 
5 posts · Jan 2011
Thank you for your help. The reverse order plugin did not work for me but I installed Paged Comments plugin and everything works just fine now. Thanks again.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Order comments busurleweb Forum How-To 1 Mar 12, 2010 02:54 PM
broken link between comments pages. Lisa Comments, trackbacks & pings 1 Feb 23, 2010 06:42 AM
Help - comments are broken on my site! Eric Bobrow Comments, trackbacks & pings 5 Jan 15, 2010 11:59 AM


All times are GMT -6. The time now is 08:43 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.