Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating » Old Version fixes and change logs »

Changelog 3.3 -> 3.3.1


  #1  
Old Mar 30, 2009, 10:52 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Atahualpa 3.3.1 is available here http://wordpress.bytesforall.com/?p=69

Changelog 3.3 -> 3.3.1
  • DONE: Auto image resizing didn't work anymore for the image height
  • DONE: Post titles were linked to the wrong Permalink URLs
  • DONE: The font-weight of widget list items could not be changed
Plus another bug was found. Either update to 3.3.2 at http://wordpress.bytesforall.com/ (only 1 file changed: header.php)

or apply this patch http://forum.bytesforall.com/showthread.php?p=3922

Applying the patch is sufficient if you already have 3.3.1. Uploading the new header.php from 3.3.2 would work, too
  #2  
Old Mar 30, 2009, 11:49 AM
BradBrown's Avatar
BradBrown
 
54 posts · Mar 2009
Thanks for rolling out a fix so quickly. I realize how complex this theme is. It would be nearly impossible to not have a few bugs slip through. I really appreciate the quality of this theme and the level of support you provide.

I do have a suggestion for a future release. I want to have headings at the top of category and archive pages. I just edit the code and add them, but it would be better if I didn't have to edit the code.

So, you could add suport for this by creating an option to turn on archive headings.

Now that we can put PHP code in the theme settings, a more flexible solution might be to add a new div at the top of multi post pages where we could insert code. This would be basically like the kicker, but would appear only once at the top of multi-post pages.

Thanks,
Brad
  #3  
Old Mar 30, 2009, 12:01 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I'll do something like that in the next version. There are definitely areas where the theme isn't flexible enough. Also, manual file edits shouldn't be required anymore at some point.
  #4  
Old Mar 30, 2009, 03:21 PM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
I'm just now updating from 3.2 to 3.31. This will be my first ever theme update -- with Atahualpa, or any other theme for that matter.

I understand that all the options I've set in "Options" are stored in the database and will be "moved automatically" into 3.31.

But, the changes I've made in index.php, header,php, etc. are another matter.

What is the best way to go through and re-do those changes where needed? Looking at the /atahualpa directory on the server I can see that all the files have a "last modified date" of 2/7/2009 except for header.php, footer.php, index.php and functions.php which have been modified more recently.

Is there a systematic, sure-fire approach to this process that guarantees I won't miss a change I've made?

I've tried to be consistent about leaving comments in files where I've made changes. but my knees are still shaking.
  #5  
Old Mar 30, 2009, 05:30 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I suggest that you upload the new version as /atahualpa331/ and run both the old and the new version at the same time. That way you can always go back to the previous version while carrying over your file edits.

You'd have to find all your file edits files in the old version and re-apply them on the new version.

I am going to add "hooks" in the next versions. With hooks, you'd have all your custom code in a single file, instead of many little edits spread over multiple files.
  #6  
Old Mar 30, 2009, 05:47 PM
Uvius
 
3 posts · Mar 2009
Hi Flynn,

having upgraded to 3.3.1 I noticed the following things around localization:

1. the date format is no longer picked up (no entry for it in the .pot file although still in the php-files - shows up again when building a new template). This has been the case since 3.2:

#: comments-paged.php:82
#: comments-paged.php:118
#: legacy.comments.php:80
#: legacy.comments.php:121
#: functions/bfa_comment_walker.php:114
msgid "F jS, Y"
msgstr ""

2. The following strings don't appear any longer, not even in the php-files:
Register
Site Admin
Login
Logout

Why? Now there is e.g. no "Register" link now even if enabled in the dashboard.

Best regards,
Uvius
  #7  
Old Mar 30, 2009, 05:54 PM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Quote:
Originally Posted by Flynn
I suggest that you upload the new version as /atahualpa331/ and run both the old and the new version at the same time. That way you can always go back to the previous version while carrying over your file edits. ...<snip>..
I'm not sure I understand how you mean this. WP won't let me effectively have two themes installed at the same time -- will it? Even IF they are two versions of the same theme.
  #8  
Old Mar 30, 2009, 07:01 PM
strangelove's Avatar
strangelove
 
29 posts · Feb 2009
Jim,

I might be able to help here. I just uploaded the 3.3.1 update to my directory:
/wp-content/themes

where now there is two versions of Atahulapa:

/atahulapha3
/atahulapha331

Then under the admin panel APPEARANCE -- THEMES
I select either the new or the old version.

I immediately noticed that upon selected the new 331 version my custom header images disappeared -- more on this later,

EDIT: the obvious now struck me -- must move any custom header images from /atahulapha3/images/header to /atahulapha331/images/header

Dr. Strangelove
www.strangelove.com/blog
Watching YouTube

Last edited by strangelove; Mar 30, 2009 at 07:05 PM.
  #9  
Old Mar 31, 2009, 04:44 AM
Ramoonus
 
4 posts · Feb 2009
Successfully updated from 3.2 to 3.3.1
yeeha
  #10  
Old Mar 31, 2009, 09:48 AM
Joe Bonner
 
8 posts · Feb 2009
Quote:
Originally Posted by strangelove
Jim,

I might be able to help here. I just uploaded the 3.3.1 update to my directory:
/wp-content/themes

where now there is two versions of Atahulapa:

/atahulapha3
/atahulapha331

Then under the admin panel APPEARANCE -- THEMES
I select either the new or the old version.
strangelove,

I tried this, but in the theme editor, they both have the same name (Atahulapha).

Do I need to edit something else inside the atahulapha331 directory?

I should add that it's obvious after clicking between the two which is which, but if there's a way to distinguish between the two, I'd be happy.

Thanks!

Last edited by Joe Bonner; Mar 31, 2009 at 10:13 AM. Reason: clarification added
  #11  
Old Mar 31, 2009, 11:46 AM
bcorrigan
 
85 posts · Feb 2009
Joe, they do have the same name, but they are ordered by name I believe. So Atahualpa 3.2 is before Atahualpa 3.3.1. Flynn, it would be useful if you could put a reference to the version in the info that shows up on the themes install page in WP Admin, like you did with version 2.21.
-Bill
  #12  
Old Mar 31, 2009, 11:50 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I'm wondering if it would be OK to wait until the next release? I'm not having problems with the things fixed in this version, so, while I'm just about ready to launch our new site with the "old" version, I'd really rather not add any more stress right now!

So if I stay at 3.3, will I be able to upgrade at 3.3.2?
  #13  
Old Mar 31, 2009, 12:23 PM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
I seem to be having a variation of the same problem: not knowing IF I've successfully updated to 3.31.

I created a new subdir hatchtown.com/wp/wp-content/themes/atahualpa331 alongside the existing hatchtown.com/wp/wp-content/themes/atahualpa

After unzipping, I uploaded all the 3.31 files into the new atahualpa331 directory.

On the WP Dashboard I see "Current Theme -- Atahualpa 3.2 by BFA WebDesign" and down in "Available Themes", along with "WordPress Classic" and "WordPress Default", I see just plain "Atahualpa" (note: no "331") .

If I click on the inactive Atahualpa I get a black-framed preview, I click on "Activate" and I return to the Dashboard view which reports "New Theme Activated -- Visit Site". BUT, it STILL says "Atahualpa 3.2" is active and plain "Atahualpa" is inactive.

Help! What's going on?

For the life of me I cannot see that anything's changed? I can see that I have new/different files in the /atahualpa331 subdirectory, but there's no indication they're being used.
  #14  
Old Mar 31, 2009, 01:37 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
At Site Admin -> Appearance -> Themes

Hover over the title "Atahualpa" and watch the browser status bar for "...&template=atahualpa331&..." to distinguish between the Atahualpa versions

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changelog 3.4/3.4.01 -> 3.4.1 Flynn Old Version fixes and change logs 8 Jan 24, 2010 09:55 AM
Changelog 3.3.3 -> 3.4 Flynn Old Version fixes and change logs 20 Jul 29, 2009 05:05 PM
Changelog 3.3.2 -> 3.3.3 Flynn Old Version fixes and change logs 21 Jun 11, 2009 08:27 AM
Changelog 3.3.1 -> 3.3.2 Flynn Old Version fixes and change logs 2 Apr 22, 2009 05:09 PM
Changelog 3.1.8/3.1.9 -> 3.2 Flynn Old Version fixes and change logs 29 Feb 14, 2009 11:49 AM


All times are GMT -6. The time now is 04:45 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.