Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

[SOLVED] Problem getting jQuery code to execute


  #1  
Old Jan 19, 2010, 05:29 PM
Eric Bobrow
 
70 posts · Jan 2009
I posted this two or three days ago as a reply to an older thread
http://forum.bytesforall.com/showthr...ry+insert+code
but haven't gotten any replies, so I'm reposting as a new thread to see if I can get a quick answer for this simple question.

----------------------

I am trying to use jQuery to show an overlay image the first time a visitor enters the site, then fade it after a few seconds or when the visitor clicks on the entry image. I worked out most of the mechanics and code on a test page, and am now trying it on one of my WP sites which has Atahualpa 3.4.2 loaded.

I can't seem to get any jQuery code to execute. I followed Flynn's directions [in the other thread] to
Add jQuery code to js.php after
jQuery(document).ready(function(){
My first simple test is to hide a DIV that floats in front of the page that has an ID of "entryImage". My code is very simple:

$("#entryImage").hide();

When that didn't do anything, I added a simple alert line to see if I could get something to execute, but I didn't get the alert popup that I expected:

alert("hello");

For the record, here is my code (in red) in js.php, showing the unmodified lines above and below what I added in grey. Any help would be greatly appreciated!

Code:
    jQuery.noConflict();
    jQuery(document).ready(function(){

    $("#entryImage").hide();
    alert("hello");

    /* For IE6 */
I'm sure this is pretty simple, but I don't know whether this code is invalid, or if it needs to be placed somewhere else.
  #2  
Old Jan 24, 2010, 12:38 AM
Eric Bobrow
 
70 posts · Jan 2009
I finally figured this out, and posted the information on the original thread in case it would be useful to others:
http://forum.bytesforall.com/showthr...3623#post23623

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to insert code for jquery plugins ? twola Header configuration & styling 3 Jan 24, 2010 12:18 AM
[SOLVED] Problem with double jquery library calls / "Shopp" plugin Shepherd Jim Plugins & Atahualpa 2 Nov 11, 2009 09:02 AM
The short code and excerpt problem. eerms Excerpts, Read more, Pagination 5 Sep 22, 2009 05:33 PM
[SOLVED] Problem with code in HTML/CSS Inserts xavison Post-Kicker, -Byline & -Footer 4 Jun 26, 2009 12:59 PM
Problem with lingering code in footer The CajunFoodie Post-Kicker, -Byline & -Footer 0 Mar 19, 2009 10:54 AM


All times are GMT -6. The time now is 04:01 AM.


Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.