Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Excerpts, Read more, Pagination »

Next/Previous Single Post Navigation


  #26  
Old Aug 2, 2015, 04:41 AM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
oops, my fault, I had the option 'Keep next/prev. links on SINGLE post pages to same post category?' set to YES.

Edit bfa_next_previous_links.php and change line 98 from
HTML Code:
next_post_link($bfa_ata['single_next_prev_newer']);
to
HTML Code:
next_post_link($bfa_ata['single_next_prev_newer'], 'next', TRUE);
and change line 123 from
HTML Code:
previous_post_link($bfa_ata['single_next_prev_older']);
to
HTML Code:
previous_post_link($bfa_ata['single_next_prev_newer'], 'previous', TRUE);
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Aug 4, 2015 at 04:46 AM.
  #27  
Old Aug 3, 2015, 12:07 AM
rickpoet
 
63 posts · Jan 2010
Hey there...well that second bit of code editing disappears the navigation on the single post pages altogether. Was the second set of code meant to be done instead of the first changes, or in addition to? (I did them in addition to.)

Here's a post which as of tonight should be showing a previous link below: http://www.haikuniverse.com/117/ (and which tomorrow after 3 am should be showing both a previous and next)

Thanks for the work on this!
  #28  
Old Aug 3, 2015, 11:23 AM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The page does not change
but I put in the new code
a cache exists...sigh.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Aug 3, 2015 at 06:23 PM.
  #29  
Old Aug 3, 2015, 11:55 AM
rickpoet
 
63 posts · Jan 2010
Hi Juggledad...I appreciate the frustration you may have with people experiencing the same issues over and over such as changes not being apparently implemented because a cacheing plugin is in place etc. This, however is not what is happening here.

a) I deleted the cache (and habitually do so every time I make these kinds of changes) after making the code changes both times.

b) the page did not stay the same (i.e. your "page does not change") - what happened here is when I put in your second set of codes, the next/previous navigation buttons now disappeared completely from the single post pages. I don't think that has anything to do with caching.

So, my most recent question to you on this was this: You had me adjust code a first time, that didn't work. You posted your "oops" message with a second set of code. I made the second set of code changes. What's unclear to me is if that second set of code changes was meant to be:

-instead of the first ones you sent (meaning I should have undid the first changes you suggested and just done the second)

OR

-done both sets of code changes (which is what I actually did, leaving the single post pages now devoid of next/previous navigation...which is a completely new thing, and not an "unchanged" page because of a cache issue.)

What do you think?

Thanks,

Rick

Last edited by rickpoet; Aug 3, 2015 at 11:57 AM.
  #30  
Old Aug 3, 2015, 12:03 PM
rickpoet
 
63 posts · Jan 2010
Quote:
Originally Posted by juggledad
Page does not change
but I put in the new code
cache exists...sigh.
p.s. with just one more syllable on the first and third lines of your message, you could EASILY turn that into a haiku.
  #31  
Old Aug 3, 2015, 05:03 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Drat's ...it was suppose to be a haiku - I never could count vowels.

The first set of code would handle the case where the next/previous were by category.. The secodn set was for next/previous by post date order. They can both be there and should be independent.

I just put in a fresh copy of Atahualpa and reset my settings, then put in just the last code change and it works fine for me. So it might be something in your settings.

export your settings
attach them to a reply
I will look at it
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Aug 3, 2015 at 05:06 PM.
  #32  
Old Aug 3, 2015, 05:18 PM
rickpoet
 
63 posts · Jan 2010
OK, I have nothing in the Home Link on single or multi post page fields in Next / Prev Navigation settings.

You may have answered the question though, you said "...then put in just the last code change" - so should I not have kept in the first set of changes you sent to?

Regardless, settings file attached. Thanks! (I offer haiku services incidentally...

R
Attached Files
File Type: txt ata-wwwhaikuniversecom-20150803.txt (13.6 KB, 306 views)
  #33  
Old Aug 3, 2015, 05:53 PM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
your settings and the code change work fine for me. It's possible that you made an error in adding the code change(??)
If you send me a PM with an admin ID/PW I'll take a quick look
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #34  
Old Aug 3, 2015, 06:56 PM
rickpoet
 
63 posts · Jan 2010
Well no problem to do that but can you confirm whether both sets of code changes need to have been made or just the 2nd set. (It was unclear to me when you posted the second set of changes if they were to be made INSTEAD OF or IN ADDITION TO the first set. Right now the code has all 4 lines of code changed....I can easily reset that file and just make the second set if that was the issue?
  #35  
Old Aug 4, 2015, 04:49 AM
juggledad's Avatar
juggledad
 
23,526 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
You should be all set now - my fault doing a copy/paste (head slap)where I had you change 'previous_post_link' to 'next_post_link' and that messed it up.

It didn't happen to me because I didn't copy the code exactly when I tested it, I was just adding teh new parts in ...sigh...
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #36  
Old Aug 4, 2015, 10:33 AM
rickpoet
 
63 posts · Jan 2010
haiku

perfect Juggledad
website doing what it should
above and beyond



THANK YOU!

Bookmarks

Tags
next/previous navigation, single post, single post pages

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Hide next/previous navigation bar if there is just one post in a category... chiara7 Excerpts, Read more, Pagination 6 Mar 7, 2010 04:42 PM
Next/Previous Navigation on MULTI Post Pages for posts with many categories assigned joan Post-Kicker, -Byline & -Footer 4 Jan 8, 2010 03:27 PM
Can the next/previous post navigation be constrained to the current category ? 3ukman Header configuration & styling 1 Aug 29, 2009 09:14 AM
[SOLVED] Next post and previous post links on top of single post page error susieswe Atahualpa 3 Wordpress theme 2 Jul 15, 2009 02:58 PM
[SOLVED] How do I move next/previous navigation to the bottom of the post evany Post-Kicker, -Byline & -Footer 1 Jun 7, 2009 06:41 AM


All times are GMT -6. The time now is 06:29 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.