Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating » Old Version fixes and change logs »

Atahualpa 3.7.1 released


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Oct 6, 2011, 10:09 AM
Flynn's Avatar
Flynn
 
3,765 posts · Oct 2008
Munich, Germany
This fixed one serious bug that occurred since 3.6.8 when you edited a theme file on the server, through WP Admin -> Appearance -> Editor, see http://forum.bytesforall.com/showthread.php?t=15572


Download Atahualpa 3.7.1

(There are 2 links in that post. Use the small one at the bottom if 3.7.1 is not on wordpress.org yet)

Last edited by lmilesw; Oct 6, 2011 at 10:38 AM.
  #2  
Old Oct 7, 2011, 11:48 AM
deClench
 
3 posts · Oct 2011
Still having the same problem in 3.7.1 as with 3.7.0 with the tabulation in Atahualpa Theme Options.

Anyone else seeing this bug or am I doing something wrong? Thanks!


Quote:
WP 3.2.1, upgrading from Atahualpa 3.6.7 to 3.7.0

The Atahualpa Theme Options section has lost its tabulation. All content is dumped on screen. Other sections seem fine, and front end seems fine.

Tried 3.6.9 and have same issue. 3.6.7 was fine.

Any thoughts? Thanks!
  #3  
Old Oct 7, 2011, 11:56 AM
deClench
 
3 posts · Oct 2011
My bad. I renamed the uploaded to "atahualpa 3.7.1" to distinguish it from the other versions. Renaming to just "atahualpa" has brought back the formatting.
  #4  
Old Oct 12, 2011, 03:01 PM
kletskater's Avatar
kletskater
 
85 posts · Jun 2010
ata 3.7.1 works very fine for me, thanks for al who make this theme possible,

i've got one a question:
-when doing a loadspeed test at uptrend, i get the error message atahualpa371/js/DD_roundies.js?ver=0.0.2 file not found.
this dd_roundies.js seems to slowdown pageload by not being there:
What is this .js for?, do i need it?
if yes how can i (re)install it?
if not, how can I get rit of the error message?
  #5  
Old Oct 12, 2011, 03:42 PM
juggledad's Avatar
juggledad
 
22,265 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
go to the theme options->Configure CSS & JS->IE6 PNG Fix CSS Selectors and delete everything from that option
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Oct 13, 2011, 01:29 AM
kletskater's Avatar
kletskater
 
85 posts · Jun 2010
Quote:
Originally Posted by juggledad
go to the theme options->Configure CSS & JS->IE6 PNG Fix CSS Selectors and delete everything from that option
That did it, thanksJuggledad
  #7  
Old Oct 24, 2011, 08:07 PM
ymf
 
61 posts · May 2009
Upgrade from 3.5.3 to 3.7.1 was uneventful. Contributed $5. Thanks!
  #8  
Old Oct 28, 2011, 11:57 AM
qbuster's Avatar
qbuster
 
84 posts · Mar 2010
Alrewas, Staffordshire, UK
I've just upgraded to 3.7.1 and WebsiteDefender is reporting the following vulnerability:


Quote:
The Wordpress theme atahualpa from your WordPress installation in / is known to be affected by a security vulnerability.

Vulnerability details
Title WordPress Atahualpa Theme 's' Parameter Cross-Site Scripting Vulnerability
Theme directory /home/waterway/public_html/wp-content/themes/atahualpa367/
Description WordPress Atahualpa theme is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. Atahualpa theme version 3.6.7 is vulnerable; prior versions may also be affected.
Any comments?
  #9  
Old Oct 28, 2011, 05:05 PM
lmilesw's Avatar
lmilesw
 
10,100 posts · Jul 2009
Central New York State USA
Notice the path is for 3.6.7. I had than happen in my test with website defender. I saw some old installs of Atahualpa. If the path if for an older version you don't have installed anymore just click the resolve to see what happens.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #10  
Old Oct 29, 2011, 08:07 AM
qbuster's Avatar
qbuster
 
84 posts · Mar 2010
Alrewas, Staffordshire, UK
Quote:
Originally Posted by lmilesw
Notice the path is for 3.6.7. I had than happen in my test with website defender. I saw some old installs of Atahualpa. If the path if for an older version you don't have installed anymore just click the resolve to see what happens.
I noticed there version difference but I thought it worth while posting that WebsiteDefender judges there is a security issue. I have 'resolve'd it and so far don't have a reaction to 3.7.1.
  #11  
Old Nov 13, 2011, 08:27 AM
MickR
 
22 posts · May 2010
just had a strange prob going from 3.5.3 to 3.7.1...

Uploaded 3.7.1 to server and then activated.
When i went to Theme Options in dashboard i tried clicking on the various links ('Body, Text and Links', 'Style and Configure Layout' etc), but page remained stuck on the 'Start' page, ie: couldn't open the various theme options pages. Reactivated 3.5.3 and all ok again.

Just wondering if anyone has experienced same? I'll have a play around (turn off caching etc), but any tips/ pointers appreciated.

Tx,

Mick.
  #12  
Old Nov 13, 2011, 09:10 AM
MickR
 
22 posts · May 2010
Update to previous forum post.

Turned off caching, wp minify etc, in the faint hope that something there might be affecting 3.7.1 admin. No change, problem still existed. Then uploaded and activated ATA 3.6.4 and that worked fine. Stopping there for the moment.

Wordpress version is 3.2.1, so wondering if there's some conflict between this WP release and the admin functions of the latest ATA release?

If anyone has the same, or a fix, would be interested to hear about it.

Mick.
  #13  
Old Nov 13, 2011, 09:32 AM
juggledad's Avatar
juggledad
 
22,265 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
try temporally disabling your plugins
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #14  
Old Nov 13, 2011, 09:39 AM
MickR
 
22 posts · May 2010
Hi Juggledad,

Thanks for the quick reply, and I just came back in to say found problem (it was my own fault!)

3.7.1 uses jquery in admin pages and i'd accidentally removed the call from wp-includes/script-loader.php (changed to call from Googleapis as that's a compressed version, and I'd got the URL wrong!).

So, all ok and no prob with ATA 3.7.1 and WP 3.2.1

Tx again,

Mick.
  #15  
Old Nov 18, 2011, 08:29 AM
KatyDigg's Avatar
KatyDigg
 
318 posts · Jul 2009
W3C Validation:

ATA 3.6.7 passes W3C Validation (of which I have been very happy with)

whereas

ATA 3.7.1 sadly, fails W3C Validation, fails with 2 errors.
Quote:
Validation Output: 2 Errors

Error Line 206, Column 136: document type does not allow element "table" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag

…"table-layout:fixed;width:100%" cellpadding="0" cellspacing="0" border="0"><tr>



The mentioned element is not allowed to appear in the context in which you've placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you've forgotten to close a previous element.

One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "<a>", "<span>", or "<font>").


Error Line 239, Column 132: document type does not allow element "table" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag

…yle="table-layout:fixed;width:100%" cellpadding="0" cellspacing="0" border="0">



The mentioned element is not allowed to appear in the context in which you've placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you've forgotten to close a previous element.

One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "<a>", "<span>", or "<font>").

206. <table id="my_widget_area" class="bfa_widget_area" style="table-layout:fixed;width:100%" cellpadding="0" cellspacing="0" border="0"><tr>


239. <table id="my_footer_area" class="bfa_widget_area" style="table-layout:fixed;width:100%" cellpadding="0" cellspacing="0" border="0">



__________________
UniServer | WP 4.0 | ThemeFrame 1.2.6 | Montezuma 1.2.2 | ATA 3.7.18
  #16  
Old Nov 18, 2011, 10:14 AM
lmilesw's Avatar
lmilesw
 
10,100 posts · Jul 2009
Central New York State USA
I don't have an answer Katy but I wouldn't be concerned. I used the validator years ago and got frustrated at trying to rid my site of errors. There was apparently something changed in 3.7.1 that kicks out a couple of errors but 2 errors is really low. Try validating many sites and you will get a whole bunch more than that.

I have some simple sites in earlier versions of Atahualpa that validate and some that don't.

Bottom line is if the site is working I'm happy.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #17  
Old Nov 18, 2011, 11:28 AM
juggledad's Avatar
juggledad
 
22,265 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Are you validating with the CSS internal or external?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #18  
Old Nov 18, 2011, 01:17 PM
KatyDigg's Avatar
KatyDigg
 
318 posts · Jul 2009
It's okay guys......thank you for your time ......... I've sorted the issue and now have

ATA 3.7.1. passed W3C validation.

I'm happy
__________________
UniServer | WP 4.0 | ThemeFrame 1.2.6 | Montezuma 1.2.2 | ATA 3.7.18
  #19  
Old Nov 18, 2011, 01:35 PM
lmilesw's Avatar
lmilesw
 
10,100 posts · Jul 2009
Central New York State USA
What did you do Katy? Maybe it could help others.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #20  
Old Nov 18, 2011, 01:44 PM
KatyDigg's Avatar
KatyDigg
 
318 posts · Jul 2009
To be honest, Imilesw, I'm somewhat

as I ought to have remembered from previous versions ... in footer.php

one has to edit out lines 93, 95, 97 and 99.

Then run site on W3C and voila! Validation pass
__________________
UniServer | WP 4.0 | ThemeFrame 1.2.6 | Montezuma 1.2.2 | ATA 3.7.18
  #21  
Old Nov 19, 2011, 01:29 PM
lmilesw's Avatar
lmilesw
 
10,100 posts · Jul 2009
Central New York State USA
Are you referring to the p tags?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #22  
Old Nov 20, 2011, 09:08 AM
KatyDigg's Avatar
KatyDigg
 
318 posts · Jul 2009
Quote:
Originally Posted by lmilesw
Are you referring to the p tags?
Hi Larry, yes, referring to the p tags.
__________________
UniServer | WP 4.0 | ThemeFrame 1.2.6 | Montezuma 1.2.2 | ATA 3.7.18
  #23  
Old Nov 30, 2011, 01:28 PM
Wonderlady
 
2 posts · Jan 2011
Question: I just went to upgrade to 3.7.1 and got a warning that all of my customizations would be removed. Given the highly customizable theme that this is, and I have enjoyed working with it, it seems counterproductive to keep upgrading if I have to redo all of the customizations each time. I am a pretty good Wordpress user in that I can go through the options in the theme and figure out how to customize things. However, a lot of this technical stuff is way over my head.

Be that as it may, is there any workaround to being able to save the customizations or reload them automatically?

Thanks!
Ruth
  #24  
Old Nov 30, 2011, 01:38 PM
lmilesw's Avatar
lmilesw
 
10,100 posts · Jul 2009
Central New York State USA
That is a generic WordPress message as many times when the theme settings are all in the theme itself you will lose them. With Atahualpa you will need to copy images that you uploaded into the images folder and sub folders into the new images folders and sub folders. All the theme settings are in the database so will not be lost.

For the recommended upgrade procedure visit this post. We recommend the manual upgrade method. Then if something isn't quite right you can just switch back to the old version.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #25  
Old Dec 20, 2011, 06:24 AM
gurdain
 
1 posts · Dec 2011
Quote:
Originally Posted by juggledad
try temporally disabling your plugins
Hi there

I have uploaded atahualpa 3.7.3 alongside my existing 3.5.3 installation

When I activate the new one, everything looks fine apart from my breadcrumbs.

When I go to the Atahualpa options I get the same problem you got - I cannot click on any of the tabs - I just get a hash on the URL.

You mentioned something about wp-includes and jquery....I have no idea

I am running WP 3.3 - can someone point me in the right direction. Things were fine on 3.5.3.

Bookmarks

Tags
ata 3.7.1, w3c validation

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atahualpa 3.6.1 released Flynn Old Version fixes and change logs 33 Jul 13, 2012 08:38 PM
Atahualpa 3.7.0 released Flynn Old Version fixes and change logs 6 Oct 5, 2011 02:14 PM
Atahualpa 3.6.7 released (was 3.6.6) Flynn Old Version fixes and change logs 8 May 12, 2011 07:07 PM
Atahualpa 3.5.1 released Flynn Old Version fixes and change logs 46 May 31, 2010 08:27 AM
Atahualpa 3.5.0 released Flynn Old Version fixes and change logs 14 May 27, 2010 04:51 PM


All times are GMT -6. The time now is 09:44 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.