Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating » Old Version fixes and change logs »

Atahualpa 3.7.0 released


  #1  
Old Oct 4, 2011, 04:59 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Looks like we're having another update every day now. All kidding aside, this should be the last one for the next few (not: many) weeks, unless serious issues are found. The next big TODO is: Implement new WP settings API instead of the current proprietary one which is 3 yo old now

3.7.0 has a couple security improvements as requested by WordPress.org

Changelog 3.7.0:

- functions.php, line 873: $homeURL = home_url() -> $homeURL = esc_url( home_url() );
- /functions/bfa_header_config.php, line 281, 283: $bfa_ata['searchbox_text'] -> esc_attr($bfa_ata['searchbox_text'])
- searchform.php, line 1: home_url() -> esc_url( home_url() );
- searchform.php, line 5: the_search_query() -> esc_attr( the_search_query() )


Download Atahualpa 3.7.0 here
  #2  
Old Oct 5, 2011, 11:05 AM
deClench
 
3 posts · Oct 2011
WP 3.2.1, upgrading from Atahualpa 3.6.7 to 3.7.0

The Atahualpa Theme Options section has lost its tabulation. All content is dumped on screen. Other sections seem fine, and front end seems fine.

Tried 3.6.9 and have same issue. 3.6.7 was fine.

Any thoughts? Thanks!
  #3  
Old Oct 5, 2011, 01:29 PM
Webmason's Avatar
Webmason
 
69 posts · Feb 2009
Minneapolis, MN USA
I have an EMERGENCY! I have put up 3.7 and now my whole site front and back end are blank. I don't know what happened but I can't even get in to change it back? Please help a.s.a.p.!

http://www.Tip20.com

Thanks,
Tom
  #4  
Old Oct 5, 2011, 01:32 PM
ChristoPhoto
 
3 posts · Oct 2011
Cornwall, UK
Yeah mine did the same, i just refreshed it a few times and kept reloading the back of the site, then it all came back. perhaps it was updating something in the background that you don't see...
  #5  
Old Oct 5, 2011, 01:43 PM
Webmason's Avatar
Webmason
 
69 posts · Feb 2009
Minneapolis, MN USA
hmmm... mine hasn't come back so far...
  #6  
Old Oct 5, 2011, 01:58 PM
Webmason's Avatar
Webmason
 
69 posts · Feb 2009
Minneapolis, MN USA
Ok, I have fixed it, by uploading a fresh copy of 3.7.0

I'd still like to know what I did wrong. I have done this process many times with no trouble. What in the theme could cause bot the front and admin area to disappear?

Thanks,
Tom

Update:
Looks like others had this problem with editing the functions.php file. I suspect my problem was the same...

Last edited by Webmason; Oct 5, 2011 at 02:17 PM. Reason: update
  #7  
Old Oct 5, 2011, 02:14 PM
awcguy
 
34 posts · Feb 2011
West Virginia
Send a message via AIM to awcguy
Flynn, thank you for the update!

My interest was peaked when you said: The next big TODO is: Implement new WP settings API instead of the current proprietary one which is 3 yo old now

Sounds like
you have a notional idea on future upgrades and fixes. By chance is the enhancement of the logo area to "center" a graphic on the list and The rotating script that is slowing becoming defective has weird bugs for instance which leave behind prior images on rotation.

Could you tell me if those 2 items are in the "Enhancement" and "defect" category?

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atahualpa 3.6.1 released Flynn Old Version fixes and change logs 33 Jul 13, 2012 08:38 PM
Atahualpa 3.6.7 released (was 3.6.6) Flynn Old Version fixes and change logs 8 May 12, 2011 07:07 PM
Atahualpa 3.6.4 released juggledad Old Version fixes and change logs 55 Mar 20, 2011 05:02 AM
Atahualpa 3.5.1 released Flynn Old Version fixes and change logs 46 May 31, 2010 08:27 AM
Atahualpa 3.4.9 released Flynn Old Version fixes and change logs 51 May 12, 2010 10:37 AM


All times are GMT -6. The time now is 04:40 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.