Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Excerpts, Read more, Pagination (http://forum.bytesforall.com/forumdisplay.php?f=20)
-   -   [SOLVED] Span Tag in Post Title screwing with Display in Excerpt Title (http://forum.bytesforall.com/showthread.php?t=15493)

vCopia Sep 25, 2011 08:59 PM

[SOLVED] Span Tag in Post Title screwing with Display in Excerpt Title
 
1 Attachment(s)
I inserted a span tag around a single word in the TITLE of my blog post so it would appear smaller than the rest of the text. The tag works fine for all purposes except when displayed as an excerpt. Then the tag interferes with, I'm guessing, some other preset function or setting.

Here's what is typed into the TITLE line in the Edit Post area:

HTML Code:

Reviews on Clickbank <span style="font-size: 8pt;">(more)</span>
Attached is how that title appears when the post is displayed as an excerpt.

Any way I can work around this so I can keep the tag?

Thanks.

juggledad Sep 25, 2011 09:07 PM

Look at the excerpt options add span to the do not strip

vCopia Sep 25, 2011 10:34 PM

Found it. inserted span begin tag only and saved. Still displayed the same. So set up a class and changed the tag from orig above to one that used class within the span tag. Still the same. Thoughts?

juggledad Sep 26, 2011 04:29 AM

Works fine for me. Do you have all the 3.6.7. patches applied?
  • PATCH 367-01: Odd effects when 'CSS: Compress' = 'Yes'
  • PATCH 367-02 is incorporated in PATCH 367-04
  • PATCH 367-03: PHP errors when adding widget areas in index.php
  • PATCH 367-04: Hovering over a Post/Page title only shows "Permanent Link to"
  • PATCH 367-05: Site Title appended after the 'WordPress SEO by Yoast' title

vCopia Sep 26, 2011 08:33 AM

Yup. Uploaded 'em to the server on 8/14. Even double checked the patch links shared via your references above to be sure I had the same ones. I did.

Suggestions? If helpful, the url is: http://getrichclicknow.com/blog

juggledad Sep 26, 2011 09:49 AM

What SEO options are you using?
are you using the Atahualpa Post options? If so, what do they say?

vCopia Sep 26, 2011 10:11 AM

1 Attachment(s)
I'm not using the Atahualpa Post options. I'm using the "All In One SEO" plugin. In case it helps, I've attached a pdf of that plugin's set up page.

Thank you for your continued support!

juggledad Sep 26, 2011 10:47 AM

in that case, at dashboard->posts->edit->the post in question what is in the 'All in One SEO Pack' title field?

vCopia Sep 26, 2011 11:49 AM

The "All in One SEO Pack" title field shows:

Reviews on Clickbank

Just the above. No other words. No code.

juggledad Sep 26, 2011 11:56 AM

try this, go to ato->Configure SEO->Use Post / Page Options? and set it to 'YES'
then go to the post and go to the Atahualpa Post Options and check the box 'Check to NOT display the Body Title on Single Post or Static Pages' and update the post
then go back to ato->Configure SEO->Use Post / Page Options? and set it back to 'NO'
and look at the post

vCopia Sep 26, 2011 02:20 PM

Awgh! I was really rooting for this fix! But, alas, no change.

juggledad Sep 26, 2011 03:15 PM

can I take a look at the backend? if so send me a PM with an admin ID/pw

juggledad Sep 29, 2011 01:20 PM

1 Attachment(s)
the site looks fine to me in Safari on a Mac
Attachment 1547

vCopia Sep 29, 2011 01:36 PM

I just pulled up http://getrichclicknow.com/blog, moved down the page to view the excerpt titles, and still saw the following:

(more)"> Reviews on Clickbank (more) instead of

Reviews on Clickbank (more)

Did so on my Mac using Safari, Foxfire and Chrome. Since this issue is limited to the title line in an exceprt, and I still see the referenced error, could you please take another look and see if you can help me figure out why the error persists despite the admin setup being correct??

Thanks so much.

juggledad Sep 29, 2011 01:42 PM

Your version of bfa_post_parts.php does not match the original for 3.6.7 or the patched version and that is what is causing the issue

vCopia Sep 29, 2011 02:37 PM

OK... downloaded the patch file for bfa_post_parts.php from this post ( http://forum.bytesforall.com/showthread.php?t=14718 ) and then uploaded it to this location on my server.

/public_html/getrichclicknow/wp-content/themes/atahualpa/functions

went to http://getrichclicknow.com/blog, and found the excerpt still isn't displayed as it is suppose to. So, then, I opeed the patch of bfa_post_parts.php I'd just downloaded and couldn't find the updated code that should have been there (as stated in the patch download post referenced above.

Is there somewhere else I can get the file bfa_post_parts.php ??

juggledad Sep 29, 2011 03:18 PM

did you remember to shut off the caching plugin you have active?

vCopia Sep 29, 2011 04:57 PM

I just cleared the cache being held by the WP-Cache plugin and tried viewing the blog again. Same.
I disabled the WP-Cache plugin and tried viewing again. Same.
Now that it is disabled, I uploaded the bfa_post_parts.php file again, (in case that is what you meant), and viewed again. Same.

juggledad Sep 29, 2011 05:13 PM

I made a change to your version, try it now

vCopia Sep 29, 2011 05:28 PM

Cookin' with gas, as me mum use to say! Woo-hoo!

Thanks so much for spending such a chunk of time on matter. Quick Q: was the version change to the entire theme, or just the bfa_post_parts.php file (want to back up file(s) separately just in case).

juggledad Sep 29, 2011 07:19 PM

it was just a small change in bfa_post_parts.php
(are you on a mac using lion?)

vCopia Sep 30, 2011 07:17 AM

Much thanks for everything! And, I'm using a Mac OS X, ver 10.6.8. No lions here. Only leopards.

Feel free to mark this post as resolved anytime.


All times are GMT -6. The time now is 07:21 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.