Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

Amazon Astore link does not work


  #1  
Old Mar 26, 2009, 01:04 PM
pbravin
 
20 posts · Feb 2009
I created an astore.php file containing the following:

________________
<?php
/*
Template Name: Amazon aStore
*/
?>

<iframe src=”http://astore.amazon.com/deaexpundcon-20″ width=”90%” height=”1000″ frameborder=”0″ scrolling=”yes”>

<?php get_footer(); ?>
_______________

Then created a wordpress page identifying this file as a template

and when i go to this page, the following message appears

______________
The requested URL /%E2%80%9Dhttp://astore.amazon.com/deaexpundcon-20%E2%80%B3 does not exist.
_______________

What did I do that was not done right?

Thanks

Phil
  #2  
Old Mar 26, 2009, 06:21 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
The closing </iframe> is missing, also you'd probably need

PHP Code:
 <?php get_header(); ?>
above the iframe

PHP Code:
 <?php
/*
Template Name: Amazon aStore
*/
?>
 <?php get_header(); ?> 
<iframe src="URL-HERE" width="99%" height="1000" scrolling="no" frameborder="0"></iframe>
<?php get_footer(); ?>
But you'll probably need some parts from the head of index.php as well so it'd be best to make a copy of index.php as amazon-astore.php and replace everything between get_header and get_footer with your single line of iframe code
  #3  
Old Apr 27, 2009, 03:19 AM
eipi
 
2 posts · Apr 2009
Hello, Flynn.
I've created a page with iframe as #2.
It works by Fire-fox with other contents (Ads and side bar), but not by IE. Other contents Ads,sidebar footer can't be displayed using iframe by IE when I select only right bar only. Please advise.
  #4  
Old Apr 27, 2009, 08:38 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
If it works in FF but not in IE then you probably have spaces or special characters in your iframe URL
  #5  
Old Apr 28, 2009, 03:11 AM
eipi
 
2 posts · Apr 2009
Flynn,
Many tks, It's been solved.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] cant seem to get this too work help please! link in header image sine Header configuration & styling 5 Jun 22, 2009 10:05 AM
How to stop address URL link from popping up when the cursor is on a link? araneum Post-Kicker, -Byline & -Footer 0 Apr 11, 2009 07:00 PM
Link not a link in Cat or Tag Mode Steve_T Excerpts, Read more, Pagination 1 Feb 8, 2009 02:05 PM
"Remove 2nd footer link to BFA" doesn't work Flynn Atahualpa 3 Wordpress theme 0 Dec 13, 2008 05:47 PM


All times are GMT -6. The time now is 08:09 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.