Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

[SOLVED] Page Menu Problem in IE


  #1  
Old Sep 9, 2010, 12:12 PM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
I'm having some problems with how my page menu shows in IE. Lots of overlapping. It's ok in Firefox though. Below is the code I used, hopefully it isn't too messed up. I know the bar color doesn't go all the way to the sides but I've found the solution to that and will change it. I've attached 2 graphics so you can see how it looks on both of them. It's the upper overlap that I'm concerned about.

What do i need to do to correct the problem in IE?

div#menu1 ul.rMenu {
background: transparent;
border: none;
}

div.widget ul li {
padding: 1px 5px 1px 14px !important;
background: url('<?php bloginfo('template_directory'); ?>/images/bullets/gray-arrow.gif') no-repeat 0 4px;
}
div.widget ul li a:hover {
text-decoration: underline;
}
/* ================================================ */
/* Page menu background */
/* ================================================ */
div#menu1 {
height: 0px;
margin-top:0px;
background: 62250f;
}
/* ================================================ */
/* Page Menu item's background and border */
/* ================================================ */
div#menu1 ul.rMenu {
background: 62250f;
border: 62250f; 5px;
}
/* ================================================ */
/* Page Menu item */
/* ================================================ */
ul.rMenu li a:link,
ul.rMenu li a:hover,
ul.rMenu li a:active,
ul.rMenu li a:visited,
ul.rMenu li {
background: 62250f; !important;
color: #df9c32 !important;
}
/* ================================================== */
/* CSS for setting menu padding */
/* ================================================== */
ul.rMenu li {
padding: 0px 12px 0px 12px
}
ul.rMenu-ver li {
padding-top: 0px 12px 0px 12px
margin-top: 0px 0px 0px 0px;
}

Last edited by sleenie; Sep 9, 2010 at 09:47 PM.
  #2  
Old Sep 9, 2010, 12:47 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
First I would just like to clean up what I initially see and go from there.
The lines that I Changed are in red. The border syntax needs to be in the order of size, style, color. I don't know that any of these changes will fix your issue but there were some semicolons missing and/or in wrong spots.

div#menu1 ul.rMenu {
background: transparent;
border: none;
}

div.widget ul li {
padding: 1px 5px 1px 14px !important;
background: url('<?php bloginfo('template_directory'); ?>/images/bullets/gray-arrow.gif') no-repeat 0 4px;
}
div.widget ul li a:hover {
text-decoration: underline;
}
/* ================================================ */
/* Page menu background */
/* ================================================ */
div#menu1 {
height: 0px;
margin-top:0px;
background: #62250f;
}
/* ================================================ */
/* Page Menu item's background and border */
/* ================================================ */
div#menu1 ul.rMenu {
background: #62250f;
border: 5px solid #62250f;
}
/* ================================================ */
/* Page Menu item */
/* ================================================ */
ul.rMenu li a:link,
ul.rMenu li a:hover,
ul.rMenu li a:active,
ul.rMenu li a:visited,
ul.rMenu li {
background: #62250f !important;
color: #df9c32 !important;
}
/* ================================================== */
/* CSS for setting menu padding */
/* ================================================== */
ul.rMenu li {
padding: 0px 12px 0px 12px
}
ul.rMenu-ver li {
padding-top: 0px 12px 0px 12px;
margin-top: 0px 0px 0px 0px;
}
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Sep 9, 2010, 01:24 PM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Thanks. I have changed those now. I had already changed some of them after I sent the post but not all. That hasn't changed anything though. IE still shows the same.
  #4  
Old Sep 9, 2010, 07:33 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Could you export your setting via ATO>Import/Export Settings and attach to a reply (use the paper clip icon)? I need to see this in a live site.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Sep 9, 2010, 08:25 PM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Sure...here it is. Thanks. Any assistance is greatly appreciated.
  #6  
Old Sep 9, 2010, 08:39 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
It wasn't attached sleenie
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old Sep 9, 2010, 09:48 PM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Well.... I'll try again. Thx

Last edited by sleenie; Sep 10, 2010 at 07:49 AM.
  #8  
Old Sep 9, 2010, 10:49 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
The big problem was with this section of CSS Inserts. I took it out and things started working better.
HTML Code:
/* ================================================ */
/* Page menu background */
/* ================================================ */
div#menu1 {
height: 0px;
margin-top:0px;
background: #62250f;
}
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #9  
Old Sep 10, 2010, 07:48 AM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Larry,

It does look much better now. What was the problem with that particular insert? I was trying to follow Juggledad's cheat sheet. I learn something new every site I do it seems.

Thanks so much for your help.
  #10  
Old Sep 10, 2010, 10:15 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
It was just messing with CSS somehow. I just saved the page of your site and started ripping out CSS section by section and that was the one that fixed it. I suspect it had something do to with the 0px.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #11  
Old Sep 10, 2010, 01:00 PM
sleenie
 
291 posts · May 2009
Texas and New Mexico
Send a message via Skype™ to sleenie
Thanks Larry...I really appreciate it. I didn't want to play with Larry's code but I guess i should learn to do so more. I'm setting up a site where I can doing some importing and more testing on my own. Good thing they don't charge at W3 Schools for general access.

I think when I move next month I'm going to take a class on CSS.

Again, thanks.

Bookmarks

Tags
ie page menu problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with %page-right menu positioning NicGuestJelley Page & Category Menu Bars 5 Jul 30, 2010 04:12 PM
[SOLVED] Problem! I cann't turn off the link to first level parent page in Page Menu majia Page & Category Menu Bars 2 Jul 3, 2010 09:35 AM
Problem changing the background color of just one of the page menu items\buttons Thomas Page & Category Menu Bars 3 Jun 6, 2010 05:38 PM
Page Menu Bar Problem charliesjones Page & Category Menu Bars 4 Mar 26, 2010 08:07 AM
Intermittent problem with page menu bar bunching up wardrob Page & Category Menu Bars 6 Jan 30, 2010 12:57 PM


All times are GMT -6. The time now is 08:30 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.