Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

Change to colour handling in H1, H2, etc in CSS Inserts.


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Aug 4, 2010, 10:48 AM
coop42
 
13 posts · Jul 2009
Responding to a previously closed post about H1, H2, etc colour formatting change.

In previous versions, a simple definition of the colour (h1 {color: #FF000; }) in the CSS Inserts was sufficient.

Now we have to add class= to the definition?

So we'd have to code the CSS as...

H1.red { color: #FF0000; }

And then code each of the tags as <H1 class="red"> rather than the simpler <H1>?

That's a bit tedious.

Just curious, was there a particular reason for this, or is it an "unintended consequence" of something else?

Can it go back to the old/simpler way of doing it?

coop
  #2  
Old Aug 4, 2010, 11:28 AM
lmilesw's Avatar
lmilesw
 
10,100 posts · Jul 2009
Central New York State USA
I just put some code like what you mention in CSS Inserts and then wrapped some text in a page in an h1 tag and all worked as expected. Where did you see that we have to add class= to the definition?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Aug 4, 2010, 11:43 AM
coop42
 
13 posts · Jul 2009
I was referring to the post "[SOLVED] H1, H2, H3 color codes lost in WP 3.0.1". In it the poster (c12281) stated that he/she solved the same problem I was having with colours of the H1, etc by adding class to the CSS.

I had a simple definition of H1 in the CSS inserts, and it didn't change the colour of the header.

h1 {
padding: 0;
margin: 0;
font-size: 1.9em;
line-height: 1.5;
font-weight: normal;
color: #365DA0;
}

and in the page, the code is simply...

<h1>This is the title</h1>

but this has no effect on the colour of the header.

When I changed the CSS in the CSS Inserts to:

h1.colour {
padding: 0;
margin: 0;
font-size: 1.9em;
line-height: 1.5;
font-weight: normal;
color: #365DA0;
}

and the related code in the page to

<h1 class="colour">This is the title</h1>

The colour of the header changed as specified (and as expected). The first CSS doesn't work, the second one does.
  #4  
Old Aug 4, 2010, 12:09 PM
coop42
 
13 posts · Jul 2009
OK, that's just weird.

Before lunch, the basic CSS didn't work. Not in IE, FF, Opera, Chrome or Safari.

After lunch, after replacing the class code with the basic code, it worked.

I didn't restart the computer, or even the browsers.

I hate it when that happens.

Arrgh! Now I don't know what the problem was.
  #5  
Old Aug 5, 2010, 06:07 AM
juggledad's Avatar
juggledad
 
22,265 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
do you have a caching plugin active? Never try to develop with a caching plugin active and make sure to delete the cache or your changes may take some time to show up.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Aug 5, 2010, 11:33 AM
coop42
 
13 posts · Jul 2009
Nope, and the effect was the same on my WinXP laptop, a Win7 machine, an iPhone and an iPad.

So it was something very, very odd.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
why Fields in the Atahualpa 3.3.3 does not expand? css inserts, html inserts krystyna New Versions, & Updating 3 Oct 28, 2010 12:22 PM
HTML/CSS Inserts Jurgen Estanislao Forum How-To 0 Aug 3, 2010 07:40 AM
ADD HTML/CSS Inserts -- 3.5.1 --- Need to remove default CSS Inserts ortho New Versions, & Updating 0 Jun 23, 2010 03:17 PM
Css Inserts not working?? mcphoto Sidebars & Widgets 3 Jan 5, 2010 09:15 AM
[SOLVED] why Fields in the Atahualpa 3.3.3 does not expand? css inserts, html inserts ppat2 New Versions, & Updating 3 Jun 2, 2009 05:41 PM


All times are GMT -6. The time now is 11:14 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.