Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

[SOLVED] Sidebar Outside Loop--What Happened?


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jul 26, 2010, 01:57 PM
epsymp
 
37 posts · Jul 2010
Hey,

I've been working on the sidebars for awhile.

The atahualpa right sidebar was fine, except i wanted to change it for different pages.
i registered the extra sidebars i needed, and added a "get sidebar" to one of the templates.
for some time i'd been struggling with styling it...maybe the "td id=right" managed it fine...
i can't tell right now because i had to troubleshoot this morning and replace some files in the ftp.

since then nearly all of the sidebars, even the ones i haven't been trying to customize are showing up outside the loop.
any ideas what's going on, or how to fix it?

here's an example of the problem:
http://toadthejournal.com/

for some reason this page is still how it was before:
http://toadthejournal.com/?page_id=370


i'd appreciate any help.
i'm pretty new to web design, so let me know if i should clarifying something.
e

Last edited by epsymp; Jul 26, 2010 at 02:04 PM.
  #2  
Old Jul 26, 2010, 02:53 PM
juggledad's Avatar
juggledad
 
22,403 posts · Mar 2009
OSX 10.10.1 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I'm unclear as to why you feel you need to register new sidebars? Aren't the two to a side enough? You already have the ability to exclude them from pages if you want and if you need to have different widgets in the sidebar for different pages, there are plugins that allow you to do with little hassle (see widget logic)

so what are you trying to do, there may be an easier way to do it.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jul 26, 2010, 04:15 PM
epsymp
 
37 posts · Jul 2010
hey, thanks,

widget logic appeared to me after having messed around, and on your suggestion i'll try it out once i get this solved.

at this point all of the pages that are based on a template have a misplaced sidebar, whether they're using a "new" sidebar or not, and i can't figure out where the code is that's causing it.

in short, i can't simply undo this myself.
  #4  
Old Jul 26, 2010, 08:18 PM
juggledad's Avatar
juggledad
 
22,403 posts · Mar 2009
OSX 10.10.1 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
So remove the template or rename it without access to the code you are using, there is no way to guess what you might have done. Stick a bunch of php echo statements in to trace the logic,
HTML Code:
Echo 'i am here now<br>';
use the <br> for line breaks
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oh no what happened! Dani808 Customization, Design, Programming... 14 Jul 30, 2010 02:28 PM
What happened to my Blog title text? wordsnak Header configuration & styling 16 Mar 18, 2010 06:33 PM
[SOLVED] Help!!! What happened???? Antonino Giglio Header configuration & styling 2 Mar 8, 2010 07:07 PM


All times are GMT -6. The time now is 02:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.