Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Marketplace » Customization, Design, Programming... »

Oh no what happened!


  #1  
Old Dec 7, 2009, 07:43 PM
Dani808's Avatar
Dani808
 
22 posts · Dec 2009
Hawaii
I followed your instructions in the gold forum for changing the footer and I am getting the following error


Parse error: syntax error, unexpected '}' in /home/content/d/s/t/dstolfi808/html/halaukalama/wp-content/themes/atahualpa/functions.php on line 139

It wont even let me in the editor or anypart of the site anymore to fix it!
  #2  
Old Dec 7, 2009, 07:57 PM
juggledad's Avatar
juggledad
 
23,551 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what post are you refering to?
you must have added or removed a '}' which is causing the problem

copy and paste teh 10 lines before and after 139 and indicate the line numbers.

If you are in a rush, just upload a fresh copy of the functions.php and you should be all set.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Dec 7, 2009, 08:52 PM
Dani808's Avatar
Dani808
 
22 posts · Dec 2009
Hawaii
the one about deleting out the wordpress references in the footer.

It wont let me back in at all to the editor and I did upload the functions php file but it isn't helping. When I hit edit or even try to preview my site I get that error. Why wouldn't it update the php file? That should have fixed it I don't get it.
  #4  
Old Dec 8, 2009, 12:58 AM
juggledad's Avatar
juggledad
 
23,551 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If your still getting the error, then you haven't uploaded the right copy or have a cache issue. Delete function.php and try the site before uploading it. You should see a different error if it has been deleted
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jan 5, 2010, 09:02 AM
kreodig
 
2 posts · Jan 2010
if you have access via FTP, please check write permissions on this file
  #6  
Old Feb 3, 2010, 03:20 PM
victorm
 
11 posts · Feb 2010
juggledad is right, had the same problem because we serve some of the files straight from the frontend (nginx) and after each change of this kind we need to restart the process to kill the live cache. tricky if you run fastcgi on the same box.

Last edited by victorm; Feb 3, 2010 at 03:36 PM.
  #7  
Old May 30, 2010, 11:25 PM
TakeAimJK
 
2 posts · May 2010
Hi,

I'm a brand newbie to the Wordpress game, and I've made my first cock-up, and now my site is down, with the following message:Parse error: syntax error, unexpected ';' in E:\Domains\t\takeaimnz.com\user\htdocs\wp-content\themes\atahualpa\functions.php on line 139 because my changes were obviously not up to scratch. I thought they were!

I can't get into wp-admin at all.

I understand that the best way to fix this is to upload a new copy of functions.php, but I don't have ftp access, and my host is inaccessible. Is there another way?

With fingers crossed,

JK
  #8  
Old May 31, 2010, 04:48 AM
juggledad's Avatar
juggledad
 
23,551 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Well, if you can't get into wp-admin and you don't have ftp access, then you are going to have to contact your host for help. Removing the Atahualpa folder will resolve this since you will revert back tothe default theme
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old May 31, 2010, 07:41 AM
Murias
 
4 posts · May 2010
Amsterdam
I'm also very new to Wordpress and the same thing happened to me when I tried to remove the footer. Maybe the instructions could be a little clearer for people who aren't familiar with php.
  #10  
Old May 31, 2010, 08:03 AM
juggledad's Avatar
juggledad
 
23,551 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Murias - if you upload a fresh copy of footer.php you should be back up.

I'm not sure how much clearer the instructions could be
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; May 31, 2010 at 08:11 AM.
  #11  
Old Jun 1, 2010, 04:07 PM
TakeAimJK
 
2 posts · May 2010
I thought so. I'll see what can be done.

Perhaps a warning - "Make sure any changes you make are accurate, because incorrect changes here can..." etc. It would have made me have second thoughts!!

Thanks for the confirmation. And for all your contributions!
  #12  
Old Jul 30, 2010, 12:15 PM
203voices
 
3 posts · Jul 2010
California
I am having a similar problem.

Attempting to access my site, including the wp-admin, gives me the problem:

Parse error: syntax error, unexpected T_STRING in /home/twozerw2/public_html/wp-content/themes/atahualpa/functions.php on line 148

I had been trying to work on the footer as well. I am very new to all of this. How can I edit footer.php if I can't even get to wp-admin?

Thanks.
  #13  
Old Jul 30, 2010, 12:42 PM
203voices
 
3 posts · Jul 2010
California
Update: I was able to get into the code through my ftp. The code I altered looks like this:

function footer_output($footer_content) {
$footer_content .= '<br />;
//insert code here
return $footer_content;
}


I put the //insert code here in to remind myself where the code I pulled out was. Is that my problem?
  #14  
Old Jul 30, 2010, 02:26 PM
lmilesw's Avatar
lmilesw
 
10,173 posts · Jul 2009
Central New York State USA
I would put the code you took out back in or replace the functions.php with a fresh one. You can get instructions for what you are trying to do in the Gold Forums with a $20 donation. It wouldn't be right for me to give you the instructions when others have paid for them as I did when I was starting out with this theme.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #15  
Old Jul 30, 2010, 02:28 PM
203voices
 
3 posts · Jul 2010
California
Thanks a lot. I was able to get in through my ftp and fix the damage. Appreciate the support.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] I love Atahualpa, but what happened to my nav menu formatting? viewdesigninc Page & Category Menu Bars 0 Apr 10, 2009 06:59 PM


All times are GMT -6. The time now is 12:31 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.