Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

[SOLVED] 404 error with wp-print and wp-email


  #1  
Old Dec 25, 2008, 11:00 PM
Alexi
 
20 posts · Dec 2008
Oceanside, CA
Excellent theme. Thank you for the hard work. Clap, clap, clap! (already sent money )

Using Wordpress 2.7 and the latest download of Atahualpa 3.1.3. with updated (2.40) wp-email, wp-print plug-ins I am getting a 404 message (“Not Found - Sorry, but you are looking for something that isn't here.”) when I click on the footer entries “Print This Post” and “Email This Post”.

The post filename string being generated is good . . . up to the “/print/” at the end.

Should I be hunting for a mis-setup on my part . . . or could it be a bug?

Here is the string being generated:

http://www.beautyprpro.com/merry-chr...ew-year/print/

Thanks again.

Alex Irving
  #2  
Old Dec 26, 2008, 06:22 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
It's doing that in WP 2.7 with permalinks on. WP 2.7 doesn't seem to add a trailing slash to permalinks. It may be related to that. I am looking into it.
  #3  
Old Dec 26, 2008, 06:35 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
It works with the new versions (2.40) of both WP-Print and WP-Email http://lesterchan.net/portfolio/programming/php/
  #4  
Old Dec 26, 2008, 06:53 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Edit: I just saw that you ARE using version 2.40 of the plugin. After you installed the new versions you'd have to save the permalinks again. That's a general requirement for these plugins and not related to the theme.

You also seem to miss the trailing slash in your permalinks (unless you left them out on purpose). I was able to get them back by disabling and re-activating a few plugins and saving the permalinks again. I could not track it down to a specific plugin though. It may have been the outdated WP-Print/WP-Email plugins or not. It does not seem to be caused by the theme. The missing slash used to happen with the default theme too
  #5  
Old Dec 26, 2008, 08:59 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
The missing trailing slash on WP 2.7 permalinks seem to be caused by the WPG2 plugin
  #6  
Old Dec 26, 2008, 09:57 AM
chris's Avatar
chris
 
39 posts · Dec 2008
essen@nrw.de
Did you read the instructions ...

... http://lesterchan.net/wordpress/readme/wp-print.html
... http://lesterchan.net/wordpress/readme/wp-email.html

Quote:
You Need To Re-Generate The Permalink (WP-Admin -> Settings -> Permalinks -> Save Changes)
  #7  
Old Dec 27, 2008, 05:29 PM
Alexi
 
20 posts · Dec 2008
Oceanside, CA
Thank you both (Flynn and Chris) I am doing my homework. I appreciate the concern.

Alex
  #8  
Old Dec 27, 2008, 08:28 PM
Alexi
 
20 posts · Dec 2008
Oceanside, CA
Trailing slashes OK and all works like a charm after following suggestions. RTDM (Read the darn manual <g>).

Thank you

Alex
  #9  
Old Dec 28, 2008, 12:38 AM
chris's Avatar
chris
 
39 posts · Dec 2008
essen@nrw.de
you are welcome ... I have had the same issue last week and was about to start a thread ... but I found the instructions and it solved the problem

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to customize 404 error page? wfzimmerman Atahualpa 3 Wordpress theme 21 Oct 2, 2016 06:50 PM
404 error when reader submits comment beanfair Comments, trackbacks & pings 4 May 7, 2010 04:45 AM
How to add support for WP-Print, to print pages/posts? AndrewRH Atahualpa 3 Wordpress theme 1 Jun 2, 2009 04:13 PM
Subscribe by Email Error jrotem RSS, Feeds & Subscribing 0 May 11, 2009 04:07 AM
404 error seneque Atahualpa 3 Wordpress theme 1 Apr 11, 2009 10:20 PM


All times are GMT -6. The time now is 04:04 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.