Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

[SOLVED] Problem of internal link


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Apr 11, 2010, 06:36 AM
shus
 
38 posts · Dec 2009
Hello!

I have created intrenal link to go to some positon inside a post.

Tags inside html is correct:
<a href="#BaganII-GreatStupas"></a>
<a name="BaganII-GreatStupas"></a>

Link in addres panel has the such view:

http://webshus.ru/?p=1710#BaganII-GreatStupas

But when I click the text with link (it is placed at top of the post) - notihg occurs.

What is a case of the problem?

Thank in advance.
  #2  
Old Apr 11, 2010, 09:17 AM
juggledad's Avatar
juggledad
 
22,172 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
there is no <a name="BaganII-GreatStupas"></a> on that page
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #3  
Old Apr 11, 2010, 09:22 AM
shus
 
38 posts · Dec 2009
This is a part of html from the post (13 row from top)

<em><span style="font-size: small;"><strong><span style="font-size: medium;"><a href="#BaganII-GreatStupas">2. Великие ступы</a></span></strong></span></em><span style="font-size: medium;"> </span><span style="font-size: medium;"> </span><span style="font-size: medium;"> </span><span style="font-size: medium;"> </span>

This is lower (begin of page 2)

<h1><strong><em><span style="font-size: medium;"><a name="BaganII-GreatStupas"></a>2. Великие ступы</span></em></strong></h1>

Last edited by shus; Apr 11, 2010 at 10:26 AM.
  #4  
Old Apr 11, 2010, 12:33 PM
juggledad's Avatar
juggledad
 
22,172 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
<a href="#BaganII-GreatStupas"> will only link to a <a name="BaganII-GreatStupas"> on the current page. Since <a name="BaganII-GreatStupas"> is on page 2 it can't be linked to.
If you put that link code on page 2 it will work.
__________________
Give a person a solution, you fix one issue, teach a person how to solve their problem you enable them forever.
Juggledad | Forum Moderator/Support
  #5  
Old Apr 12, 2010, 03:53 AM
shus
 
38 posts · Dec 2009
Solved!
Thank you.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Link problem in text widget gina31 Sidebars & Widgets 9 Jan 23, 2013 01:27 PM
Compressed CSS, internal or external? paulae Header configuration & styling 10 Oct 18, 2009 01:01 PM
[SOLVED] RB Internal links not working with ATA 3.3.3 paulae Plugins & Atahualpa 2 Jun 6, 2009 01:49 PM
Does theme work with RB Internal Links? paulae Plugins & Atahualpa 3 Mar 11, 2009 05:07 PM
Dreamweaver homepage link problem Dealer Bicycles Atahualpa 3 Wordpress theme 4 Jan 31, 2009 04:38 PM


All times are GMT -6. The time now is 10:11 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.