Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

Compressed CSS, internal or external?


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Oct 18, 2009, 09:00 AM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I don't quite understand something. In the options/Configure CSS and JS, one of the options is to compress CSS or not. What happens if you compress CSS and also have CSS inline? Or can CSS be compressed only with the external CSS option?

I've been trying to make the front page load faster, so I keep trying different combinations of inline/external/CSS compression, then checking the result on pingdom. The results often aren't very logical.

And oddly, I just tried larchmontgazette.com there, and got a total load-time of 6.4 seconds. I tried greenwichtime.com, a local news site not far from here, and got 21 seconds, yet that site seemed to load much faster when going there by browser, after dumping the cache. It's all very confusing.

I'd like to know what combination of CSS and JS inline/external and CSS compression you are all using, and what kind of load-times you're getting.
  #2  
Old Oct 18, 2009, 09:07 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
If you set CSS to Compress and Inline, you will see it with all the extra white space removed.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Oct 18, 2009 at 09:10 AM.
  #3  
Old Oct 18, 2009, 09:19 AM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Ah. OK. I wonder if that should make much difference in the loading time.

Just noticed in the source code: Bad Behavior 2.0.30 run time: 18.432 ms

Bad Behavior was added by a consultant who rescued us after we were hacked. I guess 18 milliseconds isn't too much, right? But when I read http://www.bad-behavior.ioerror.us/, I wonder if we need it. You can't just post a comment with link spam in it; we have to approve comments. And we have Askismet running. Do you think BB is necessary? I just checked, and found this in the BB report: Bad Behavior has blocked 3728 access attempts in the last 7 days.
  #4  
Old Oct 18, 2009, 11:08 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
As to taking it out, think of this. If it wasn't in, you wuld have hade to moderate 3728 comments last week. How long would it have taken someone to moderate them? How much of a load would that have put on the database (inserts of the comments, then the deletes)?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Oct 18, 2009, 11:20 AM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
We never had so many comments to moderate before BB was installed. I think most of those attempts are bots who can't get past our anti-spam math question anyway. I'm just wondering if having BB in place does itself cause a slowdown of page loading.
  #6  
Old Oct 18, 2009, 11:38 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
everything adds into the time it takes to render the page.
I just added 10 plugins and 10 widgets and WP284/Ata344 now shows 327 queries in 1.84 seconds
I added 8 posts and get 334 queries in 2.44 seconds
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Oct 18, 2009, 11:49 AM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
You're looking at the speed from the footer code? Have you tried it at tools.pingdom.com? I'm curious if you'll see a big difference there.
  #8  
Old Oct 18, 2009, 12:45 PM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
JD, I tried something else. I'm beta-alpha testing WP 2.9-rare, at http://www.skilovers.com/wp/

I get 177 queries. 0.517 seconds in the footer (visible), and 3.1 seconds at pingdom. The site is on the same host as my news site, in Utah.
  #9  
Old Oct 18, 2009, 12:49 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I'm running these test on my local machine
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Oct 18, 2009, 12:53 PM
paulae's Avatar
paulae
 
1,332 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Yes, I know....isn't there a way to view your local machine over the net by putting the IP address in the URL field? I don't know much about this, obviously.
  #11  
Old Oct 18, 2009, 01:01 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I might be able to to do it. If I have some time. I think I have to change a setting in my router...I'll think about it.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
External CSS not working? tangch00 Header configuration & styling 1 Aug 21, 2009 04:46 AM
[SOLVED] RB Internal links not working with ATA 3.3.3 paulae Plugins & Atahualpa 2 Jun 6, 2009 01:49 PM
[SOLVED] Widgets showing compressed in IE and normal in Firefox wmoura Sidebars & Widgets 2 Jun 4, 2009 07:36 AM
Does theme work with RB Internal Links? paulae Plugins & Atahualpa 3 Mar 11, 2009 05:07 PM
Error 500 - Internal server error gpeery Installing & running WordPress 5 Mar 1, 2009 06:05 PM


All times are GMT -6. The time now is 12:17 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.