Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Broken Theme - Stylesheet is missing - Error upon initial upload


  #1  
Old Mar 5, 2009, 07:16 PM
rontorica
 
14 posts · Mar 2009
Hello, I am very excited to start using this new theme. I created a folder called atahualpa3 under themes. I uploaded atahualpa32.zip into this folder.

When I returned to WP to activate the theme, I got this error message.

Broken Themes

The following themes are installed but incomplete. Themes must have a stylesheet and a template.
Description
Stylesheet is missing.

Can you please help?

Thanks,
Veronica
  #2  
Old Mar 5, 2009, 07:33 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
You need to extract the zip file on your desktop computer first. This should create a folder /atahualpa/ or /atahualpa3/ or something like that on your computer. Upload that folder to wp-content/themes/ so that you end up with /wp-content/themes/atahualpa/ on your web hosting account
  #3  
Old Mar 5, 2009, 07:44 PM
rontorica
 
14 posts · Mar 2009
Thanks for getting back to me. When I tried that I received a long list of error messages. I will do it again and post them right away.
  #4  
Old Mar 5, 2009, 07:50 PM
rontorica
 
14 posts · Mar 2009
When I unzip the file and then upload them to the directory, the theme shows up on my WP screen. However, when I try to activate it, I get this list of error messages.

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_header_config.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 22

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_header_config.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 22

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_hor_cats.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 23

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_hor_cats.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 23

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_hor_pages.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 24

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_hor_pages.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 24

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_footer.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 25

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_footer.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 25

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_recent_comments.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 26

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_recent_comments.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 26

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_popular_posts.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 27

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_popular_posts.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 27

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_popular_in_cat.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 28

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_popular_in_cat.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 28

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_subscribe.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 29

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_subscribe.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 29

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_text_widget.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 30

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_text_widget.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 30

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_search_widget.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 31

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_search_widget.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 31

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_calendar_widget.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 32

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_calendar_widget.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 32

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_comment_walker.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 33

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_comment_walker.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 33

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions/bfa_theme_options.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/atahualpa3/functions.php on line 130

plus more
  #5  
Old Mar 5, 2009, 08:05 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Looks like you have not uploaded /atahualpa3/functions/

You'll need to upload the whole /atahualpa3/ directory, with everything that's inside, files and subdirectories
  #6  
Old Mar 5, 2009, 08:18 PM
rontorica
 
14 posts · Mar 2009
functions.php is uploaded. I uploaded the entire file that was unzipped. I just tried to delete functions.php and reload it. Same long list of error messages.
  #7  
Old Mar 5, 2009, 08:51 PM
rontorica
 
14 posts · Mar 2009
I just loaded another theme and it worked fine. However, I don't like it as well as yours. I hope we can figure out why I am having trouble. Thanks for your time.
  #8  
Old Mar 5, 2009, 09:49 PM
rontorica
 
14 posts · Mar 2009
I even tried uploading an older version of your theme and got similar errors. It seems to be the .php files causing the problems. I tried to view these files and downloaded PhotoParade as they seem to be that type of files. However, photoparade couldn't open them.
  #9  
Old Mar 6, 2009, 08:42 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Hope you won't mind me poking in -- Flynn must be out buying groceries or something

You can view/edit the .php files using a plain, text editor like Notepad, Notepad++ or NoteTab Pro

(suggest you do NOT use a wordprocessor like MS Word as they tend to want to include formatting in the files they create/save and WordPress files do NOT work after such treatment)

At this point, I'd suggest you get into your FTP program and completely delete the /atahualpa folder and its contents from the directory /wp-content/themes/ up on the server.

Then, do a fresh un-zip of atahualpa.3.2.zip and copy the entire resulting folder "/atahualpa" (and all the files it contains) up to your server and into the /wp-content/themes/ folder.

It sounds like you've been gaining experience installing themes while having all this trouble. Starting afresh with the Atahualpa un-zip, upload and activation should guarantee success!
  #10  
Old Mar 6, 2009, 10:56 AM
rontorica
 
14 posts · Mar 2009
Hello, I really appreciate your willingness to help me.
I did as you said. I deleted the folder and the contents. I downloaded the file again. I unzipped the file (I am using a trial version of winzip if it matters). I transferred all the unzipped files using select all to a new folder. I then uploaded the entire contents of that folder to a newly created folder under themes.

I received a long string of error messages when I tried to activate the theme.

However, this time I really looked at the error messages in detail. I found the files they were referring to and reloaded the files. That cleared two of the error messages.

It doesn't seem to work on the files:
functions.php or header.php

Here is a sample of the error messages I am getting:
Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/Atahualpa.3.2/functions/bfa_postinfo.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/Atahualpa.3.2/header.php on line 772

Fatal error: Call to undefined function bfa_header_config() in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/Atahualpa.3.2/header.php on line 884

Warning: include(/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/Atahualpa.3.2/functions/bfa_hor_cats.php) [function.include]: failed to open stream: No such file or directory in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/Atahualpa.3.2/functions.php on line 23

Warning: include() [function.include]: Failed opening '/home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/Atahualpa.3.2/functions/bfa_hor_cats.php' for inclusion (include_path='.:/usr/local/php5/lib/php') in /home/content/e/l/o/eloheimchannel/html/wordpress/wp-content/themes/Atahualpa.3.2/functions.php on line 23


I am not sure WHAT that actually means. But, it seems like the file functions.php is missing some components. I have reloaded the files that it seems to be missing like bfa_hor_cats.php. Every time, they were already present and I was just replacing them. It didn't work anyway.

I hope you can help!
  #11  
Old Mar 6, 2009, 10:59 AM
rontorica
 
14 posts · Mar 2009
After I upload I show that I have 309 files and 1,282,133 bytes in the folder that is supposed to be running the theme. Does that match yours?
  #12  
Old Mar 6, 2009, 11:56 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
1.) The preview problems you mention might be related to the dots you have in your folder name atahualpa.3.2. I remember that the Wordpress preview system doesn't like dots in there.

2.) You mention Photoparade. That is an image editor and doesn't have to do anything with PHP or Atahualpa. Don't touch the files with that. You might have messed up a few files while opening them in a image editor and saving them again. If you want to view files, use a plain text editor (not Word) such as the default text editor of Windows. But for now, don't even view the files to avoid any errors at that stage.

3.) Make sure all non-image files are uploaded in ASCII mode in your ftp program.

4.) Download atahualpa from either http://wordpress.bytesforall.com or
http://wordpress.org/extend/themes/atahualpa
(and not from anywhere else)

5.) Make sure you have Wordpress 2.3 or newer. 2.2 should work but I have not tested for a while. 2.1 and older will definitely not work.

I guess your issue is related to 1) or 2) or both
  #13  
Old Mar 6, 2009, 12:06 PM
rontorica
 
14 posts · Mar 2009
Hi Flynn,
Thanks for getting back to me.

1.) The preview problems you mention might be related to the dots you have in your folder name atahualpa.3.2. I remember that the Wordpress preview system doesn't like dots in there.


I will try this although yesterday I didn't use any dots in my file name and had the same problem

2.) You mention Photoparade. That is an image editor and doesn't have to do anything with PHP or Atahualpa. Don't touch the files with that. You might have messed up a few files while opening them in a image editor and saving them again. If you want to view files, use a plain text editor (not Word) such as the default text editor of Windows. But for now, don't even view the files to avoid any errors at that stage.


I didn't open the files, they wouldn't open. Plus, I did a brand new download this am so even if that was the problem I don't think it would apply now.


3.) Make sure all non-image files are uploaded in ASCII mode in your ftp program.

I didn't make any sort of specifications when uploading. I am using filezilla. I will see if I can make that specification.

4.) Download atahualpa from either http://wordpress.bytesforall.com or
http://wordpress.org/extend/themes/atahualpa
(and not from anywhere else)


So far, I have tried both places and gotten the same results. I even tried an older version and had the same problems.


5.) Make sure you have Wordpress 2.3 or newer. 2.2 should work but I have not tested for a while. 2.1 and older will definitely not work.


I just bought a domain and hosting from GoDaddy yesterday and did their one click download. I would imagine they are using the latest version, but I will check.

Thanks again, I will check in after I try these ideas.
  #14  
Old Mar 6, 2009, 12:17 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
2, 3, 4 and 5 don't seem to apply then. I have no other idea at the moment as Wordpress/Atahualpa/Web Server seems to know the location of the files and successfully include some of them but not the others.
  #15  
Old Mar 6, 2009, 12:39 PM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Quote:
Originally Posted by rontorica
...<snip>...
I did as you said. I deleted the folder and the contents. I downloaded the file again. I unzipped the file (I am using a trial version of winzip if it matters). I transferred all the unzipped files using select all to a new folder. I then uploaded the entire contents of that folder to a newly created folder under themes. ...<snip>...

2nd message: <snip>...After I upload I show that I have 309 files and 1,282,133 bytes in the folder that is supposed to be running the theme. Does that match yours?
It might be hard to see that it's happened but when you unzip the file "atahualpa.3.2.zip" it creates a folder called "atahualpa" that contains ALL the theme files. If you're seeing all the unzipped files and folders you might try going "up" one directory level so as to see the containing "atahualpa" folder.

Then, rather than going into the folder, selecting all and uploading, JUST select the folder \atahualpa and upload it into /wp-content/themes/ on theGoDaddy server.

Re the number/size of a correct installation of Atahualpa: I've been making changes, uploading image files and the like so the number and size of the files I have could never agree with what you see. For the record, I checked the "properties" of the Atahualpa folder (right click on the folder name in Windows Explorer) right after unzipping and I'm told there are 311 files in 10 folders (1.23 MB (1,294,420 bytes)).

Okay! I see that Flynn is back on the case so I'm gonna duck out at this point -- you're in good hands! Good Luck!
TTFN Jim
  #16  
Old Mar 6, 2009, 02:25 PM
rontorica
 
14 posts · Mar 2009
Hi Jim and Flynn,
I tried the folder name with no dots. That didn't work.

I tried Jim's idea and uploaded the folder. That didn't work either.

BUT I DID GET IT TO WORK!!!!!!!!!!!!

The key was when I asked how many files Jim had. He gave me the number of files and said that he had 10 folders. I wasn't showing any folders on my end. Using Winzip to extract the files put all the files into one long list rather than in the folders.

I downloaded easyzip and used it to unzip the files. Easyzip kept the files in folders. That was the answer.

I am really happy that I stuck with this and I am so grateful for all of your help.

Wow! Now I get to build my site!

THANKS THANKS THANKS

Veronica
  #17  
Old Mar 6, 2009, 02:48 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Glad to hear it's working

So Winzip has a default setting of extracting everything into the same folder. Nice one, will keep that in mind when we have a mysterious problem here again.

7zip is the ZIP program I use

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] WPMU/Buddypress theme error aahkendall Atahualpa 3 Wordpress theme 2 Jul 15, 2009 10:22 AM
Missing Save Changes button again, and missing footer area paulae Sidebars & Widgets 1 May 13, 2009 09:46 AM
I need to upload larger images the PaperTemptress Atahualpa 3 Wordpress theme 1 May 4, 2009 10:32 PM
Completely broken WP - Please help Humphrey New Versions, & Updating 1 Apr 26, 2009 05:22 AM
Theme Options Menu Doesn't Work + error + spanish tranlation (Beta) ghenghiz Languages & Translations 6 Apr 4, 2009 07:36 PM


All times are GMT -6. The time now is 10:34 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.