Wordpress Themes - WP Forum at BFA
There will be no more development for Atahualpa (or any other theme), and no support. Also no new registrations. I turned off the donation system. I may turn the forum to read only if it gets abused for spam. Unfortunately I have no time for the forum or the themes. Thanks a lot to the people who helped in all these years, especially Larry and of course: Paul. Take care and stay healthy -- Flynn, Atahualpa developer, Sep 2021

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Comments showing after creating new post page


  #1  
Old Mar 17, 2010, 07:35 AM
talbin
 
19 posts · Feb 2010
Hello:

I created a new static home page and new post page based on the excellent instructions on this page. However, once I did this, even though I have things set to not show comments, the comments are now showing. Before I did this, comments were hidden.

On the Wordpress Settings/Discussions, I have unclicked the box for "Allow Comments". When I create or edit a post, the box for "Allow Comments" is unchecked. The new post page is set to Private, as I only want people to access the comment via a link (the comment is actually an event description).

I must be missing something. How do I eliminate comments from showing on posts given this new configuration?

Thanks!
  #2  
Old Mar 17, 2010, 02:32 PM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what version of Atahualpa and WP?
What is the url showing the issue?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 18, 2010, 05:36 AM
talbin
 
19 posts · Feb 2010
Thanks for replying, Juggledad. I really appreciate your looking into this.

Atahualpa: 3.4.6
WP: 2.9.2
Example 1 - full comments
Example 2 - "comments are closed"

Before the change, nothing at all was visible in the comment area.

Also, both these posts existed before I changed the post/page stuff - I haven't changed them at all. But I did try adding a completely new post after the change - came up with full comments. I also tried deleting a pre-change post and re-entering it, but no dice - also had full comments.

Last edited by talbin; Mar 18, 2010 at 05:38 AM. Reason: added information
  #4  
Old Mar 18, 2010, 05:57 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I'm getting a NOT FOUND on the first example
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Mar 18, 2010, 06:12 AM
juggledad's Avatar
juggledad
 
23,765 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I just reread the post and you say you are making posts 'private'
Quote:
Private posts are visible only to you (and to other editors or admins within your site)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Mar 18, 2010, 08:38 AM
talbin
 
19 posts · Feb 2010
Hmm, not sure what's happening. The pages I linked show in WP Admin, but not on the site.

Try this one instead

Also - I made the post page private, not the posts themselves. My goal is to show clickable events (using Kirian O'Brien's calendar plugin) - allowing the user to see the full post for clicking, but not allowing access to a typical "blog page" per se.

Thanks, Juggledad.
  #7  
Old Mar 19, 2010, 06:31 AM
talbin
 
19 posts · Feb 2010
Okay, I managed to get things looking the way I want them, but I have a feeling my fix isn't really "the" fix - I think something may still be not quite right with the underlying code. However, I'm not a programmer so I could very well be wrong about that.

Here's what I did:

ATO --> Edit Post/Page Info Items : I deleted everything in the three Footer areas

ATO --> Style & Configure Comments --> Comments are Closed Text : I deleted what was in the box.

It still seems that unchecking the WP Settings/Discussion option for showing comments should work, even if the blog posts have been moved off the Home page and onto another page that I created, but I did find a workaround.

Thanks!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Page Navigation and Comments not showing with Code sleizure Center area post/pages 6 Jan 18, 2010 03:55 PM
Post title not showing up on single post page metalbuzz Post-Kicker, -Byline & -Footer 2 Jul 17, 2009 12:11 PM
On comments page for post Leave a Reply and comments are white daisy24 Comments, trackbacks & pings 4 Feb 19, 2009 06:40 AM
Archives not working, comments not showing and a page question ! aliferste Comments, trackbacks & pings 8 Dec 14, 2008 03:16 AM


All times are GMT -6. The time now is 02:49 PM.


Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.